2ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

Debian GNU/Linux スレッド Ver. 22

1 :login:Penguin:04/03/09 22:07 ID:9tluYtM1
過去ログは多分>>2-5あたり

Debian GNU/Linux スレッド過去ログ検索 (namazuTamer 氏提供)
http://debian.dtdns.net/2ch-debian/

Debian のよくある質問や関連サイトはこちら (namazuTamer 氏提供)
スレ立て時のテンプレも以下にあります。
http://debian.fam.cx/

     * 質問の前には必ず参照の事 *

2 :login:Penguin:04/03/09 22:08 ID:9tluYtM1
前スレ
Debian GNU/Linux スレッド Ver. 21
http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1074000711/
http://pc.2ch.net/test/read.cgi/linux/1074000711/

過去ログ
00 http://cocoa.2ch.net/unix/kako/970/970632381.html
01 http://cocoa.2ch.net/linux/kako/980/980163775.html
02 http://cocoa.2ch.net/linux/kako/992/992323048.html
03 http://pc.2ch.net/linux/kako/999/999724231.html
04 http://pc.2ch.net/linux/kako/1006/10062/1006278960.html
05 http://pc.2ch.net/linux/kako/1011/10117/1011766081.html
06 http://pc.2ch.net/linux/kako/1015/10151/1015174417.html
07 http://pc.2ch.net/linux/kako/1018/10184/1018445203.html
08 http://pc.2ch.net/linux/kako/1020/10209/1020967965.html
09 http://pc.2ch.net/linux/kako/1024/10240/1024031354.html
10 http://pc.2ch.net/linux/kako/1027/10274/1027442221.html
11 http://pc.2ch.net/linux/kako/1030/10301/1030178687.html
12 http://pc.2ch.net/linux/kako/1033/10330/1033049225.html
13 http://pc.2ch.net/linux/kako/1036/10361/1036184754.html
14 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1040637707/
15 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1045176646/
16 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1051790435/
17 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1056885910/
18 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1061600500/
19 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1065374560/
20 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1069631907/

3 :login:Penguin:04/03/09 22:08 ID:9tluYtM1
誰も立てないから立てたぞ。

4 :login:Penguin:04/03/09 22:14 ID:+6z8wirA
>>1
乙でした


5 :login:Penguin:04/03/10 00:04 ID:a+I015m0
>>1
オツカレー

久々に役に立ちそうなネタハケーン

Linuxカーネル2.6で実現するACL
http://www.itmedia.co.jp/enterprise/0403/06/epn01.html

6 :login:Penguin:04/03/10 00:22 ID:kzOOw7Wz
前スレ>>>999

次のリリースは4ではなくて3.1になる模様。
リリースクリティカルバグも減ってきてるし、そう遠くないうちにリリースするのでは。

Debian 「sarge」リリース情報
http://www.debian.org/releases/sarge/

7 :login:Penguin:04/03/10 01:57 ID:vDE+OKG4
ムトゥ氏はおつかれなのか、NNRPなんか喰っちゃってますよ。
暴食厳禁。おだいじに。

つーか、うまいんか?それ?

8 :login:Penguin:04/03/10 05:18 ID:Pvh2Niel
Mebius PC-MV1-C1Eにsargeのkernel-image-2.6.3-686を入れてみた。深く考えずに。
・マルチユーザーモードでブートしなくなった(リブートはできる)。
ブートシーケンスの途中で画面が真っ暗になり、Ctrl-ALt-Del以外を受け付けない。
いまだに2.6系をまともに動かせていない…。1ヵ月ほど待ってみよっと。


9 :login:Penguin:04/03/10 09:03 ID:mopXW4ee
sargeはwoodyのbf2.4のように、kernel-2.4を基本とするbf2.6選択可能な
ものとなるだろうか?
リリースまでにkernel-2.6系の安定化が間に合うだろうか?

10 :login:Penguin:04/03/10 16:55 ID:pq72avVw
現在、apt-getでインストール出来るカーネルの最新は
2.4.18-1でよろしいでしょうか?

11 :login:Penguin:04/03/10 16:58 ID:vxlx7wkN
>>10
2.4.25-1と2.6.3-1
sources.listがインスコcdしか見てねえんじゃないの?

12 :login:Penguin:04/03/10 20:38 ID:ge5GJADO
sargeなんですけど、ここ数日のうちに
ls -l とかの結果がおかしいことに
気づきました。ファイルの合計数が
異常です。ファイルがあるのにゼロと
出たり、10ファイル程度のところで80とか
出たり。

fsこわれたかと思ってreiserfsckしてみても
異常なし。他何を調べたらよいでしょうか?


13 :login:Penguin:04/03/10 20:45 ID:k5J7EGwf
>>12
合計数がおかしいのに、file systemは関係ない。
UNIXのfile systemにdirectoryのfile数のinterfaceはない。
lsがおかしいだけだから、とりあえず気にするな。

14 :12:04/03/10 20:49 ID:ge5GJADO
別パーティションのvfatマウントしても
同じ現象なんで、やはりfs側ではないっぽいです。

何か分かりませんがとりあえずlsの含まれるパケジの状態は

ii coreutils 5.0.91-2 The GNU core utilities

です。問題を発見する前後でこのパケジのアップグレードは
なかったと思うのですが...


15 :12:04/03/10 20:51 ID:ge5GJADO
>>13
ありがとうございます。気にしなくてもほぼ
問題なく動いてそうなのですが、ひとつだけ
それが原因ぽい問題がありまして。。

wanderlustというメーラーで見ているinboxに
メッセージがあるのに空と認識されるという。


16 :login:Penguin:04/03/10 20:51 ID:k5J7EGwf
>>14
はは、おれもおかしいわ、5.0.91-2。
始めて気付いた。というか-lの時の合計数いらんよ…

17 :12:04/03/10 22:31 ID:ge5GJADO
>>15
wanderlustの件は関係ありませんでした。
wlスレで独り言で解決しました。

>>16
気にしないことにします。どうもでした。


18 :login:Penguin:04/03/10 22:51 ID:fhWLD+ef
ls -l の「合計」って、割り当てられた block の数だと思うけど。
file の数じゃなくて、大きさの合計。

19 :login:Penguin:04/03/10 23:29 ID:k5J7EGwf
え、そうなの?

http://www.opengroup.org/onlinepubs/007908799/xcu/ls.html
には、512-byte unitsのblock数って書いてあるね。

$ ls -l | head -1
合計 7916
$ ls -sd .
4 ./
$ ls -dl .
drwxr-xr-x 2 foo bar 4096 2004-03-10 19:49 ./

だからいずれにせよおかしいみたいだけど。




20 :login:Penguin:04/03/11 00:50 ID:NjQIP1cJ
ディレクトリの中身見せないと意味ないだろ…

21 :login:Penguin:04/03/11 01:06 ID:/yDh0VN8
え? 4096byteで、「合計7916」は明らかにおかしいでしょ。
(ちなみに11ファイル)

22 :login:Penguin:04/03/11 02:24 ID:ETrpCswt
-d で出てる大きさは、その directory 自体に割り当てられた領域の大きさなんじゃないかな。
こっちはだいたい file の数で決まるみたいだけど。

file の大きさは全部でどれくらい?
11個で 4MB くらいあったら「合計」は正常っぽいけど。

23 :login:Penguin:04/03/11 07:53 ID:NjQIP1cJ
放置したほうが良さそうだ

24 :login:Penguin:04/03/11 09:38 ID:VHxNBai2
放置でござるか……。

25 :login:Penguin:04/03/11 10:45 ID:82+A644L
KDE3.2.1のdebian向けkde-i18n-jaはいつごろに?


26 :login:Penguin:04/03/11 11:13 ID:shz+ui/D
sidのgnome使いはcapplets-dataを忘れずに。

27 :login:Penguin:04/03/11 11:27 ID:EKSHvjz2
Debian 3.0R2 non-us のCD1イメージを落としてインストールしたのですが、tasksel で xwindow が選択できません。
なぜでしょうか?

黒い画面嫌です。でも apt-get 使わないで tasksel で入れたいの。

28 :login:Penguin:04/03/11 11:30 ID:2Msytf1V
>>27
> でも apt-get 使わないで tasksel で入れたいの。

なぜ?

29 :login:Penguin:04/03/11 12:58 ID:ZCYkGRrQ
>>27
はい、どうぞ。
http://www.atmarkit.co.jp/flinux/rensai/linuxtips/130conslcolor.html

30 :login:Penguin:04/03/11 13:12 ID:nSyI6bvN
>>27
apt lineぐらい晒せよ
どうせcd-romしか入っていないってオチだろ?

31 :login:Penguin:04/03/11 16:27 ID:EKSHvjz2
>>28
なんか完璧に入りそうな気がするからです。あくまで気分の問題です。

>>29
そんなコマンド知りませんでした。ありがとう!

>>30
apt-lineは

deb ftp://ftp.jp.debian.org/debian woody main contrib non-free
deb ftp://ftp.jp.debian.org/debian-non-US woody/non-US main contrib non-free
deb ftp://ftp.jp.debian.org/debian-jp woody-jp main contrib non-free
deb ftp://ftp.jp.debian.org/debian woody-proposed-updates main contrib non-free
deb ftp://ftp.jp.debian.org/debian-non-US woody-proposed-updates/non-US main contrib non-free
deb http://security.debian.org/ woody/updates main contrib non-free

こんな感じです。ネットワークももちろん生きていて、ftpサーバからパッケージ取ってきてます。

32 :login:Penguin:04/03/11 16:35 ID:CcfgVuOD
>>31

一般ユーザーで tasksel してるというオチはないですか?
apt-get でやるのが嫌なら dselect や aptitude はどうでしょ

33 :login:Penguin:04/03/11 16:44 ID:wdfyMxNR
aptのパッケージの情報をクリアするコマンドってないでしょうか?
「apt-get clean」見てあった!と思ったらダウンロードしたパッケージそのものを消す
コマンドみたいだし・・・

34 :login:Penguin:04/03/11 16:46 ID:QNGcldii
>>33
どういうこと?

35 :login:Penguin:04/03/11 17:07 ID:ZEkV9buU
>>31
woodyのtaskにはX Window Systemが存在しない気がするのは、俺だけか?
apt-lineをwoodyにしたらtaskになくなっちゃったよ。

どっちにしろsidのtaskでも x-window-systemしか入れないから、
# apt-get install x-window-system
が正解な気がする。


36 :33:04/03/11 17:08 ID:wdfyMxNR
「/etc/apt/source.list」からとあるサイトを消したのですが
「apt-get update」すると、消したサイトへ繋ぎに行ってしまうので
なにかをクリアしないと駄目なのかと思った次第です。

37 :login:Penguin:04/03/11 17:14 ID:ZEkV9buU
>>36
「/etc/apt/sources.list」
から消してないのはなぜ?


38 :login:Penguin:04/03/11 17:23 ID:nSyI6bvN
>>36
apt lineから消したという幻覚を見ただけ

39 :33:04/03/11 17:37 ID:wdfyMxNR
>37
?消してますよ。

>38
以前も同じようなことがあって、ファイルかコマンドからか忘れましたが
何かを消した記憶があるんです。
でも最近、憑かれてるんで白昼夢かもしれません。
機器のそばに行ったら見直してみます。

40 :login:Penguin:04/03/11 17:44 ID:ZEkV9buU
>>39
よく見てくれよぅ。
ファイル名 違うだろぉ。

typoじゃなければ、複数書いてあって、
かたっぽしか消してないってのがありそう。

どっちにしろapt-getはsources.listに書いてある所にしかつなぎに行かないから、
システムが認識しているsources.listに書いてあるんだろ。

41 :login:Penguin:04/03/11 17:56 ID:rvcDgFJA
woody r2使ってます。
インスコ後にロケールの設定しなおして日本語使えるようにしたつもりです。
一般ユーザーではメッセージなんかが日本語で表示されるし、日本語ファイルとか扱えるんですが、
rootではメッセージが英語のままで日本語の入力も受け付けません。
rootのロケールは変わらないんでしょうか。

42 :login:Penguin:04/03/11 18:01 ID:QNGcldii
>>41
変える必要あるの?

43 :login:Penguin:04/03/11 18:11 ID:5SXwbIF3
debian-usersでもlanguage-envがらみの話が出てきたばかりじゃん。
日常的な作業をrootでするなって。


44 :login:Penguin:04/03/11 18:26 ID:LyCvTIe/
むしろ、rootを英語にしておく事でrootを嫌うようになり、
rootで作業してても、一般ユーザにすぐ戻る習慣が出来ると思いなさい。

45 :41:04/03/11 18:33 ID:rvcDgFJA
>>42-44
どーもです。いや、ちょっと気になっただけなんですがね。
クリティカルなアカウントだからかなー、とは思ったりしましたけど。
rootで日常作業するのは俺も嫌いですよ。

debian-users…読み返してみまつ。

46 :login:Penguin:04/03/11 19:45 ID:khTW7eeE
>>45
おそらく君が気にしているよりずっと気にして作ってあるので
最初のうちはそれに従いつつ、あとで熟考してみるとよろし。

わかんない時分にあれこれ考えるのは時間の浪費だったりする。

囲碁や将棋の戦法と同じ。


47 :login:Penguin:04/03/11 21:16 ID:lk14zgWi
漏れはmanだけ
alias man='LANG=ja_JP.eucJP man'
ってやってる

48 :login:Penguin:04/03/11 21:23 ID:shz+ui/D
rootへのlogin、suはしないのが普通。
sudoで困ることある?


49 :login:Penguin:04/03/11 21:28 ID:QNGcldii
>>48
一般ユーザで cd できないディレクトリで作業したいとき
ちょっと困る。

50 :login:Penguin:04/03/11 21:38 ID:khTW7eeE
>>49
NTFSマウントしたときなんかそう。

51 :login:Penguin:04/03/11 21:40 ID:kmGNgh8j
ところで apt-listchanges は日本語ロケールで実行すると死にますね。
root で日本語ロケール使うなという人は、
sudo する時
LANG=C sudo apt-get upgrade
こうするんですか?

52 :login:Penguin:04/03/11 22:08 ID:shz+ui/D
>>50
mountするときにuid,gid,umaskを設定できるよ。

>>51
> ところで apt-listchanges は日本語ロケールで実行すると死にますね。

うちでは死なないなぁ。
apt-listchanges 2.49

53 :login:Penguin:04/03/11 22:10 ID:5SXwbIF3
>>51
別に死なないけど。CJKCodecs or JapaneseCodecsは入れてる?
ちなみに漏れはrootでなく一般ユーザにmailするように設定してる。


54 :login:Penguin:04/03/11 22:27 ID:7o7Xp9Ea
全コマンドを sudo から実行できるようにさせてるのと
su で root になって実行するのって何が違うんだろ

55 :login:Penguin:04/03/11 22:42 ID:YfDDk12f
>>54
sudo だと、/var/log/auth.log に
誰がどんなコマンドを発行したか記録されていくね。
su だと、誰が root になったかが記録される。

全コマンドに権限与えたとしても、何したか追跡できる分
sudoの方がよいと思うけど



56 :login:Penguin:04/03/11 22:50 ID:V0TrHBcT
>>54
>>49


57 :login:Penguin:04/03/12 00:20 ID:RslDtoxv
>>54
sudo bashすれば同じ、かな?

58 :login:Penguin:04/03/12 00:40 ID:OVgT7EWa
>>53
python2.3-japanese-codecs とかそんなやつだな。

59 :51:04/03/12 00:40 ID:MD/oOBfW
>>53
ありがとうございます。
python2.3-cjkcodecs 入れたら不死になりました。

60 :login:Penguin:04/03/12 01:50 ID:lUPIa08x
>>26
サンキュ。助かった。
でも後遺症がデカい…。

61 :33:04/03/12 09:25 ID:nBzPM49q
>40
書きこみはtypoです。
で、帰宅して電源入れてapt-getしてみたら直ってました。
やっぱり幻想だったみたいです。失礼しました

62 :login:Penguin:04/03/12 09:32 ID:+0T77S+C
GDMで指定ユーザ自動ログオンを設定したら、
ログオン画面を飛ばすようになって(当たり前)、設定を解除できなくなった。

どうすれば元に戻せる?

63 :login:Penguin:04/03/12 10:28 ID:lPoC0ilE
>>64
/etc/gdm/gdm.conf

AutomaticLoginEnable=false

64 :login:Penguin:04/03/12 11:54 ID:MRD/wElk
>>63
俺か!

65 :login:Penguin:04/03/12 14:15 ID:mhFFSZdv
>>62
>GDMで指定ユーザ自動ログオンを設定したら、
> ログオン画面を飛ばすようになって(当たり前)、設定を解除できなくなった。
>
> どうすれば元に戻せる?

sudo gdmconfig というのもアリアリ

66 :login:Penguin:04/03/12 14:31 ID:fqBi/qET
なんか最近 apache_1.3.29.0.2-? のバージョンの上がり方が速いような

67 :login:Penguin:04/03/12 16:08 ID:5mqnibVm
カーネルを2.6系にしたので、コンソールで sudo dpkg-reconfigure xserver-common とし、
Xサーバのnice値を0にしたのですが、Xを起動しターミナルでtopの表示を見ると
XFree86のnice値が-10のままでした。
nice値を0にしたいのですが、どうすればいいでしょうか?

68 :login:Penguin:04/03/12 16:32 ID:MD/oOBfW
2.6 系にしたことと X の nice を 0 にしたいというのはどう関係するんですか?

69 :login:Penguin:04/03/12 17:02 ID:5mqnibVm
>>68
sudo dpkg-reconfigure xserver-commonをすると、nice値を設定する前に、
Xサーバのnice値についての説明が表示されます。
その説明の日本語訳の一部に、

"nice" 値として知られているプロセスの優先度をデフォルトより高い値に設定することで、
X サーバのパフォーマンスが向上することは広く知られています。
(省略)
シングルユーザワークステーションにおいては、-10 をデフォルト値とすると良いでしょう。
(省略)
Linux カーネルバージョン 2.6 (および "O(1) スケジューラ" が実装されて以降の 2.5 シリーズ)
では上記は真と言えません。そのようなシステムでは、Xサーバの nice 値は 0 に設定すべきです。

と書かれているからです。

70 :login:Penguin:04/03/12 17:13 ID:MD/oOBfW
なるほど。説明ありがとう。

debconf で設定した場合は
ここに nice の値が書かれるみたいです。
/etc/X11/Xwrapper.config


71 :login:Penguin:04/03/12 17:36 ID:q2VSkqDD
すみません質問です。woody (3.0)基本部分のみ無事インストール完了したのですが、
2点で悩んでいまして再インストールを何度かこころみています。
1、TASKSELの一覧でX-WINDOWSが見当たらない時がある。
2、日本語環境パッケージインストール途中で、CANNAのインストール時に
  必ず、止まる(30分ほど待ちましたが変わらず)

ソースの問題かと初め思いまして、APTソース元を変更などもしてみましたが
変わらず。
なにか考えられることはございますでしょうか?

72 :login:Penguin:04/03/12 17:41 ID:++M80f7W
>>71
1、>>35

73 :login:Penguin:04/03/12 17:48 ID:5mqnibVm
>>70
教えていただいたファイルを手動で書き換えてやると、nice値0で起動しました。
ありがとうございました。


74 :71:04/03/12 18:13 ID:q2VSkqDD
>72さんありがとうございます。
インストール後、後から入れるで、OKなようですね。
# apt-get install x-window-system 

無事できましたーx-windowの設定も終わって無事KDE表示がされました!!
あとは日本語化だけです。
赤帽難民なのでなんとかDebianに切り替えたいのです。(T∀T


75 :login:Penguin:04/03/12 18:46 ID:mhFFSZdv
d-i インスコレポ
http://www.mithril-linux.org/~henrich/debian/d-i_0301/

結構大変そうだな。

76 :login:Penguin:04/03/12 18:51 ID:9pNwvM17
debian-installer-demoってどうやって使うの?

# d-i-demo
Setting up the chroot in /tmp/debian-installer-demo.2043 ..
Entering the installer ..
/usr/sbin/d-i-demo: chroot exited with status code 1
Installer exited. Cleaning up the chroot ..
umount: ./proc: マウントされていません
/usr/sbin/d-i-demo: could not unmount /tmp/debian-installer-demo.2043/proc; leaving /tmp/debian-installer-demo.2043
umount: /tmp/debian-installer-demo.2043/proc: マウントされていません
/usr/sbin/d-i-demo: /tmp/debian-installer-demo.2043/proc is still mounted!

こんな感じになっちゃうんだけど?

77 :login:Penguin:04/03/12 19:13 ID:nd1XeHz2
>>75
乙カレー、と言いたい。

78 :login:Penguin:04/03/12 19:48 ID:+0T77S+C
>>63
>>65

ありがとうございました。無事戻せました。でも…

79 :login:Penguin:04/03/12 20:05 ID:++M80f7W
でも、何だよ。

80 :login:Penguin:04/03/12 21:19 ID:MD/oOBfW
>>75
こういうの、
debian は一旦インスコするとめったに入れ直さないから、
貴重なレポだね。

81 :login:Penguin:04/03/12 21:20 ID:0gdjz3Tn
>>71
2、
apt-getで止まるのかい?
プロキシ使ってたりする?

82 :login:Penguin:04/03/12 21:55 ID:sv9NFvWO
>>80
まったくだ。

83 :login:Penguin:04/03/12 22:31 ID:1k0IFh5H
>>80
debianってなんでめったに再インストールが必要にならないの?

84 :login:Penguin:04/03/12 22:42 ID:9pNwvM17
>>83
どんな時に再インストールするの?


85 :login:Penguin:04/03/12 22:54 ID:sWDVomnN
sid使ってたけど嫌になってwoodyに戻したいとき、とか。

86 :71:04/03/12 23:00 ID:q2VSkqDD
>81さんレス感謝です。
今まで、インストール時のtaskselの時に、[*] japanese environment選択すると
インストール中にCANNAのとこで止まっていました。プロキシは使っておりません。
とりあえず、
# apt-get install kinput2-canna canna 
したところ無事インストールできました。ありがとうです。
現在はKDEの日本語設定に四苦八苦してますが、なんかだんだん環境ができあがって
きてて、楽しいです。なんとか赤帽から移行できそう(^^;
しかし、apt-getは便利ですね!!

87 :login:Penguin:04/03/13 00:52 ID:agsgnNtN
kde-i18n-ja_3.2.1 マダーチンチン

88 :login:Penguin:04/03/13 05:00 ID:aPUCoE2l
sidでupgradeしたら、以下のメッセージが表示されうまくアップグレード出来ませんでした。

Preparing to replace libxft-dev 2.1.2-5 (using .../libxft-dev_2.1.2-6_i386.deb) ...
diversion of /usr/X11R6/include/X11/Xft/Xft.h to /usr/X11R6/include/X11/Xft/Xft1.h by libxft-dev
Removing `diversion of /usr/X11R6/include/X11/Xft/Xft.h to /usr/X11R6/include/X11/Xft/Xft1.h by libxft-dev'
dpkg-divert: rename involves overwriting `/usr/X11R6/include/X11/Xft/Xft.h' with different file `/usr/X11R6/include/X11/Xft/Xft1.h', not allowed
dpkg: error processing /var/cache/apt/archives/libxft-dev_2.1.2-6_i386.deb (--unpack):
subprocess pre-installation script returned error exit status 2
Errors were encountered while processing:
/var/cache/apt/archives/libxft-dev_2.1.2-6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

このエラーを解決するには、どうすればいいのでしょうか?


89 :login:Penguin:04/03/13 05:06 ID:jHAbt7wA
libxft-dev is broken, check the bts

90 :88:04/03/13 07:49 ID:ateiAiYL
>>89
すみません。
BTSを見てきます。ありがとうございました。

91 :login:Penguin:04/03/13 08:21 ID:lPeK1DK5
今後フロッピーブートってなくなるの?

92 :login:Penguin:04/03/13 08:21 ID:lPeK1DK5
↑フロッピーから起動してのインストールってことです

93 :login:Penguin:04/03/13 09:24 ID:Ga/ax+Lv
なくなる方向であるのは間違いないと思うが。

94 :login:Penguin:04/03/13 10:22 ID:qi2xWyop
>>85
ttp://debian.fam.cx/index.php?Tips#content_1_2

95 :login:Penguin:04/03/13 10:39 ID:yLmgHaUW
>>91
フロッピー自体使われなくなるからな

96 :login:Penguin:04/03/13 11:06 ID:UkZzU8dz
ついにコンビニからも消えたからな。

97 :login:Penguin:04/03/13 11:09 ID:Hl8fvFvq
sidのhotplugやばい。
boot出来なくなったよ、、、。

98 :login:Penguin:04/03/13 11:18 ID:cnreYnnx
>>97
とりあえず^Cすれ。

99 :97:04/03/13 11:28 ID:Hl8fvFvq
>>98
ども。
助かりました。
とりあえず、hotplugをdowngradeしました。


100 :login:Penguin:04/03/13 16:20 ID:nDXuVD3g
Woodyを入れて、hdparmをbackportsからapt-getしたのですが、自分で/etc/init.d/hdparmの
設定が必要かと思いきや、どうやら自動で設定されてるみたいなんですが
これはbackportsからapt-getしたためでしょうか?
公式から落とした場合は設定が必要なのでしょうか?

101 :login:Penguin:04/03/13 16:24 ID:U3Xjw9wn
入れ替えてみりゃいいじゃん。

102 :login:Penguin:04/03/13 22:37 ID:PB3ZB7zl
>>97
0.0.20040311-2 ですね。
うちのばやい、再起動後、突然USB接続のモデムが認識されなくなってビックリ。
>>97さんのカキコのおかげでhotplugの問題だと気付きました。

BTSを覗いてみたら、バグ報告はすでに上がってますね。
しかし、このバージョンひどいぞ。

103 :login:Penguin:04/03/13 23:07 ID:nexF1ghv
キター----------(・∀・)y---------!!!

kde-i18n-ja for KDE 3.2.1 by kmuto

deb http://www.debian.or.jp/~kmuto/kde ./


104 :login:Penguin:04/03/14 02:51 ID:u132MrYS
>>97
サンクス。漏れも助かった。
UkaiDialy 見たら hotplug 0.0.20040311-3 を
うpしたみたいだったので、入れてみたけど
まだ完全じゃないみたい。
102の言う通り此のバージョン酷杉。

105 :login:Penguin:04/03/14 11:09 ID:6d5IXBiC
>>104

> UkaiDialy 見たら hotplug 0.0.20040311-3 を
> うpしたみたいだったので、入れてみたけど
> まだ完全じゃないみたい。

 いまupgradeしたら-5が入ったぞ


> 102の言う通り此のバージョン酷杉。

 sidだろ、久々の地雷なんだし楽しめよ(藁

106 :login:Penguin:04/03/14 14:30 ID:1sgC14Mr
 ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄」
―――――――――――――‐┬┘
                        |
       ____.____    |
     |        |        |   |
     |        | ∧_∧ |   |
     |        |( ´∀`)つ ミ |
     |        |/ ⊃  ノ |   |   debian
        ̄ ̄ ̄ ̄' ̄ ̄ ̄ ̄    |
                        |
FreeOSで激しくおなにー

107 :login:Penguin:04/03/14 15:10 ID:GExF2ocW
                                ∧iii∧、 ナニカオチテター
                               (´∀` ミ
                               とdebianとヰ)
                               (_(_,J

108 :login:Penguin:04/03/14 16:54 ID:hBI5Fpe8
>>104
sid使いがこの程度でガタガタぬかすな、と。

109 :login:Penguin:04/03/14 17:10 ID:oxI6bThl
WoodyにbackportsにあるMozilla1.6を入れたいのですが
Mozilla1.6に必要なGTK2が無いために入れることが出来ません。
backportsにはGNOME2も無いし、どうやって入れたら良いのでしょう?

110 :login:Penguin:04/03/14 17:25 ID:N3vKtiwI
>>105
> いまupgradeしたら-5が入ったぞ
まだダメ。

> sidだろ、久々の地雷なんだし楽しめよ(藁
ほ〜い

111 :login:Penguin:04/03/14 18:30 ID:9Hnl63HY
woodyにスレッドテンプレのapt-lineを追加して、kernel-2.6.3も同時にインストールしようと
したら、reiserfs3が認識できなかった。鬱だ。。

deb http://backports.azumanga-daioh.org/debian woody kernel-2.6
deb http://backports.azumanga-daioh.org/debian woody module-init-tools

112 :login:Penguin:04/03/14 19:40 ID:hBI5Fpe8
>>109
woody用GNOME2を配ってるapt-lineは、大抵woody用gtk2も一緒に配ってる。

113 :login:Penguin:04/03/14 22:38 ID:9Hnl63HY
woodyからsargeにdist-upgradeすると、flex_2.5.31-22_i386.debがexit 1返すんですが。

114 :login:Penguin:04/03/14 23:39 ID:uqMyGxDc
そうですか。

115 :login:Penguin:04/03/15 09:17 ID:TaWbt+CA
hotplugが強力すぎて

2つのサウンドカード * OSS/ALSA
合計4つのドライバが
/dev/dsp のとりあいをしている。

e100とeepro100が
NICのとりあいをしている。

鳴るし、繋がるので
無問題だけど、
それにしても...これはすごい。


116 :login:Penguin:04/03/15 12:37 ID:gpTalceg
>>115
それって hotplug_0.0.20040311-6 ?
怖いので hold してるんだが

117 :login:Penguin:04/03/15 17:48 ID:DY/Wa2B9
>>115とは別人だが。

こっちは起動時にUSB機器が2回スキャンされる。
1回目でマウントに成功してるのに、もう1回マウントしようとして失敗してる。

その後、仮想ターミナルに切替えてみると、延々とUSB関係の割り込みエラーが。
そちらの「とりあい」と原因は同じではなかろうか?

118 :login:Penguin:04/03/15 20:07 ID:TsKG3uOb
Debian初心者です。
Woodyの7枚組CD-Romを入手して、インスコしようとしているところですが、
cfdiskでパーティションを切って、スワップの初期化をした後に/の初期化をするのですが、
雑誌の解説にはExt2, Ext3, ReiseFSの3つから選べるみたいなことが書いてあったのに、
実際にはExt2が指定されて、ファイルシステムを選択するなんてことできないのですが・・・
DebianでExt3を使うためにはどうしたらいいのでしょうか?
どなたか教えて下さい。

119 :login:Penguin:04/03/15 20:09 ID:lUDUnisU
>>118
雑誌の名前を書かないのはなぜ?

120 :login:Penguin:04/03/15 20:10 ID:C9wAMtms
bf24?

121 :118:04/03/15 20:12 ID:TsKG3uOb
>>119
雑誌はLinux WORLD, 2004 Apr.ですが・・・



122 :login:Penguin:04/03/15 20:15 ID:LroHe4bB
>>121
親切な >>120 がもう答え書いてくれてるよ。

123 :118:04/03/15 20:18 ID:TsKG3uOb
>>120, 122
スマセン。よくわからないです。
bf24というのは何ですか?

124 :login:Penguin:04/03/15 20:22 ID:VKJsQYza
>>123
たぶん起動する CD によってインストール作業をする
ブートイメージが違うはず (説明書みてね)。
で、bf2.4 というイメージでないと ext3 は選べません。


125 :118:04/03/15 20:26 ID:TsKG3uOb
>>124, 122, 120
アッ! って感じです。
わかりました。119が「雑誌は何だ?」と聞いたのも。
確かに、解説書をよく読んでませんでした。

-----
インストーラ起動の際、boot:プロンプトに「bf24」と入れるとカーネル2.4が選択される。
-----

ありがとうございました!

126 :login:Penguin:04/03/15 20:31 ID:npl/PqGJ
1枚あれば十分なんじゃ?

127 :login:Penguin:04/03/15 21:00 ID:9UKTrtNb
他のはオフライン用のバイナリCDだし

128 :login:Penguin:04/03/15 22:17 ID:op6gmVcf
バカナリ

129 :login:Penguin:04/03/15 22:49 ID:BTwsb1eI
バカばっかり

130 :login:Penguin:04/03/15 23:02 ID:xUgwIg75
↑馬鹿

131 :ムーミン:04/03/16 01:08 ID:gWzbWUCn
俺は?

132 :login:Penguin:04/03/16 01:09 ID:BYA6d7iQ
トロル。

133 :login:Penguin:04/03/16 07:47 ID:CDGMYQCN
libxft-devのバグどうにかならんのか
BTS通りに対処してみても一向に直らないよママン

134 :login:Penguin:04/03/16 07:54 ID:CDGMYQCN
ちなみに
http://penguin.s4.xrea.com/imgboard/img-box/img20040315184324.png
こんな感じになってる
ゴミみたいな小さな点が多分フォントと思われる物

135 :login:Penguin:04/03/16 09:15 ID:Urn++cJm
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=237511
I removed the libxft-dev package: /usr/X11R6/include/X11/Xft/Xft.h is
still here and belong to no package (dpkg -S). I deleted this file and
re-installed libxft-dev, everything worked fine.

これっすよね、同じエラーは出てないんでしょ。
なんか、ヒントないんでしょうか。

136 :login:Penguin:04/03/16 10:11 ID:SJElf6QX
>>133-134
BTSへgo!

137 :login:Penguin:04/03/16 10:15 ID:maK8vPG8
>>133
# dpkg --purge --ignore-depends=libxft2 libxft-dev libpango1.0-dev libgtk2.0-dev
こんな感じのことをやって削除してからインストールし直したらちゃんと入った.
今朝実行したんだけど,正確に覚えていない.参考まで.

138 :login:Penguin:04/03/16 14:36 ID:SJElf6QX
mozilla-firefox-locale-frがオフィシャルに入って
mozilla-firefox-locale-ca、mozilla-firefox-locale-ukがITPされてるし
mozilla-firefox-locale-jaも欲しいからRFPを出したいんだけど
ttp://www.mozilla.gr.jp/jlp/#firefox
にあるxpiのLicenseとかUpstream Authorが分からんよママン

分かる人代わりに出してプリーズ。

139 :login:Penguin:04/03/16 15:38 ID:ki85wrbZ
>>118
5枚目のCDでブートしろ。

140 :login:Penguin:04/03/16 15:44 ID:xuBSJvvR
おれの心臓アツくビート。

141 :login:Penguin:04/03/16 20:03 ID:fC5wmtXv
Debian入れてみますか。

142 :login:Penguin:04/03/16 20:40 ID:asI0G2Ow
Welcome to Debian

143 :login:Penguin:04/03/16 21:15 ID:Sv89PQOZ
>>133
おっと、同じ症状ハケーン!

144 :login:Penguin:04/03/16 21:37 ID:xdE6cZQ+
>>133
ttp://bugs.debian.org/cgi-bin/bugreport.cgi?bug=237509 より

$ dpkg -r --force-depends libxft-dev
$ apt-get -f install

これでもだめ?

Brandenは修正できないと言っているのでダメならpackageを消して入れ直しになるかな。

145 :login:Penguin:04/03/16 23:24 ID:JZNf+5Oe
>>135の香具師とは別じゃネーノ?
/usr/X11R6/include/X11/Xft/Xft.hだかXft2.hをリネームして-f upgradeでウマく逝ったけどな。

146 :login:Penguin:04/03/17 08:18 ID:3dhrs48A
難民って訳じゃないけどRHからDebianに乗り換え使用とチャレンジ中。
ミニマムからapt-getで便利!と大騒ぎしていたのですが
startxで失敗。apt-getからx-window-systemを持ってきたのはいいものの
VGAチップの特定ができなくて困っています。

チップはノート型のi830を使っていてlspciすると
00:02.0 VGA compatible controller: Intel Corp. Unknown (rev **)
こんな感じで言われます。

# dpkg-reconfigure xserver-xfree86
を実行していて出てくるダイアグラムには
PCI**:**:**
こんな風に入力しろと言われるものの、何を入れても先に進みません。
ここの設定のやり方自体は気がつけばすぐだと試行錯誤して
早2時間。

初めてのKDEが遠いのでどなたか設定教えてください

147 :login:Penguin:04/03/17 08:32 ID:BQeN6xdh
>>146
woody で?

148 :146:04/03/17 08:50 ID:3dhrs48A
>>147

woodyです
インスコはvanillaで行いました。

っていうかbf24だと画面が正確に表示されなくて気持ち悪かったので


バージョンは3.0r2だったはず。

149 :login:Penguin:04/03/17 09:05 ID:Iw6Hocm6
>>148
RH の時に使ってた XF86config がそのまま使えないかな?

150 :login:Penguin:04/03/17 09:39 ID:ou34gldm
とりあえず mozilla-firefox は 0.8-3 で hold しとけ

151 :146:04/03/17 09:40 ID:3dhrs48A
>>149
RHの上からdebian入れてるんで
RHの設定、全部消えちゃってます(涙)

正直、侮ってました…
メモっておけばぁぁ!

152 :login:Penguin:04/03/17 09:54 ID:u0TGHbMc
>>151
xf86cfgで自動認識できるかもしれない。
それで駄目ならKnoppixかな。


153 :login:Penguin:04/03/17 10:20 ID:7WXqhn+N
woodyのxfree86って4.1だっけ?
4.2にした方がいいかもしんない

154 :146:04/03/17 10:27 ID:3dhrs48A
>>152
まずは今からやってみます

>>153
aptになじんでいないので、apt-lineに追加とかよくわかっていないのです(涙)
xf86cfgのテキストモードでできなかったら
色々と試してみます。

みなさま親切に色々とありがとうございます。
Fedoraとかに流れなくて良かった…
よし、がんばろう

155 :login:Penguin:04/03/17 10:39 ID:a+ywf6ub
とりあえず vesa ドライバでどうよ。

156 :login:Penguin:04/03/17 11:17 ID:2NhnRXpf
woodyをVIA EPIA-C800にインスコしようとしているのですが
基本システムのインストールのところで必ずdebootstrapが異常終了しました。
戻り値1と出てインスコ出来ません。
色々検索してみたけど特に情報はなし・・・。
ハードが悪いのかなぁ!?

157 :146:04/03/17 11:22 ID:3dhrs48A
>>155

vesaでもi810でもダメだったんですよ。
unstable試してみるしかないんだろうか…

xf86cfgのテキストモードも
viでxf84cfg-4いじってみたんだけどダメですた。
マッチするデバイスがありませんと来たし。

でもこれだけありがたいレスもらってるし
無駄に消費していると思うのも嫌なので
もうちょっと格闘してみます

158 :login:Penguin:04/03/17 11:32 ID:yN3RBJB+
>>156
ググったけど、インスコできてる香具師はいるみたいだけどな。
http://search.luky.org/linux-users.9/msg02602.html

>>157
vesaでも立ち上がらないって事はビデオチップの設定が原因じゃないとか。
ダメとだけ言われても回答しようがないんで、>>1読んで情報を晒せ。

159 :login:Penguin:04/03/17 12:40 ID:4np+HG7i
>>146
> # dpkg-reconfigure xserver-xfree86
>を実行していて出てくるダイアグラムには
>PCI**:**:**
>こんな風に入力しろと言われるものの、何を入れても先に進みません。

そもそもこれってPower系のCPUに必要な設定で、
それ以外のアーキテクチャは空白にしとけ、って説明出てなかったっけか?

外してたら悪いが。

160 :login:Penguin:04/03/17 13:14 ID:7WXqhn+N
>>159
たぶんそう。
普通は入力しないと思う。
漏れは入力したことがない。


161 :login:Penguin:04/03/17 13:32 ID:v7esFrYT
先生!!
http://debian.fam.cx/ が消滅していまつ

162 :login:Penguin:04/03/17 13:35 ID:yN3RBJB+
してねーだろ。繋がるぞ?

163 :login:Penguin:04/03/17 13:39 ID:a+ywf6ub
切り分けくらいしてから書けよ。

164 :login:Penguin:04/03/17 13:42 ID:v7esFrYT
>>162
[title]

[gifbanner]

403 Forbidden.
indexファイルがない。
パーミッションが非許可になっている。
アカウントが何らかの事情により凍結されている。
注意:凍結されている場合1週間以内に改善報告を行わないと
アカウントは削除されます

Click Here! *



165 :login:Penguin:04/03/17 13:49 ID:xZu77Ih2
>>164
つながると言っているだろ

166 :login:Penguin:04/03/17 13:51 ID:a+ywf6ub
>>164
それは bbzone.net のエラーページじゃないのか?

167 :login:Penguin:04/03/17 13:51 ID:Iw6Hocm6
>>164
繋がる
キャッシュでない事も確認済み

168 :login:Penguin:04/03/17 13:54 ID:yN3RBJB+
>>164
http://penguin.s4.xrea.com/imgboard/img-box/img20040317135214.jpg

もちろんキャッシュをクリアしてから表示。

169 :login:Penguin:04/03/17 14:11 ID:v7esFrYT
つられんなよ、馬鹿

170 :login:Penguin:04/03/17 14:24 ID:xZu77Ih2
164のブラウザのキャッシュだったてことでFA
今頃顔真っ赤にしてるんだろうなw

171 :login:Penguin:04/03/17 14:28 ID:a+ywf6ub
>>170
http://debian.fam.cx/ を見に行って
>>164 なんてのキャッシュするかねぇ。
↓これじゃないの?
http://linux2ch.bbzone.net/hogehogehoge

172 :login:Penguin:04/03/17 15:16 ID:hswvN6tn
>>159
> >>146
> > # dpkg-reconfigure xserver-xfree86
> >を実行していて出てくるダイアグラムには
> >PCI**:**:**
> >こんな風に入力しろと言われるものの、何を入れても先に進みません。
> そもそもこれってPower系のCPUに必要な設定で、
> それ以外のアーキテクチャは空白にしとけ、って説明出てなかったっけか?

最近富士通MG70GN (Pentium M 1.5GHz) を購入して,Debian sidで使って
います.ディスプレイアダプタはIntel i855GMで,sidのXFree86 4.3.0の
i810ドライバで問題なく動作しています.
146で言われているダイアグラムには
PCI:0:2:0
と入力しました.また,lspciの出力は以下の通り.
00:02.0 VGA compatible controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)
/etc/X11/XF86Config-4のディスプレイアダプタの設定は次の通り.
Section "Device"
Identifier "Generic Video Card"
Driver "i810"
BusID "PCI:0:2:0"
VideoRam 8192
EndSection
最後のVideoRamの所は設定時のダイアグラムに表示された値を
そのまま使用したので,これが最適かどうかは分かりません.

Power云々(powerpcのこと?)の話は分かりませんが,これで動作
しています.
これまで使っていた古いPCのままに,ウィンドウマネージャは
ratpoisonかevilwmです.

173 :172:04/03/17 15:23 ID:hswvN6tn
ためしに先に掲げたXF86Config-4のBusIDの項を
コメントアウトしてみてもXを起動できました.
やはり関係ないのですかね.失礼しました.

174 :login:Penguin:04/03/17 16:10 ID:OPdte4Z/
やっぱ woody のXでは古いのでは。

175 :login:Penguin:04/03/17 17:12 ID:tebDzVSJ
sidのlibstdc++の依存性壊れてない?
libgcc1の >= 3.4-0 が必要なんだけどなくない?

176 :login:Penguin:04/03/17 17:14 ID:LWYWpN9U
>>168
汚ないフォント使ってますねえー。
なんとかしないんですか。

177 :login:Penguin:04/03/17 17:18 ID:mMAT0Q4G
>>175
$ apt-rdepends libstdc++5
libstdc++5
依存: gcc-3.3-base
依存: libc6 (>= 2.3.2.ds1-4)
依存: libgcc1 (>= 1:3.3.3-1)
libc6
依存: libdb1-compat
libdb1-compat
依存: libc6 (>= 2.2.5-13)
libgcc1
依存: libc6 (>= 2.3.2.ds1-4)

178 :login:Penguin:04/03/17 17:35 ID:yN3RBJB+
>>175
Experimentalじゃネーノ?

179 :175:04/03/17 17:38 ID:tebDzVSJ
洩れのlibstdc++6なんだけど…。
experimentalのパッケージ?

180 :login:Penguin:04/03/17 17:42 ID:k7961uEz
>>150
本当だ、firefox 壊れてるな。
情報ありがとん。

181 :login:Penguin:04/03/17 17:43 ID:yN3RBJB+
>>179
聞く前に調べよ。
ttp://packages.debian.org/cgi-bin/search_packages.pl?keywords=libstdc%2B%2B6&searchon=names&subword=1&version=all&release=all

182 :login:Penguin:04/03/17 19:37 ID:+KaAbOvg
>>176
そういうあんたは何を使ってるのさ

183 :login:Penguin:04/03/17 22:06 ID:hswvN6tn
>>174
http://debian.fam.cx/index.php?stable#content_1_6
ここのapt lineを使うと解決?

184 :146:04/03/17 22:24 ID:3dhrs48A
ちょっと外出していたので、レスくれた人になんの返事もできずにすいません。
I830Mでこけていたものです。
試しにsidでやってみると問題なし。

woodyでは何度やってもディスプレイドライバ読み込まなかったのに…

おつきあい頂いた皆様ありがとうございます。
ようやくdebianユーザーになりました。

まずは色々と設定いじって悪戦苦闘してみます

185 :login:Penguin:04/03/17 23:03 ID:tt0KVXif
$ pon
$ poff
pidofコマンドが見つからなえぞゴルァ(俺訳)
$ sudo vi /usr/bin/pidof
#!/bin/sh
ps a | grep pppd | grep -v grep | sed -n 's/\(.....\).*/\1/p' | colrm 1 1
$ sudo chmod 755 /usr/bin/pidof
$ sudo vi /usr/bin/poff
PIDS=$(pidof pppd) → PIDS=$(pidof)

186 :login:Penguin:04/03/17 23:06 ID:oXtMkblJ
>>185
sysvinit

187 :login:Penguin:04/03/17 23:09 ID:BQeN6xdh
>>185
俺訳すんなよ。
http://debian.fam.cx/index.php?AptGet#content_1_19

188 :login:Penguin:04/03/17 23:14 ID:TovgYUG0
BTS で mozilla-firebox がすごいことになってるように見えるけど・・

189 :login:Penguin:04/03/17 23:14 ID:TovgYUG0
s/firebox/firefox/

190 :login:Penguin:04/03/17 23:15 ID:BQeN6xdh
>>188
で?

191 :login:Penguin:04/03/18 02:32 ID:hk3dR0ky
なんらかんら言っても、優しい喪前らに萌へ

192 :login:Penguin:04/03/18 05:38 ID:QYm9+xjL
>>184
非常にタイミング悪くて申し訳ないんだけど、Xが4.2以上
kernel.2.4.12?以上(失念)でないといけなかったと思うよ。
woody(officialパッケージ)ではfbdevしかXを利用できなかった
と思います。

193 :login:Penguin:04/03/18 05:51 ID:XswnZcbH
enlightement入れてデフォルトのデスク環境にしてみたら
メニューの日本語がうまく表示されない。

194 :login:Penguin:04/03/18 09:51 ID:90BMgmzJ
そうですか。

195 :login:Penguin:04/03/18 11:05 ID:TpPHsftE
unstableのja-transってnet-toolsのja.poしか提供してないみたいだから
とっととnet-toolsにマージして廃止してしまえばええのに。
日本人が余分にインストールするパッケージが減る。

196 :login:Penguin:04/03/18 12:23 ID:AQkQ+cf2
woody & x-window-system を標準でインストールしました。

アプリケーションの終了のバッテンボタンがウインドウの左上端にあるのですが、
Windows と同じく右上端に移す方法ってありますか?

現在は右上端ボタンを押すとタイトルバーだけになってしまいます。

197 :login:Penguin:04/03/18 12:24 ID:PdXKrI3s
>>196
ウィンドウマネージャは何よ。

198 :login:Penguin:04/03/18 12:41 ID:NXZ2YO4b
>>196
woodyでそれだと…GNOME1.4標準のcruxテーマ?



199 :login:Penguin:04/03/18 12:57 ID:AbZqwF1Y
>>196
くだ質にでも逝け

200 :login:Penguin:04/03/18 13:41 ID:ovwbYq1m
だな.Debian関係ねーし.

201 :login:Penguin:04/03/18 13:42 ID:ovwbYq1m
あげちった・・・

202 :login:Penguin:04/03/18 15:01 ID:dSf5vJol
>>186
ありがとうございます。Sidなんですけど、
最近になって起こった事なんですが…
$ dpkg -l | grep sysvinit
ii sysvinit 2.85-10
$ dpkg -L sysvinit | grep bin | grep pidof
/bin/pidof
$ sudo rm /usr/bin/pidof
$ echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games:
/usr/sbin:/sbin:/home/komhrie/bin()(実際は一行)
$ sudo mv /usr/bin/poff.mybak /usr/bin/poff
$ pon ;sleep 15 ;poff
/usr/bin/poff: line 1: pidof: command not found
/usr/bin/poff: No pppd is running. None stopped.
ヽ(`Д´)ノ


203 :202:04/03/18 15:03 ID:dSf5vJol
うお、/home/komhrieは無視してくれ

204 :login:Penguin:04/03/18 15:03 ID:NTXNKJaU
ja.po だけじゃなくて、
null.po とか tim.po とかないの?

205 :185:04/03/18 15:13 ID:Yyij+o6h
自己解決しますた。
$ ls -l /bin/pidof
lrwxr-xr-x 1 root root
16 2004-03-17 14:48 /bin/pidof -> ../sbin/killall5
$ ls /sbin/killall5
ls: /sbin/killall5: そのようなファイルやディレクトリはありません
$ which killall5
/bin/killall5
$ sudo rm /bin/pidof
Password:
$ sudo ln -s /bin/killall5 /bin/pidof
でpoffが効くようになりました。
>> 186,187さんありがと〜

206 :login:Penguin:04/03/18 15:15 ID:PdXKrI3s
>>205
待て。
なんで killall5 がそんなとこにあるんだ?

207 :login:Penguin:04/03/18 15:34 ID:NPjwDOag
というか、komhrieって何?


208 :login:Penguin:04/03/18 15:56 ID:+v/ScoBE
>>206
sysvinit (2.85-11) unstable; urgency=high
* Move killall5 back to /sbin (closes: #238416)

209 :login:Penguin:04/03/18 17:18 ID:AQkQ+cf2
>>197
コントロールセンターのウインドウマネージャで

Sawfish (現在)
twm

となっています

>>198
そうです。GNOMEは1.4です。コントロールセンターの外観にCruxとありました。
ヒントありがとうございます。ここで設定できたのですね。今書き込み中に発見しました。
MS Windowsに似せたタイトルボタンを表示で希望通りの設定ができました。

>>199
>>200
すみません。でも僕はまだLinuxはDebianしかさわったことないのです。
いろいろ見るとRed Hatとかの方が初心者向きな用なので、そちらのほうも試してみたいです。
でもDebian仲間にも入れてください。

210 :login:Penguin:04/03/18 17:26 ID:PdXKrI3s
>>199
ここでいいじゃん。
最初から切り分けできるやつなんていないよ。

211 :login:Penguin:04/03/18 18:19 ID:NPjwDOag
>>209
お子ちゃまは↓で遊んできなさい。

Sawfish themes
http://themes.freshmeat.net/browse/926/
GTK themes
http://themes.freshmeat.net/browse/58/

212 :login:Penguin:04/03/18 18:21 ID:8E7JAQNc
  Woody で ATI Rage Mobility は使用できるでしょうか?
 既出かもしれませんし、私なりにハードウエアリストで調べた限りでは
使用可能の様ですが、最後の段階で X-windowsが設定できませんので、
なおボード自体はWin2000で動作しています、
 幼稚質問を恥じつつ、、、、、

213 :login:Penguin:04/03/18 18:28 ID:PdXKrI3s
>>212
最後の段階ってどこだろ。
どううまくいかないんだろ。

どうしてもだめなようなら
vesa ドライバ試すか
http://debian.fam.cx/index.php?stable#content_1_4
あたりの新しい X 試してみ。
それか sid に上げるか。

214 :login:Penguin:04/03/18 18:33 ID:NTXNKJaU
> ATI Rage Mobility
今の使ってるマシンがこれですが、 sid で使えてます。
インスコの時には woody で入れたのですが、
後で sid にしてしまったので woody ではどうだったか忘れてしまいました。



215 :214:04/03/18 18:34 ID:NTXNKJaU
と思ったら、XF86-Config-4 のバックアップに woody の時のものがあるので、
使えてたみたいです。
ちょっと記憶にはないのですが。


216 :login:Penguin:04/03/18 18:42 ID:NPjwDOag
>>212
woodyどうのこうのより、
$ dpkg -l xserver-xfree86
の結果晒した方がいい。


217 :212:04/03/18 20:33 ID:8E7JAQNc
212です 皆様本当に有難う存じました
 これでまずビデオカードを買ってこなくて済みました
 未だ、全然デビアンを動かせない初心者です、
 皆様のコメントが判るように勉強してトライしてみます

218 :login:Penguin:04/03/18 22:37 ID:5O61mdQ+
  ||// ∧_∧|∧_∧
  ||/  (n´・ω・)n   ) 何かクサいけどウンコついてない?
  ||   (ソ  丿|ヽ ● )
    ̄ ̄ ̄ ̄ ̄ u―u'

   _____
  ||// ∧_∧|∧_∧
  ||/ r(    (n´・ω・`n) ウンコついてないけど何かクサい
  ||   ヽ ● )|(    )
    ̄ ̄ ̄ ̄ ̄ u―u'

219 :login:Penguin:04/03/18 22:39 ID:9tnsZ2hL
>>214
Xの設定見せてあげれば?

220 :login:Penguin:04/03/18 23:01 ID:9tnsZ2hL
>>218
それはなんのメタファだ

221 :login:Penguin:04/03/18 23:24 ID:DGJWad7Z
Debhelper スクリプト群について質問です。
これらのスクリプトの動作って、DH_COMPAT 環境変数などの値によってまったく変わりますよね。
たとえば、dh_install や dh_installdirs が思ったとおりに動かなかったりして、
パッケージ作りでいつも難儀しているのですが、良い日本語解説サイトって無いでしょうか?
ちなみに、今 Ruby1.6, 1.8 (sid) 、ライブラリ含む、の woody への backport をやっています。


222 :login:Penguin:04/03/18 23:34 ID:a/dInIT6
>>221
ソース読んだ方が早いと思うが。

223 :login:Penguin:04/03/18 23:53 ID:DGJWad7Z
>>222
ありがとうございます。
Perl は昔ちょこっと使っただけで、今はすっかり忘れてしまってて普段使わないので。。。
勉強しなおそうかな。

ただのぐちですが、こうした重要なツールに変なモード (DH_COMPATみたいな) がいくつかあると
とたんに使いにくくなりますね。「ユーザビリティを上げるにはモードを減らせ」とも言いますし。
まあ私の頭が悪いだけ、とも言えます。。。


224 :login:Penguin:04/03/18 23:53 ID:0hvwx3WN
Debianというか、Linux自体を初めてインストールしてみました。
一つ質問ですが、
$su
password ?????
#apt-get upgradeと
$sudo apt-get upgrade とで、実行される結果は全く同じ物なのでしょうか?
(suする事がいいか悪いかは別として。)

225 :login:Penguin:04/03/18 23:56 ID:NPjwDOag
同じです。
Linux全般の平易な質問は「くだ質」スレに行くといいです。

226 :login:Penguin:04/03/19 00:18 ID:SKvHv4xQ
わからん人は平易かどうかもわからんのだろうね
debianの話なのかどうかも

227 :login:Penguin:04/03/19 00:35 ID:+QSt+VFs
わからなければ、くだ質で質問してみればいいんじゃネーノ。
どうせアッチも見てるだろ、おまいら。

228 :214:04/03/19 00:43 ID:hCqELbC9
>>217
> これでまずビデオカードを買ってこなくて済みました
ATI Rage Mobility は普通ノートPC用だと思うので、普通変えられないのでは?

>>219
そう思ったのですが、見た所何も大したことは設定してないですね。
/var/log/XFree86.0.log 見るとかなり自動で識別してくれてるみたい。
せいぜい videoram 書いたことと、特殊な大きさの液晶なので、
それを書いたことくらいかな?

>>217 さん、一応参考にしてみて下さい。
関係あると思われる所だけ抜粋しておきます。

Section "Device"
Identifier "Generic Video Card"
Driver "ati"
VideoRam 4096
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x512"
EndSubSection
EndSection


229 :login:Penguin:04/03/19 00:57 ID:g2uFTgoZ
同じ型番でも種類がいろいろあったり
実は「Rage Mobility ほげほげ」だったりするヨカーン。

230 :212:04/03/19 01:55 ID:ScccvtI9
 この ATI Rage Mobility は AGP 用です、4MBです
 この会社の製品の様ですが、HPには記載ありません、マイナーは製品?
 確か1400円(値札はずれてました)くらいの激安、845Gの内臓ビデオに負ける代物です
 皆様ご指導有難う存じました、流れてくる画面と数字を緊張して眺めて
インストールゆっくりとやってみます、今まで掛かってリムーバブルHDD
にしました、明後日から又やります、
 

231 :login:Penguin:04/03/19 02:37 ID:+QSt+VFs
マターリガンガレ

232 :login:Penguin:04/03/19 10:32 ID:uKPTG7Ae
FDCloneをソースからインスコしました。パッケージあるの知らんかった。
マニュアルインスコ時にディレクトリがないと怒られたんで手で掘り、なんとか
使えるようになったつもりだったんですが、一般ユーザー(日本語)でman fdすると
次のように言われてしまいます。

$ man fd
fd(1) を再フォーマットしています。しばらくお待ちください...
invalid charset name
man: コマンドはステータス 256 で終了しました: (echo '.ll 9.0i'; /usr/bin/zsoelim /usr/local/man/ja_J
P.EUC-JP/man1/fd.1) | /usr/bin/tbl | /usr/bin/nroff -mandoc -Tnippon | exec /usr/bin/pager -s

rootで英語版のmanは見られます。
パーミッションとかも問題ないはずなんですが、どこに問題があるんでしょうか。

ちなみに、FDCloneだけでなく、man slとかでも同様の問題が出ます。

233 :login:Penguin:04/03/19 10:39 ID:Glm9gJGW
# locale-gen
の結果晒してみたら?

234 :232:04/03/19 11:28 ID:uKPTG7Ae
>>233
こんなんなりました。

# locale-gen
Generating locales...
ja_JP.EUC-JP... done
ja_JP.UTF-8... done
Generation complete.

235 :login:Penguin:04/03/19 11:36 ID:Tz6V0CD1
apt-get --purge remove gnome*

こんな感じでgnomeとkdeを削除して、fvwmのみにしたのですが、
デフォルトでログインしてもfvwmが起動してくれません。
Ktermの画面が出たところで止まってしまいます。
gnome関連のパッケージがまだ残っているからでしょうか。
Debianの場合、デフォルトで起動するWMの設定はどこに書き込まれて
いるのでしょうか?
/etc/X11/xdm以下のファイルを開いてみても訳わかめなので。

236 :login:Penguin:04/03/19 11:37 ID:Glm9gJGW
$ PAGER=more man fd
$ PAGER=lv man fd
$ PAGER=jless man fd
$ echo $LESSCHARSET
$ echo $JLESSCHARSET

237 :login:Penguin:04/03/19 11:39 ID:Glm9gJGW
>>235
$ cat ~/.xsession
fvwm
$

238 :login:Penguin:04/03/19 11:46 ID:UxmKUQWe
>>235
#update-alternatives --config x-window-manager
で変更してみたらどうでしょうか?



239 :login:Penguin:04/03/19 12:23 ID:i3fPzcTZ
>>221
FYIなんだが
deb http://deb.ruby-lang.org/debian/ stable main contrib non-free
ってのでは問題なのかな? > 1.8系



240 :login:Penguin:04/03/19 12:28 ID:NTK4ejVt
mozilla-firefox 0.8-5がきたけど
Save AsのCancelとSaveボタンの順番が変わってる

ドーナッテルノー チャンチャカチャンチャカチャンチャンチャン

241 :login:Penguin:04/03/19 12:36 ID:NTK4ejVt
% sudo dpkg-reconfigure mozilla-firefox
Updating mozilla-firefox chrome registry...done.
Unknown error, message=replacewith($string, $replace, $with): $replace and $with must have the same length.
install-menu: /etc/menu-methods/freedesktop-desktop-entry-spec-apps: aborting
update-menus[1379]: Script /etc/menu-methods/freedesktop-desktop-entry-spec-apps returned error status 1.
Unknown error, message=replacewith($string, $replace, $with): $replace and $with must have the same length.
install-menu: /etc/menu-methods/freedesktop-desktop-entry-spec-dirs: aborting
update-menus[1379]: Script /etc/menu-methods/freedesktop-desktop-entry-spec-dirs returned error status 1.

アヒャヒャー

242 :235:04/03/19 12:40 ID:Tz6V0CD1
>>238
>#update-alternatives --config x-window-manager
>で変更してみたらどうでしょうか?

Thanks.
But...
No alternatives for x-session-manager

243 :235:04/03/19 12:44 ID:Tz6V0CD1
>>242 teisei simasu

>>238
>#update-alternatives --config x-window-manager
>で変更してみたらどうでしょうか?

There are 2 programs which provide x-window-manager

Selection command
------------------------------------------------
1 /usr/X11R6/bin/twm
+ 2 /usr/bin/fvwm2

to hyouji saremasita.

244 :login:Penguin:04/03/19 12:49 ID:ON1hC28W
>>235
なんで>>237を無視すんの?

245 :235:04/03/19 13:06 ID:Tz6V0CD1
>#update-alternatives --config x-window-manager

de kaiketu simasita. arigatou gozaimasita.

>>244
sumimasen. .xsession ga mitsukarimasen desita.

246 :login:Penguin:04/03/19 13:12 ID:PRBD2n+v
>>245
少しは読み手の事を考えたらどうだ?

247 :login:Penguin:04/03/19 13:17 ID:jIeOqW6l
読まれたくないんじゃないかな。

248 :235:04/03/19 13:32 ID:Tz6V0CD1
>>246
sumimasen. can not use Japanese..

249 :login:Penguin:04/03/19 14:26 ID:LB6JobjS
>>248
fvwmにした都合で日本語入力できないの?
.xsession で XIM に kinput2 を指定しないと駄目なのでは?
さっき.xsessionの話で反応薄かったから実はよく分かってない?

250 :235:04/03/19 14:40 ID:Tz6V0CD1
>>249
お騒がせ致しました。
このとおり日本語入力も可能になりました。
fvwm2でフォントに関するエラーが出てしまいましたので、
けっきょくfvwm2は諦めてしまいました。
日本語の設定を最初からやり直して解決しました。
どうも有難うございました。

>さっき.xsessionの話で反応薄かったから実はよく分かってない?

はい。
勉強不足のため適切な返答ができずに申し訳ありませんでした。

251 :login:Penguin:04/03/19 19:22 ID:e37ZPolX
flash6 pluginが更新されたな。

サヨナラlibstdc++2.10-glibc2.2

252 :login:Penguin:04/03/19 21:26 ID:MU27DGO3
sidとsargeが更新されたな。
http://distrowatch.com/table.php?distribution=debian

253 :login:Penguin:04/03/20 01:29 ID:j70eP/hd
gcc に-lsslオプションつけてたら
/usr/bin/ld: cannot find -lssl
といわれてしまいます。何が足りないのでしょうか?
OpenSSLとlibsslはインストール済みなのですが。

254 :login:Penguin:04/03/20 01:36 ID:EbVe4Bf8
$ dpkg -L libssl0.9.7

255 :login:Penguin:04/03/20 09:56 ID:GjTlsAXy
libssl-devは入れてありますか。

256 :login:Penguin:04/03/20 11:54 ID:mQvLGfmB
こういうときにapt-getがささっと動いたら便利かな。
だれかdapt-getの開発機本濡。

257 :login:Penguin:04/03/20 13:41 ID:2nOYkG+c
言い出しっぺの法則が発動しますた。
ガンガレ>>256

258 :login:Penguin:04/03/20 14:42 ID:9iULFgCQ
http://download.gna.org/kazehakase/debian/
の風博士だけど、スクロールバーがMozillaのスクロールバーになっちゃう。
GTK+のスクロールバーにしたいんだけど、どうやるのさ。

259 :login:Penguin:04/03/20 15:54 ID:ctptKJmE
自宅のThinkpad i1400にDebian3.0をinstallしました。
なんとかinstallはできたのですが、LANカードの設定をしようと思っていたところ…
/etc/pcmciaがありません…
どうしたらよいのでしょうか…
LANカードはcorega FEther PCC-TXDです
よろしくお願いいたします

260 :login:Penguin:04/03/20 16:03 ID:727AkseS
>>258
そんなことできるの?

261 :login:Penguin:04/03/20 16:05 ID:727AkseS
>>259
http://debian.fam.cx/index.php?AptGet#content_1_19

262 :259:04/03/20 16:25 ID:ctptKJmE
>>261
アドバイスありがとうございます。
apt-getでPCMCIAをinstallするようにしてみればいいのでしょうか?
再インストールしてみた方が早いかな…

263 :login:Penguin:04/03/20 17:17 ID:VmvHNqSm
>>256
auto-aptでできればいいのだけどね。

264 :login:Penguin:04/03/20 20:01 ID:ns1z7Mb6
>>258
~/.kazehakase/mozilla/kazehakase/chrome/chrome.rdf

<RDF:Description about="urn:mozilla:package:global">
<c:selectedLocale resource="urn:mozilla:locale:ja-JP:global"/>
<c:selectedSkin resource="urn:mozilla:skin:classic/1.0:global"/>
</RDF:Description>
って項を加えるとGTK+のになるよ.galeonでも


265 :login:Penguin:04/03/20 22:15 ID:7IgQdGzQ
$dpkg -S /etc/init.d/iptables
ってやっても
dpkg: /etc/init.d/iptables not found
となるだけ。これってもう使われてない?
/sbin/ip{,6}tables{,save,restore}があるから要らないといえば
いらなそうな気もするけど。ただ起動時にはどこかでactiveな
設定が読み込まれる必要があるよね?

266 :login:Penguin:04/03/20 23:17 ID:gYXe1CVe
>>265
README.Debianに書いてあるよ。

267 :login:Penguin:04/03/21 00:16 ID:rjOp6D3S
>>266
ありがとうございます。
/etc/network/interfacesに記述するのがDebian流のようですね。
記述の仕方は何通りかありそうですが。

とこで/etcの下はある程度の期間使っていると、ゴミとおぼしき
ファイルがいくつかできあがりますが、それらを判別する
分り易い方法はないものでしょうか。
仮に
$find /etc/network -type f -exec dpkg -S {} \;
としたところ、interfacesすらもnot foundとなってしまいます。

268 :login:Penguin:04/03/21 00:23 ID:L65JB0TN
>>267
昔DWNにそんなネタが出てたな。
その「ゴミとおぼしきファイル」がどんなファイルか知らんけど。

269 :253:04/03/21 03:57 ID:z2ih3x9n
>>254-255
入ってなかったので

# apt-get install libsasl-dev

とすると

Sorry, but the following packages have unmet dependencies:
libssl-dev: Depends: libssl0.9.6 (= 0.9.6c-2.woody.4) but 0.9.6c-2.woody.6 is
to be installed
E: Sorry, broken packages

となってしまいます…
うーむ。

270 :login:Penguin:04/03/21 10:34 ID:Z2xh+MtG
>>269
libsslで過去ログ検索ぐらいしたのか?

271 :login:Penguin:04/03/21 13:56 ID:NEo+mICH
少々くだらない質問かもしれませんが
sidって、結構ベースとなるパッケージがバージョンアップした時、
それに依存するパッケージはどうしてるんでしょうか?
それと一緒に一気にアップグレードするのか、
問題が起きるか、誰かがアップグレードするまでとくになにもしないのか。

たとえばベースとなるパッケージというのはxfree86とか、glibcとかあたりです。

272 :login:Penguin:04/03/21 14:13 ID:o6HpbREM
引きずられて、ものすごい勢いでアップグレードされますが何か?

273 :login:Penguin:04/03/21 14:16 ID:VIOuo2DY
>>271
同じソースから生成されてるパッケージ群は、ほぼ一緒に出る。
それ以外はメンテナによる。

274 :login:Penguin:04/03/21 14:35 ID:oMJBOu5t
今、Debianのインスが簡単になると、
一気にメジャーなディストリになりそうな気がする。

厨房が増えるのは嫌だけど、周りにVine難民、RedHat難民、Turbo難民
が増えているのでとても気になる。

275 :login:Penguin:04/03/21 14:55 ID:VIOuo2DY
>>274
どうぞ
http://life4.2ch.net/yume/

最近/procが2回マウントされてキモチワルイ(;´Д`)
fstabから/procをコメントすると文句言われるんだが、どう対処すりゃいいんだ?

276 :login:Penguin:04/03/21 14:59 ID:6goZkpdD
このソフトって無料なんだな

277 :login:Penguin:04/03/21 15:15 ID:hmjYxdK2
>>274
厨房にも寛容なディストリでないとメジャー化は無理だと思う。
ユーザー層を限定した敷居の高いマイナー路線を貫くし家内。

278 :login:Penguin:04/03/21 15:32 ID:bRimo47J
そのVine難民でつ。w
まぁ元々FreeBSD使ってたのだが。

279 :login:Penguin:04/03/21 15:36 ID:vdlHQJfo
emacs-w3m の ML でも話題になっているけど、素の install-info が入っている
パッケージはないんでしょうか。自分もあの独自スクリプトのせいで、問題解決に
時間を費したことがありました。

280 :login:Penguin:04/03/21 17:14 ID:NSoQVzLQ
>>279
ttp://debian.fam.cx/index.php?install#content_1_33

281 :login:Penguin:04/03/21 17:42 ID:am7IdCWv
さておまいら、この度NotePCを買う事になったんだけど、何かお勧めはある?
debian specificな問題では無いけど、アレは苦労したとか、コレは何の問題もなくインスコ出来た、とかその程度でもいいので

条件としてはA4サイズである事、バッテリー駆動時間が長い事、(出来れば)無線LANが内蔵されている事
予算は出来れば20以内に収まって欲しい…_| ̄|○

最新モデルじゃなくて型落ちしてるのとかでも構わないので
是非ご指導をおながいします

282 :login:Penguin:04/03/21 17:59 ID:NSoQVzLQ
>>281
ググれ

以上

283 :login:Penguin:04/03/21 18:54 ID:4qOI6CtU
>>281
チンコパッド

284 :login:Penguin:04/03/21 19:08 ID:UafuAAAv
>>281
てぃんこぱっど

285 :login:Penguin:04/03/21 19:15 ID:3zXX8VIQ
dynabook

286 :login:Penguin:04/03/21 19:31 ID:QuDM2nys
Let's

287 :271:04/03/21 19:59 ID:NEo+mICH
>>272>>273
どちらなんだろう?

バラバラにアップするが、メンテナががんばってるから、
ついづいされてアップグレードされてるのが実状と見るべきなのかな?

288 :271:04/03/21 20:00 ID:NEo+mICH
そうタイムラグも無しにアップされてると言うのなら別にいいんだけど、、、。
glibc当たりのアップグレードだったら、ほぼ全部が影響されるのだからどうしてるのか名?と。


289 :login:Penguin:04/03/21 20:03 ID:NEo+mICH
pentium Mのマシーン。
その要件だったら無線LANのハードウェアの適合の問題がありそうだけども、
確か何処かのすれで、ドライバの仕様公開したとか読んだ気がするので。

ま、LINUXで使える無線LANのPCカードなりUSBを探して、それがさせる奴と言う捜し方になるだろうけど。

290 :login:Penguin:04/03/21 20:05 ID:NEo+mICH
>>274
knoppixをHDDにいれるときにもっと細かい設定をできるようになればそういうのになるかもね。
knoppixはむしろLINUX全体で見ても初心者に優しいディストリだから。

今は全部一気にいれるしか無かったはずだし。

291 :login:Penguin:04/03/21 22:03 ID:YJqjfjWA
>>267
/etc/default/iptables
を見ると、/etc/init.d/iptablesを使う方法についても書いてあるよ。
作者はすげーやって欲しくなさそうだが。
でも殆どのケースじゃ/etc/init.d/でやれば十分だからな。。

292 :login:Penguin:04/03/22 01:15 ID:EMU8Zfm5
>>281
> さておまいら、この度NotePCを買う事になったんだけど、何かお勧めはある?
燃料電池がまともに実装されるまで待つヨロシ。


293 :login:Penguin:04/03/22 03:26 ID:c2HQZ/hh
php4のパッケージはいつになったらapache2で動くようになるんだ?

294 :login:Penguin:04/03/22 03:30 ID:cWcf129L
反物質電池っていつ実現されるの?

295 :login:Penguin:04/03/22 10:26 ID:na2Nnm8i
python-opengl を入れても
Importing the GLUT library failed.
と言われるんですが、何か足りないのでしょうか?
環境は sarge です。

296 :login:Penguin:04/03/22 10:27 ID:34gpXMnE
>>反物質電池っていつ実現されるの?

板違い。
対消滅エンジンに関する議論は2004年現在、SF関連の板でしか行われていない。
実用化の話なら22世紀以降の反物質板に書き込め。


297 :login:Penguin:04/03/22 11:52 ID:LPLLAEG/
>>274
もう少し、デフォルトでインストールした時に派手だと受けるんだろう
けれどな。

298 :login:Penguin:04/03/22 11:55 ID:LPLLAEG/
>>294
陽子崩壊を研究していた大先生は、山の洞窟に膨大な水を入れて、
チェレンコフ放射の起こるのを待っていましたが、結局、失敗し、
ニュートリノの研究に切り替えてノーベル賞をもらいましたとさ。

299 :login:Penguin:04/03/22 12:26 ID:i39Jt5XX
apt-getしたらマウスが動かなくなった.かわいくねー

300 :login:Penguin:04/03/22 15:48 ID:JoNEJ9nZ
>>299
apt-get で何をしたのだ?

301 :login:Penguin:04/03/22 16:34 ID:3C3WC1ZG
>>300
apt-get removeしたって事だろ。

302 :login:Penguin:04/03/22 16:48 ID:KSsm00+x
デブ厨です。
woodyを入れたんだけど、KDEが立ち上がらない(Xが落ちる)。
GNOMEやtwmは立ち上がるから、XFree86の設定関係の問題ではないと思う。

こういうことってオイラだけですか?
どなたか解決策などご存じの方、アドバイスをおねぎします。

303 :login:Penguin:04/03/22 17:01 ID:EXMVDTRJ
/var/log/XFree86.0.log を見てみたら?

304 :login:Penguin:04/03/22 17:14 ID:hx0ykdZW
>>302
KDEのライブラリがインストールされていない。

305 :login:Penguin:04/03/22 17:30 ID:3C3WC1ZG
>>302
くだ質へ逝け。

306 :login:Penguin:04/03/22 17:34 ID:FY439LsK
>>305
Debian 依存の問題の可能性もあるから
くだ質に持ってこられても困る。

307 :login:Penguin:04/03/22 17:35 ID:KSsm00+x
>>303 見ても、意味がわからんだす。厨でスマソ。
>>304 apt-get install kdelib* で突っ込んだけど、やぱり、立ち上がらないナリ。
(グスン

308 :login:Penguin:04/03/22 17:44 ID:gBINicjo
>>302
普通defaultでKDEが立ち上がるが...logの内容は?

309 :login:Penguin:04/03/22 17:49 ID:KSsm00+x
>>308 $less /var/log/XFree86.0.log してみたんですが、あまりに長くて、
どこに注目したらいいのかわからないのですが・・・


310 :login:Penguin:04/03/22 17:56 ID:xjAHizbf
>>309
http://debian.fam.cx/index.php?install#content_1_28

311 :login:Penguin:04/03/22 18:00 ID:3l0Uz1Mc
~/.xsession-errors には何か書かれてる?

312 :login:Penguin:04/03/22 18:31 ID:KSsm00+x
>>311 〜/.xsession-errorsはないです。
代わりに〜/.kde2-errorsなら以下の通りです。
+ break
+ sysmodmap=/tec/X11/Xmodmap
+ usrmodmap=/home/taro/.Xmodmap
+ startup=/home/taro/.kde2rc
+ resources=/home/taro/.Xresources
+ startssh=
+ sshagent=/usr/bin/ssh-agent
+ '[' -x /usr/bin/ssh-agent -a -a '' ']'
+ startssh=yes
+ '[' /usr/bin/X11/xmodmap ']'
+ '[' -f /etc/X11/Xmodmap ']'
+ '[' f /home/taro/.Xmodmap ']'
+ '[' -x /home/taro/.kde2rc ']'
次に続く


313 :login:Penguin:04/03/22 18:32 ID:KSsm00+x
さっきの続き
+ '[' -f /home/taro.Xresources ']'
+ xrdb -load /home/taro/.Xresources
++ which kde2
+ '['  '!' -n /usr/binkde2rc ']'
+ '[' -n yes ']'
+ exec /usr/bin/ssh-agent -- kde2
DCOPServer up and running.
kdeinit: Fatal IO error: Client killed
kdeinit: sending SIGHUP to children.
KLauncher: Exiting on signal 1
kdeinit: sending SIGTERM to children.
kdeinit: Exit
ksmserver: cannot connect to X server :0
connect() failed: : NO such file or directory

314 :login:Penguin:04/03/22 19:08 ID:INf8AP04
startkdeを直接実行してない?

315 :login:Penguin:04/03/22 19:10 ID:KSsm00+x
>>314 gdm(でしたっけ? GUIのlog-in画面)でKDEを選択してlog-inしました。
runlevelが5になってます。

316 :login:Penguin:04/03/22 19:13 ID:FY439LsK
>>315
runlevel がなんか関係あるのか?

317 :login:Penguin:04/03/22 19:17 ID:KSsm00+x
>>316 あいや、コンソールからコマンドでXを立ち上げているのではないです、
って程度の意味です。

318 :login:Penguin:04/03/22 19:21 ID:FY439LsK
>>317
それはきっと runlevel 5 ではない。
who -r してみ。

319 :login:Penguin:04/03/22 19:27 ID:KSsm00+x
>>318 本当だ。スミマセン。run-level 2 でした。


320 :login:Penguin:04/03/22 20:02 ID:KSsm00+x
302以下、質問者のID:KSsm00+xですが・・・
それで、結局、KDEについてはどうなるんでしょうか・・・
どなたか、ヘルプ・ミー・・・


321 :login:Penguin:04/03/22 20:25 ID:946HV4k5
全部、KDE関係のライブラリを消してもう一度インストールしてみれば?
それでダメなら、graphic driverとライブラリの相性が悪いな。graphic
boardは何?

322 :login:Penguin:04/03/22 20:27 ID:NFqchUwb
Sidつかってますが、

WoodyのKDEの現行バージョン
2.2.2というのがとてつもなく古いので
なんともかんとも(一昨年ぐらい??)
.kde2-errors
というネーミングから考えると
たぶんディスプレイ・マネージャが
kdmになってるので

dpkg -P kdm
して
apt-get install xdm
すると、標準的なxdmになるので
そっちだとどうかなーー。
ぐらいしかわかりません。

すみません。成仏してください。


323 :login:Penguin:04/03/22 20:30 ID:SBqKvdu+
gnomeなくなっちゃうの?

324 :login:Penguin:04/03/22 20:56 ID:PMf/E4VK
いまさっきapt-get dist-upgradeしたら、
ntpdate,ntp,ntp-server,ntp-simpleがそれぞれ
アップグレードしました。しかし、
/etc/init.d/ntp-serverがないんです。
$dpkg -L ntp-serverと確認すれば含まれています。
みなさんのところではどうでしょうか?

325 :login:Penguin:04/03/22 20:58 ID:AhEgbE7f
>>323
なんで?

326 :login:Penguin:04/03/22 21:02 ID:v1BdWVJL
>>323
キチガイMarillatがいなくなるだけ。大丈夫。
つか、changelogの暴言はみっともないね。


327 :login:Penguin:04/03/22 22:51 ID:IEaXA1Xc
>>281
ThinkPadでLinuxスレへカモン!

328 :login:Penguin:04/03/22 23:26 ID:1KWqnnfb
>>324
sid使いなら同意を求める前にBTSぐらい覗けっての
ttp://bugs.debian.org/cgi-bin/bugreport.cgi?bug=239283

329 :login:Penguin:04/03/22 23:56 ID:7rvL+3Vo
SELinuxを使ってる人はいますか?
http://www.coker.com.au/selinux/
ここに書いてあるようにsources.listを書き換えるだけで、
簡単に使えるようですが。重要なパッケージを
SELinux用にビルドされたもので上書きしてしまうので、
ちょっとためらいます。

330 :login:Penguin:04/03/23 00:02 ID:ruxv99eD
とあるプログラムのデバッグ用に、chroot 環境で dhcpd を動かしてるんですが、
起動しても chroot 内の /var/log/syslog が空のままです。そのほかのログもすべて空のままです。
chroot 環境は debootstrap で woody のものを作成しました。なにか原因が考えられるでしょうか?


331 :login:Penguin:04/03/23 00:09 ID:oQ/oppc7
syslogがchroot環境で動いてないからじゃないの?

332 :login:Penguin:04/03/23 00:10 ID:oQ/oppc7
s/syslog/syslogd/ ね

333 :login:Penguin:04/03/23 00:17 ID:ruxv99eD
>>332
ありがとう!できました。


334 :login:Penguin:04/03/23 01:29 ID:h3YM5mSH
>>329
>ここに書いてあるようにsources.listを書き換えるだけで、
>簡単に使えるようですが。重要なパッケージを
>SELinux用にビルドされたもので上書きしてしまうので、
>ちょっとためらいます。

 上書きしたパッケージじゃないとSELinuxでは動かないと思われ
 まぁ、試すのならテスト環境作っておくとかさ




335 :login:Penguin:04/03/23 16:27 ID:ZWW1fVIt
ish ってもう無いの?

336 :login:Penguin:04/03/23 16:33 ID:h+hzJfTN
>>335
debian-jp にない?

337 :login:Penguin:04/03/23 17:24 ID:Z7lKXe37
どんなシェルだっけ・・・と1分ほど考え込んでしまった。

338 :login:Penguin:04/03/23 21:35 ID:6RV5ur+y
udev入れたら/dev/fb0がなくなりました
試しに/etc/udev/udev.rulesに
 KERNEL="fb[0-9]*",  NAME="%k"
と加えてみましたが、/dev/fb0がつくられる様子がありません
コンソールはフレームバッファで表示されてます
誰かヒントください

339 :login:Penguin:04/03/23 21:39 ID:LOLMGBFZ
sageリリース マダァ?

340 :login:Penguin:04/03/23 21:44 ID:rydKWJ/G
赤帽からの移行を検討しています。

Debianはパッケージ管理が優れてて、何でもパッケージ管理していると
聞きましたが、ApacheやPostgreSQLをソースからコンパイルして
インストールするのは、Debian的には良くないことなのでしょうか?

341 :login:Penguin:04/03/23 22:00 ID:ntKF/PF5
>>340
どう使うかは使う人の自由。
ソースを--prefixを使って公式パッケージとは別にインストールして、起動スクリプトを流用するというのが、
Linuxに限らず商用Unixでもよく使う手ではあるけれど、
debianの場合、パッケージでインストールされているものはアップグレードの時に上書きされてしまうから、
パッケージはアンインストールしなければならない。

342 :login:Penguin:04/03/23 22:28 ID:Q/uWHWdJ
>>340
ソースからインストールする事が良くない仕様だとして
そんな不自由なディストロを使う香具師がいるのかと。

343 :login:Penguin:04/03/23 23:12 ID:95SXA/TZ
>>341
apt-buildでいいんじゃないか?
そういうためのパッケージだし
使った事ないけど

344 :login:Penguin:04/03/23 23:38 ID:Q/uWHWdJ
experimentalにgtk-2.4くるようだな。
unstableに入るのも当分先だろうし、sargeには入らんだろうなぁ…。

345 :login:Penguin:04/03/23 23:46 ID:6RV5ur+y
>>344
たごーさんがMLでunstableに入れろって言ってきたやつらにブチギレてたんで当分ムリでしょう

346 :login:Penguin:04/03/24 00:57 ID:bZmDGJj9
>>342
apt-get source package_name して、./configure の
引数変えるなりパッチ当てるなりして、カスタムパケジ作れば?

ああでも、他のパケジの依存関係等々が気にならないなら、
別に /usr/local に突っ込みまくっても弊害はないよ。



347 :340:04/03/24 04:31 ID:CXl8OGXw
>>341-346
Thanks。これから頑張って修行してDebian使いになります。

348 :login:Penguin:04/03/24 09:01 ID:a70oEZFx
mail-transport-agent とか httpd みたいな、いろんなものに依存してそうな
virtual package に該当するものをソースからいれると、つじつまあわせが
面倒かもね。


349 :login:Penguin:04/03/24 10:36 ID:KtDRw6e3
stableで、なぜかshutdownコマンドが
command not foundになってしまったんです
apt-get installとすると、dpkg ldconfig not found on PATH
などnot found on PATHがいくつか出るようになってしまいました

どうすればいいでしょうか?

350 :login:Penguin:04/03/24 10:40 ID:iOOY1PkD
>>349
http://www.google.com/search?q=dpkg+ldconfig+not+found+on+PATH&ie=UTF-8&oe=UTF-8&hl=ja&btnG=Google+%E6%A4%9C%E7%B4%A2&lr=lang_ja

351 :login:Penguin:04/03/24 10:42 ID:Lt1wjRsY
ここだけの話language-env の存在は悪の要素の方が強いと思うのだ
あまり便利じゃないし

352 :login:Penguin:04/03/24 11:04 ID:iOOY1PkD
>>351
ここだけの話にしないで
しかるべきところに投げた方がいいよ。

353 :login:Penguin:04/03/24 11:17 ID:+MXNuuXu
>>351
そうか?
俺は、あれがなかったらまともに使えるように出来なかったかも。



354 :login:Penguin:04/03/24 11:21 ID:00mHeDdw
ここで何度も見るけど、あれは入門者向けの設定のガイドラインなんだそうな

355 :login:Penguin:04/03/24 13:33 ID:RT5S39k/
libapache2-mod-php4 キタ━━(゚∀゚)━━!!!

356 :login:Penguin:04/03/24 15:45 ID:hUzRS/D3
>>353
俺も、あれがないと困ったかも。
今はともかくDebian入門時はほんと助かった。
あれで設定したのをベースに、自分なりの環境にしていった。


357 :login:Penguin:04/03/24 16:28 ID:IILIjSdB
ウィンドウマネージャのxfce4をwoodyに入れたくて、>>1のスレッドテンプレにあるように
/etc/apt/sources.listにdeb http://jk.genesis-server.org/xfce4 /
と書いてapt-get updateを実行しましたが、失敗したと言われます。
もしかしてアドレスが違うのでしょうか?探してみたのですが、見つかりません。

358 :login:Penguin:04/03/24 16:43 ID:iOOY1PkD
>>357
「失敗したと言われます」じゃ本当は何と出たのかわからないです。
http://linux2ch.bbzone.net/pukiwiki.php#shitsumon

359 :login:Penguin:04/03/24 16:44 ID:iOOY1PkD
>>357
つーか、よく見れ。

360 :357:04/03/24 17:29 ID:IILIjSdB
>>359
Err http://jk.genesis-server.org packages Could not resolve 'jk.genesis-server.org'

faild to fetch http://jk.genesis-server.org/xfce4/Release Could not reolve 'jk.genesis-server.org'

W: Could not stat source package list http://jk.genesis-server.org
Packages (r/lib/apt/lists/jk.genesis-server.org_xfce4_packages - stat (2 No such file or directory)

W: You may want to run apt-get update to correct these problems
E: Some index files failed to download they have ignored ,or old ones of instead

こんな感じです。手書きなので間違っているかもしれません。

361 :login:Penguin:04/03/24 17:34 ID:TeSdxB1g
サーバが消えたかな?

362 :login:Penguin:04/03/24 21:13 ID:maZgokfT
今更だがXFree86の4.4にDRIのsnapshot導入してみた。
X24でもOpenGL関係が感動的に速くなったよ。

363 :login:Penguin:04/03/24 21:14 ID:O0S3M/Pr
そうですか。

364 :login:Penguin:04/03/24 21:38 ID:knV/8FQt
>>357

~$ host jk.genesis-server.org
Host jk.genesis-server.org not found: 3(NXDOMAIN)
~$

俺もこれで挫折した

365 :login:Penguin:04/03/25 00:33 ID:+Q93rHXH
woody から sarge に dist-upgrade して dvipdfmx を入れようとしています。
woody のときに入っていた dvipdfm とコンフリクトするので dvipdfm を
削除しようとしても以下のようなメッセージが出て削除できません。
どうやったら正しく削除できるか誰か教えて下さい。

dvipdfm を削除しています...
Removing `diversion of /usr/share/texmf/tex/latex/graphics/dvipdfm.def to /usr/share/texmf/tex/latex/graphics/dvipdfm.def.tetex by dvipdfm'
dpkg-divert: rename involves overwriting `/usr/share/texmf/tex/latex/graphics/dvipdfm.def' with
different file `/usr/share/texmf/tex/latex/graphics/dvipdfm.def.tetex', not allowed
dpkg: dvipdfm の読み込みエラーです(--remove):
サブプロセス post-removal script はエラー終了ステータス 2 を返しました。。
以下のパッケージの処理中にエラーが発生しました:
dvipdfm
E: Sub-process /usr/bin/dpkg returned an error code (1)

366 :357:04/03/25 00:40 ID:02uz+x7O
あれ、スレッドテンプレが更新されてる?
XFCE4のアドレスが変わってる・・・と思ったら、
さっき非公式パッケージの検索で見つけたアドレスだった。

これは繋がったけどダメだったんですよ。エラーは書き留めてないけど。

367 :login:Penguin:04/03/25 00:59 ID:MXuY3Kn4
>>365
BTSへgo!

368 :login:Penguin:04/03/25 01:31 ID:SegmuTIo
ねえ、mew-3.3のstableへのbackportって、どっかに無い?
もうtestingにしちゃおうかな。疲れちゃったよ。。

369 :login:Penguin:04/03/25 01:53 ID:AhcIJVqq
# apt-get install xfonts-mona
でmonafont入れてみたのですが、X再起動してもmozillaのフォント一覧にmonafontが入った気配が
ありません。どうすればmonafontを使う事ができるのでしょうか?
あと、monafontをXの標準のフォントにしたいのですが、その設定はどうすればよいでしょうか?

370 :login:Penguin:04/03/25 02:35 ID:5prgORFz
>>369
woody, sarge, sid のどれを使ってるのかくらい教えてください。
Xの標準フォントについては良く分かりませんが、
使っている window manager のフォント設定で monafont を指定すればいいのでは?
xfontsel や xlsfonts で現在利用可能なフォントが調べられます。

371 :login:Penguin:04/03/25 02:43 ID:f+ZtkYLH
Debianではなく、apt-getに惚れてたんだ と気付いた

372 :login:Penguin:04/03/25 02:52 ID:uHd0effB
おれはパッケージの多さと free に対するこだわり、あと
健全な国際化感覚が気に入った。
昔 vine 使ってた時は、console で fdisk 使ったら
LANG=C でも日本語が出てきて読めなくて困った。

373 :login:Penguin:04/03/25 03:06 ID:MXuY3Kn4
apt-getがあってもapt-lineやパッケージが少なけりゃ面白くねー罠

374 :login:Penguin:04/03/25 04:11 ID:4aewjZt9
>>369
http://sourceforge.net/project/showfiles.php?group_id=55807

ここからttfなモナを落してみてはいかがしょうか

375 :login:Penguin:04/03/25 04:11 ID:0diYaopf
>>372
それは LC_MESSAGES=C じゃないと日本語でるかも、debianでも。
LC_*ってLC_ALLが優先されるのダサいよね。

376 :365:04/03/25 04:32 ID:+Q93rHXH
>>367
結局 sarge の tetex-base が入っていると dvipdfm が消せない
ということのようでした。woody の tetex-base をいったんインストールして
から dvipdfm を消したら成功しました。

377 :login:Penguin:04/03/25 04:48 ID:4aewjZt9
>>369,374
monafont-ttf-2.90.zip を解凍して
mkdir /usr/share/fonts/truetype/mona して
cp mona.ttf /usr/share/fonts/truetype/mona/ して
fc-cache -v して
はい、おわり。
Mozilla,kwrite,ochusha,xchatで確認しました。

378 :login:Penguin:04/03/25 04:51 ID:4aewjZt9
>>377
おおっと、woodyとかだったら知らないよ

379 :login:Penguin:04/03/25 12:21 ID:yq1meqBL
>>375
優先度がLANG→LC_*→LC_ALL→LANGUAGEなんだから普通だろ。
LC_ALLはLC_*を一時的にリセットする時なんかに使うもんだ。

>>377
をいをい。
手で突っ込むなら/usr/local/share/fontsにしとけよ。

380 :login:Penguin:04/03/25 13:08 ID:4aewjZt9
>>379
商用フォントを持っているなら、/usr/share/fonts/truetype/にでも放り込ん
でfc-cacheを実行すれば、デスクトップ上のフォントとして利用できます。

ある有名な方の投函より。

381 :login:Penguin:04/03/25 13:49 ID:RS8XllWy
>>379
確認するけど、これは右に行くほど優先度が高いという意味なのかな?


382 :login:Penguin:04/03/25 14:03 ID:PG/tr873
>>380
~/.fonts/じゃだめなの?

383 :login:Penguin:04/03/25 14:11 ID:4aewjZt9
>>382
fc-cache で、~/.fonts もスキャンしてるんでよろしいかと。

man fc-cache

384 :login:Penguin:04/03/25 14:55 ID:48XzSjqG
fontconfigとかxftcacheはわかるが
defomaがいまいちわからん。
積極的に使ってる人はどんな理由で使ってるの?

385 :login:Penguin:04/03/25 16:22 ID:1CR7ZZ5K
>>381
ワハハ
LANGUAGE > LC_ALL > LC_MESSAGE > LANG

なんで矢印を使ったのか、書いた漏れも理解に苦しむ(w

386 :login:Penguin:04/03/25 16:27 ID:TJDDMcch
そろそろsargeリリースが見えてきたな

387 :login:Penguin:04/03/25 16:30 ID:Hwrsjn18
sargeはカーネル2.4がデフォルトですか?

388 :login:Penguin:04/03/25 17:13 ID:uHd0effB
サーゲ age

389 :login:Penguin:04/03/25 17:19 ID:qGgRdtd3
sargeのXは4.2.1なのか?

390 :login:Penguin:04/03/25 19:06 ID:SqagC5BP
sargeのKDEは3.2.1なのか?

391 :login:Penguin:04/03/25 20:29 ID:WJhq8JaY
サーゲは2.6できぼんむ

392 :login:Penguin:04/03/25 20:30 ID:8IBWqx2n
Debianって未だにインストーラは2.2?

393 :login:Penguin:04/03/25 22:04 ID:BxL4U7GA
>>387
デフォルトはわからんが、i386用はバニラと読み上げになるみたいだね。
bf24がなくなるから2.4ベースだと思うけどな。

>>392
2.2って何のバージョン?

394 :login:Penguin:04/03/25 23:45 ID:QcsZwJ4z
ここの連中はまったく協力してないのか

たわば!

395 :369:04/03/26 01:26 ID:wyHYpCCO
>>374 >>377
とりあえずその方法でうまくいったのですが、できることならば
# apt-get install xfonts-mona
でうまくいってくれればよいのですが、そうはいかないものなのですか?

いろんなフォントを試してみたのですが、どうもX全体のフォントがぼんやりしているように
思われます。アンチエイリアスを解除するにはどこをいじったらよいでしょうか?

396 :login:Penguin:04/03/26 01:35 ID:J7Eh9Huw
まず window manager とか何か、デスクトップ環境とは何か、
X の仕組み、X のフォントの仕組み、xft の仕組み、
などを調べて、全てを理解しなくてもいいから、
自分なりに問題をしぼり込むといいと思います。


397 :login:Penguin:04/03/26 01:42 ID:rZIDnhWH
>>395
xfonts-monaにttfなfontはないだろ。
そのくらいaptitude等で簡単に調べられるんだから、調べてから発言してはどうか?

398 :login:Penguin:04/03/26 01:45 ID:r23gKwgw
>>395
woody? sarge/sid?

399 :login:Penguin:04/03/26 02:03 ID:H5VodzNv
>>395
アンチエイリアスをオフにする
GDK_USE_XFT=0

400 :369:04/03/26 02:07 ID:wyHYpCCO
>>398
sid

>>396-397
申し訳ありません。まだX window systemのどの点が問題なのか把握していないようです。
フォントの仕組みなどをもう少し勉強して出直してきます。

401 :login:Penguin:04/03/26 02:30 ID:3zKCvMdg
Sidのtetex-base(2.0.2-6)のarray.styが壊れているっぽい
$ platex hoge.tex(/usr/share/texmf/tex/latex/tools/array.sty)) (./hoge.aux))
! Incomplete \iffalse; all text was ignored after line 9.
<inserted text>
array.styの
\def\@arraycr{\relax\iffalse{\fi\ifnum 0=`}\fi
\@ifstar \@xarraycr \@xarraycr}
が間違っていると思うんだが、分かる人いる?



402 :login:Penguin:04/03/26 11:32 ID:XSMpNxlc
>>401
BTSへgo!

403 :login:Penguin:04/03/26 17:40 ID:AiOyoL+8
kernelを2.6.4 にしたら、grub でrootがマウントできなくなった。
2.6.3までは問題なかったのに、root=bootオプションを指定しろみたいなメッセージが出る。
指定してるだろうが。
ためしに、2.6.5をコンパイルしてみたが、やはりだめだった。なんでだ。
誰か同じような症状の人いませんか。
grub側の問題のような気もするが、分からん。

404 :login:Penguin:04/03/26 17:53 ID:wwuVUsQL
>>403
2.6.4で動いてまつ。(sourceから構築しますた)。
別にroot=オプションとか付けてないけど大丈夫だよ。
漏れはgrubじゃなくてliloを使ってるけど。

kernelじゃなくてgrub側の問題かもね。

405 :login:Penguin:04/03/26 17:53 ID:3ZW1Ksbq
どうぞ。
http://linux2ch.bbzone.net/pukiwiki.php?About#shitsumon

406 :login:Penguin:04/03/26 18:41 ID:AiOyoL+8
>>404
ありがと、もっと色々試してみる

>>405
あっ、それから、あんたもありがと、夜道は気をつけてね、

ではであ。

407 :login:Penguin:04/03/26 18:52 ID:tMSPvf8+
おどし?

408 :login:Penguin:04/03/26 18:58 ID:EUbCydci
テストバージョンをftpインストールすると
パッケージインストールのところでなんか赤くなって関数なんとかエラーで止まちゃうけど
使うなってことでしょうか?

409 :login:Penguin:04/03/26 19:06 ID:GVU4EFJg
そう

410 :login:Penguin:04/03/26 21:55 ID:OxNn0oJ9
>>395
ttp://utyuuzin.net/debian/dists/original/unstable/binary-i386/ttf-mona_2.90-1_all.deb

411 :login:Penguin:04/03/26 23:28 ID:oV0/Y1FW
>>401
Woodyでもその部分は
\def\@arraycr{\relax\iffalse{\fi\ifnum 0=`}\fi
\@ifstar \@xarraycr \@xarraycr}
だけど、array.sty自体じゃなくてhoge.texがどっか間違ってる
ってことはないでつか?

412 :login:Penguin:04/03/27 00:22 ID:MT5cGCUQ
2.6.4のelfconfig.hがまちがってる

413 :login:Penguin:04/03/27 00:35 ID:MT5cGCUQ
ちがった。modpostだな。

414 :login:Penguin:04/03/27 00:45 ID:MT5cGCUQ
連続投稿スマソ。
どっかに使えるmodpostのバイナリ落ちてませんかね。
これがないとモジュールが作れない。
linux/scriptsの中にあるmodpost.cはコンパイル失敗します。

415 :login:Penguin:04/03/27 09:57 ID:SJFdouKq
>>264
アリガトン

416 :login:Penguin:04/03/27 21:46 ID:c2pY2qHt
>>411
\section{\ruby{漢字}{かんじ}}
とやってた俺が馬鹿ですた。吊ってきます…


417 :login:Penguin:04/03/27 23:47 ID:0yxuVKXf
イキロ

418 :login:Penguin:04/03/28 10:53 ID:Fp0XiWM9
sarge-i386-netinstってpcmcia使えんの?

419 :login:Penguin:04/03/28 11:29 ID:fsTWEzv2
おい、sidをアプグレドしたらsylpheedのアカウント
全部消えたぞどうしてくれるんだよ!

420 :login:Penguin:04/03/28 12:24 ID:IZYufO7U
ぷぷぷ。ばっかでー

421 :login:Penguin:04/03/28 12:59 ID:GaArXAol
sylpheedは去年から放置プレイ中だぞ?
その前にupgradeしたのはいつだよ。

422 :login:Penguin:04/03/28 14:24 ID:43BgL9Mu
>>419

 あのよー sid使いだろ?見苦しいぞ。
 backportsでも使っとけ

423 :login:Penguin:04/03/28 15:03 ID:npb0HfjI
Debian woodyのemacs21。
起動すると画面が上下2分割されるんだけど、分割せずに起動する設定ってどうやるの?
今のところ、起動する度にCTRL+X+1ってやってるけど、面倒臭いので何とかしたい。

424 :login:Penguin:04/03/28 15:04 ID:MjN2tOKd
>>423
なんで分割されるんだ?

425 :login:Penguin:04/03/28 15:14 ID:csHyeOyn
房質問ですまんが、そんなにDebianって安定してるのか?
ttp://japan.linux.com/enterprise/04/03/26/1547203.shtml
以下引用
> Debianの「不安定版」は、最低でも、ほとんどの商用Linuxベンダの最新リリースと同等の安定性を持つと考えられている。
> 「テスト版」はそれよりもさらに強固であり、「安定版」ともなれば、その他すべてのディストリビューションが安定性の面で参考にする、絶対的な基準である。
> 〜〜〜
> しかし、幅広い層のユーザに対し最良の選択肢を提供するという意味で、Debian方式が最も優れていることが証明されている。

426 :login:Penguin:04/03/28 15:21 ID:SWny3ovz
>>423
エラー原因を除去せよ。

427 :login:Penguin:04/03/28 15:22 ID:SWny3ovz
>>425
誉め杉だと思うけど、安定運用にはDebianだと思うよ。

428 :login:Penguin:04/03/28 15:31 ID:Lm119H+Y
なんだろこれ

lrwxrwxrwx 1 root root 57 2004-03-28 14:34
/etc/dev.d/default/udev_selinux.dev
-> /USR3/src/P/udev/udev-0.023/debian/udev/sbin/udev_selinux


429 :login:Penguin:04/03/28 16:15 ID:3re+AcBK
>>428
Bug#240517

430 :login:Penguin:04/03/28 16:40 ID:fsTWEzv2
>>420
くう〜

>>421
つい一週間前のことだぞ。sylpheed自体は
バージョンアップしてないから、原因は
他にありそうだな。

>>422
根性でアカウント作りなおしたぞ。
パスワード思い出すの苦労したぜ。

431 :425:04/03/28 17:06 ID:csHyeOyn
430を見るに、やっぱりこれは嘘なんだな!
> 「Debianの「不安定版」は、最低でも、ほとんどの商用Linuxベンダの
> 最新リリースと同等の安定性を持つと考えられている。」
やはりテスト版を使ってる漏れは間違っていなかったw

432 :login:Penguin:04/03/28 17:15 ID:MjN2tOKd
>>425
根拠がまったく示されてないから
こんなの鵜飲みにしちゃいかんよ。

433 :login:Penguin:04/03/28 17:34 ID:HRrMqU/y
>>431
つーか、どういう意味での安定性を期待してる?
sidでも1回ごとの安定性はある程度期待できるが、
更新頻度がハンパじゃないから、いつかは地雷を踏むことになるよ。


434 :login:Penguin:04/03/28 17:50 ID:npb0HfjI
>>426
ありがとう。
メッセージ読んでみたらeggが無いって書いてあった。
入れたはずなのに……思いながらもう一度入れ直してみたら直ったよ。

>>424
という訳で、エラーがあると画面が分割されて下側にメッセージが出るようです。

435 :425:04/03/28 18:03 ID:csHyeOyn
>>432
たとえ適当な根拠があっても、さすがにこれは言い過ぎですよねw
ただsid入れてみようかと思う程度には気になる文だったのですよ。

>>433 人柱にはなりたくないのですよ。
ソフトの入れ直しまたはアップデートを緊急に必要とするバグは困ります。
できれば暇なときにアップデートできるくらいの余裕が欲しいですね。
漏れは地雷踏むのを楽しめるような人間ではないですし
起動しなくなったりしては復旧など出来ませんからね。

436 :login:Penguin:04/03/28 18:12 ID:3re+AcBK
>>435
> 人柱にはなりたくないのですよ。
そんなあなたに相応しいのは stable です。

437 :login:Penguin:04/03/28 18:13 ID:npb0HfjI
>>431
アップデート時にトラブルに見舞われる危険性を孕んでいるのはどれも同じ。
例え商用ディストリでも。(全バージョンとの互換性なんかの問題もあるし)

ていうか、安定運用が目的ならセキュリティフィクス以外はアップデートしない方が良いと思うんだけど。

438 :教えて下さい:04/03/28 18:30 ID:vlVLMoq+
スレ違い&くだらない質問かもしれませんが、
デビアンパッケージはどうすれば展開出来るのでしょうか?
当方リナザウ使いなのですが、携帯でやっとの思いで落として来たファイルが.debだったのです。
現在、海の上でググれないので、教えて頂けないでしょうか?
おねがいします。


439 :login:Penguin:04/03/28 18:33 ID:7NjxuGcC
あのぉ、ちょっと聞いてもいいでしょうか。
debian sid で kde3.2.1 使ってるんですけど、
アプリのmenu がどうもおかしくなって、--force-overwrite したためだと思うんですけど、
テキストがありません! なんて感じで、でもクリックするとサブメニューはあるんです。
ただし、二重に出てきますけど、
ところで、どのファイルにメニューのテンプレートってあるんでしょうか。
それか、一番いいのは、どのdebファイルをreinstall すればいいですか。
知ってる方、教えてください。
お願いします。

440 :login:Penguin:04/03/28 18:34 ID:7NjxuGcC
あっ、すいません、忘れてました。
kde-su もエラーが出るんです。
お世話をかけます。

441 :login:Penguin:04/03/28 18:35 ID:MjN2tOKd
>>438
http://debian.fam.cx/index.php?AptGet#content_1_21

442 :430:04/03/28 18:38 ID:FC3V0nsc
>>425
あ、俺がいうのもなんだがsidは
そんなに怖いモンではないよ。

今回のはどういうタイミングでかしらないが
.sylpheedのaccountrcのデータがそっくり
消えてて、思いあたるのは昨晩寝るまえに
アプグレドしたということだったわけ。

最近、そういえばfirefoxのブックマークが
消えてたことがあったので、なんかが作用して
いるのは間違いなさそう。

443 :login:Penguin:04/03/28 18:53 ID:7NjxuGcC
Lindowsためしに入れてみたんだけど、なんであんなに重いんだ。

444 :login:Penguin:04/03/28 18:56 ID:MjN2tOKd
>>443
Lindowsスレ
http://pc3.2ch.net/test/read.cgi/linux/1077026075/

445 :login:Penguin:04/03/28 20:03 ID:d0/0b0/+
            ∫    _________
   ∧,,∧     ∬   /
   ミ,,゚Д゚彡っ━~  < >>1を嫁や、カス共
_と~,,  ~,,,ノ_.  ∀   \
    ミ,,,,/~), │ ┷┳━   ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄
 ̄ ̄ ̄ .じ'J ̄ ̄| ┃
 ̄ ̄ ̄ ̄ ̄ ̄ ̄  ┻

446 :login:Penguin:04/03/28 20:09 ID:UQclGePY
玄箱で遊んでいるんですが、libc6をdpkg使用としたところ、

dpkg: error processing libc6_2.2.5-11.5_powerpc.deb (--install):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
libc6_2.2.5-11.5_powerpc.deb

と言われます。
デバッグをしたいんですが、dpkgってどこかに標準エラー出力の内容を吐いてくれてないんでしょうか?


447 :438:04/03/28 20:11 ID:vlVLMoq+
>>441
ありがと


448 :login:Penguin:04/03/28 20:28 ID:5eihpvip
>>431
testing内だけで常に依存関係が満たされてるとは限らないから
dist-upgradeするとごっそり削除されることあるぞ。

unstableでもそういうことあるけど、たいてい翌日にはなんとか
なってる。

unstableでも十分安定してると思うけどな。
正式リリースでコンパイルできないkernel-sourceを入れてた
Vineなんかよりはましだろう。

449 :login:Penguin:04/03/28 20:30 ID:5eihpvip
>>442
FIrebirdからFirefoxになって、設定ファイルのフォルダが
.mozilla-firebirdから.firefoxになった、とかではなくて?

450 :login:Penguin:04/03/28 20:44 ID:d0/0b0/+
>>446
preinstスクリプトを煮るなり焼くなり好きにすればよいのでは。

日本語パック入れたらブックマーク消失、って目には合った事あるな。

451 :login:Penguin:04/03/29 00:03 ID:c6XUI8Tg
>>446
/var/lib/dpkg/info/libc6.*

452 :login:Penguin:04/03/29 16:15 ID:UexNR/9i
あるパッケージを入れるときにいろいろ関連パッケージを入れられることがありますが、
いらなくなったときにはまとめて消したいですよね。手軽にやる方法はありませんか?

apt-cache の depends と rdepends で依存関係を取り出せるのでがんばって追いかける
という方法は思いつきますが、手でやるのはちとつらいのでなんかそれっぽい便利な
ツールでもあると嬉しいなと。


453 :login:Penguin:04/03/29 16:29 ID:9OpAqt5j
>>452
# orphaner --purge -a
とか?

454 :login:Penguin:04/03/29 17:09 ID:qXXjtXyO
sarge に xfree-4.3.0 キターね

455 :login:Penguin:04/03/29 17:10 ID:fw7OEET2
おれは
% apt-cache show `deborphan|xargs` |less
こうやって一応確認してから、
% apt-get --purge remove `deborphan|xargs`
これで消してるよ。

456 :login:Penguin:04/03/29 17:28 ID:D3SjtTOr
Sargeをインストールしようとしてるのですが、taskselの画面で出てくる「Linux Standard Base」は選択するほうがいいのでしょうか?

選択肢を選んだときの説明文では、役割がいまいち理解できませんでした。

457 :login:Penguin:04/03/29 17:47 ID:D3SjtTOr
456です。
すみません、ぐぐる前に質問してしまいました。
選択するほうがベターなようですね。

458 :login:Penguin:04/03/29 17:52 ID:T/x6xvGo
>>455
よくわからないんですが、そのxargsには意味はあるの?

459 :455:04/03/29 17:56 ID:fw7OEET2
一行にまとめてるつもりだったんですが、
なくてもできるみたいです。
というか backquote すると、何でも無理矢理一行にさせられるみたいですね。
知らなかった。
echo `ls -1`

460 :login:Penguin:04/03/29 19:06 ID:uLqzSptp
ちょっとすんません.質問です.
unstableにupgradeしたら,xfontselとかemacsで
Unable to load any usable ISO8859 font
ってエラーがでるんですけど,俺だけ?
直し方知ってる人いませんか?もしかして,既出だったりする?
よろしこ.

461 :login:Penguin:04/03/29 20:55 ID:RnFQThHn
>>460
sid使いになった記念にテメェで解決してみてください

462 :login:Penguin:04/03/29 21:00 ID:31UBiepO
>>439 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=239260 の件
でしょうか。うちではmenuを2.1.9に戻して回避してます。

463 :login:Penguin:04/03/29 22:10 ID:UexNR/9i
>>453
>>455
なるほど、deborpanというのがあるんですね。orphanerはdeborpanの
フロントエンドと。なんかあるだろうとは思いましたが、自分では探せ
ませんでした。ありがとう。


464 :login:Penguin:04/03/29 23:12 ID:+hnj9j8z
テンプレサイトに書いてあるだろ。

465 :login:Penguin:04/03/29 23:23 ID:UexNR/9i
>>464
えーと思ってもう一度orphanで検索したらTipsのページにありました。ここ見たんだけど、
「パッケージについて」のところにそれっぽいのがなかったのでそれ以上はさがさなかった
んですよね。「環境について」の「少しでもディスクを節約したい」に書いてあったとは...
ディスク節約したかったわけじゃないので目に入りませんでした。


466 :login:Penguin:04/03/30 00:05 ID:6eE8PRdc
過去スレにも幾度となく出てるが

467 :login:Penguin:04/03/30 02:02 ID:raapba6E
>>465
わかりやすく書き直しといてよ。

468 :login:Penguin:04/03/30 02:04 ID:raapba6E
>>459
> というか backquote すると、何でも無理矢理一行にさせられるみたいですね。
え?

469 :login:Penguin:04/03/30 09:34 ID:yoNBxken
>>462

なんとかできました。
ありがとうございます。感謝、感謝。

470 :login:Penguin:04/03/30 10:03 ID:d9ZYZBRo
>>466
「パッケージ」「依存」とか「パッケージ」「削除」とかで過去スレ検索しても
なかなかそれっぽいのにはあたらなかったんですよね。deborphanで検索
すればみつかりますが、知ってたらそもそも調べる必要ないわけで。



471 :login:Penguin:04/03/30 11:01 ID:+vB2xZFp
xorgマダー?

472 :login:Penguin:04/03/30 11:07 ID:d9ZYZBRo
結局こんなふうにやりました。

1. deborphan -a --no-show-section | sort > foo
2. apt-get remove 削除したいパッケージ
3. deborphan -a --no-show-section | sort | comm -23 - foo > baa
4. baaの中を見る。空なら終わり。必要なパッケージがあればfooに追加して3へ。
5. apt-get remove `cat baa`
6. 3に戻る。


473 :login:Penguin:04/03/30 11:18 ID:ApCTMVrY
>>472
テンプレに追加しといてよ。

474 :login:Penguin:04/03/30 11:46 ID:XKNfNFmn
それを自動化するスクリプトキボンヌ

475 :login:Penguin:04/03/30 12:04 ID:pR9PK2++
>>474
自動でやるのコワクね?

476 :login:Penguin:04/03/30 12:09 ID:I5UNbnV6
手動も怖い
間違えた時が

477 :login:Penguin:04/03/30 12:09 ID:7+Ipkkq3
じゃあ手動で進む自動スクリプトなら安心だ

478 :login:Penguin:04/03/30 12:13 ID:X92F9u5e
僕はお父さんに任せてますが、それはそれで怖ひ

479 :login:Penguin:04/03/30 13:31 ID:oqM2MQTm
aptitude とか使ってれば楽なのに。
他の package に必要だから入れるやつには、専用の印がついてく。
その印がついてる package は、必要じゃなくなった時点で削除される。
この印を手動でつけたり消したりもできるし、便利だよ。

480 :login:Penguin:04/03/30 14:17 ID:+ymqJsAm
参考になる

481 :login:Penguin:04/03/30 17:07 ID:gl/sPtF/
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=237509

Another workaround is simply to move or delete
/usr/X11R6/include/X11/Xft/Xft.h, getting it out of the way.

482 :login:Penguin:04/03/30 17:30 ID:/U/4tp+6
debfosterってのもあるな。

483 :login:Penguin:04/03/30 20:36 ID:03JlYO9i
aptitudeのpoがほとんど翻訳されてない様子
サラッと眺めて、ちと気になった部分

>依存関係を満足するためにインストールされるパッケージ
依存関係を満すためにインストールされるパッケージ

>Compressed size
>圧縮サイズ
圧縮時サイズ

>Uncompressed size
>展開サイズ
展開後サイズ

>DebSz
>Deb 量
チトワロタ

セクションのmainだけメインと翻訳するなら、翻訳しない方がいいんじゃないの
禿しくバランス悪いしカコワルイ

484 :455:04/03/30 21:25 ID:f9e4EFTp
>>468
違うの?

485 :jj:04/03/30 22:14 ID:xYwfHTBy
DebianでIntel Fortranの秘商用バージョンを使っています.

Ver.7.1で,古いpentium機にインストールしたところ,ちゃんと動いていたのですが,
(alienで変換し,地球流体電脳倶楽部さんのdebファイルを使って設定)

Pentium4機に全く同じ手順でインストールしたところ,コンパイルができなくなりました.

具体的には,intarnal compiler errorとでます.
(stopとend文しかないようなものでも)

なにか考えられる原因がありましたら,ご教授頂けないでしょうか?

環境.
インストールフロッピーのCompactからインストール,キャラクタベース.
カーネルは2.2.20です
(もちろんIFCの動作対象外ですが,pentium機では動いていましたので..).

486 :login:Penguin:04/03/30 22:24 ID:X92F9u5e
sub programの実行に失敗してんじゃねえの?
$ ltrace -f ifc foo.f
$ strace -f ifc foo.f
など。

487 :login:Penguin:04/03/30 22:29 ID:sAMD3tVA
インストール済みのパッケージ名だけ出すにはどうしたらいいのでしょうか?
再セットアップ時にapt-get install にぶちこめたら楽だと思いまして。

488 :login:Penguin:04/03/30 22:33 ID:jgmDOGXv
>>487
dpkg --get-selections と dpkg --set-selections


489 :login:Penguin:04/03/30 22:55 ID:sAMD3tVA
>>488

なるほどー、こんな便利な使い方があるのか。ありがとうございました。

490 :login:Penguin:04/03/30 23:36 ID:X92F9u5e
COLUMNS=180 dpkg -lでもいいじゃん

491 :login:Penguin:04/03/30 23:37 ID:X92F9u5e
| tail +6しないとまずいか。dpkg -lは。

492 :login:Penguin:04/03/30 23:39 ID:Xkesc2Q3
>>490
リストを見ながらapt-get install hogehogeを繰り返せと言うのですか?



493 :login:Penguin:04/03/30 23:41 ID:LNk3kMRm
sargeは5月4週以降で確定でつね。
kmutoさんとこ見れ。

494 :login:Penguin:04/03/31 00:46 ID:BBhXeA0X
ATOKX ga tukaenaku natta
with KDE3.2,X4.3,,,,,
nani ni izon suru mondai nanoka wakaranai.

@debian sid/

$. ~.xsession
[1]+ Segmentation Fault /usr/lib/im/httx -if atok12 -lc_basiclocale ja_JP -xim htt_xbe

495 :login:Penguin:04/03/31 01:24 ID:NYuW8Kfx
upgradeした後やたらと重いのでtopしてみたら、
firefoxがCPU独占状態。

mozilla-firefox_0.8-7

496 :login:Penguin:04/03/31 01:32 ID:eWeZmCqk
>>495
ウチはそんなことねーぞ。
MEMは一番喰ってるけど(つってもたいしたこたねぇ)

497 :login:Penguin:04/03/31 03:16 ID:vLasL2l2
>>492
続きはshellスレあたりで。

dpkg -lならversionも分かるよ。
get-selections形式への変換も簡単だし。

498 :login:Penguin:04/03/31 06:20 ID:t6n6GlHk
sidのdiaで日本語入力がちゃんとできなくて困ってない?

変換中の下線つきの文字が表示されなくて、
変換後に文字の後半部分がなくなってる。

Dia Bugzilla, Debian BTS, Debin jpML検索, Debian 2chスレ検索
まだどこにも報告がないようだ。

こんな派手なバグ、誰も気づかないってことはないはずだが?

あ (あを1回入力)
あ (あを2回入力)
ああ (あを3回入力)
ああ (あを4回入力)
ああ (あを5回入力)
あああ (あを6回入力)
あああ (あを7回入力)
あああ (あを8回入力)
ああああ (あを9回入力)
...

dia 0.92.2-5 sid
kinput2-canna 3.1-3 sid
canna 3.7-4 sid

499 :login:Penguin:04/03/31 06:24 ID:nrExv2Bn
>>498
sargeもかも。

500 :login:Penguin:04/03/31 06:32 ID:t6n6GlHk
>>498

int(n/3) + 1 ?

ああああ (あを9回入力)
ああああ (あを10回入力)
ああああ (あを11回入力)
あああああ (あを12回入力)
...


501 :sage:04/03/31 06:48 ID:t6n6GlHk
>>499

てことは、
sargeのdia 0.92.2-3 ですでにダメってことか。
woodyのdia 0.88.1-3 は大丈夫?

0.92.2か0.92か0.91のどこかっぽい。

dia使っててapt-get updateさぼってる人、
OKかNGか、バージョンいくつか、教えて。

ひさしぶりにdia使ったから、
どの時点でバグが出たかわからん。

あとはsnapshot使って一個づつ検証か、、
めんどうだな、、、


502 :login:Penguin:04/03/31 06:51 ID:t6n6GlHk
>>501

sage書くとこ間違えた。

503 :login:Penguin:04/03/31 12:27 ID:D2yaoy2g
誰も使ってないんじゃないの(ワラ

504 :login:Penguin:04/03/31 12:41 ID:UHbFfNM1
gimp2.0マダーチンチンマチクタビレター

505 :login:Penguin:04/03/31 13:00 ID:Z4CfDgn0
sidを使っていて,w3mを0.5-5に更新したら,
ブックマークが文字化けするようになった.
結局bookmark.htmlでcharsetを設定していないと化けるようだ.
<head>に
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=EUC-JP">
を追加したら読めるようになった.


506 :login:Penguin:04/03/31 16:27 ID:enkmlqbq
udev入れたら2.6でカーネルモードpppoeが使えなぃぃぃ。
dbus-1がサポートされるようになった辺りからこんなメッセージが出る。
>Linux kernel does not support PPPoE -- are you running 2.4.x?

ハァ?

507 :login:Penguin:04/03/31 16:52 ID:I5AwSspL
KVMスイッチの事で質問が有るのですが、、
http://www.princeton.co.jp/product/kvm/pkvppa_pua.html
これのPUAの方を購入したんです。が、マウスとキーボードがUSB接続なんですーー;
Linux対応と買いてあるので差し込んだら自動的に認識するだろうと予測したのですが、
自動的に認識せず、カーネルを2.4にしても上手く認識しません。
で、再インストールを実行し、インストール時の認識を求めているのですが、
BIOSの設定でUSBキーボードを有効にすれば、始めのBoot; のプロンプトまでは操作でき、
そこでEnterを押すと操作出来なくなります。(bf24も同じだった)
認識させる方法が別る方いらっしゃいましたら、どうか答えてくださいませんか

508 :login:Penguin:04/03/31 17:39 ID:t6n6GlHk
>>503
確かに。
ネットワーク図とかUMLとかはvmwareのwindowsでvisio?
そろそろvisioはやめたいよ。


509 :login:Penguin:04/03/31 19:15 ID:uQ6ghWh1
>>507
sargeインストーラを試してみる。

510 :login:Penguin:04/03/31 21:43 ID:NHJHT0RC
>>507

knoppix 試してみるのどうよ?


511 :jj:04/03/31 22:23 ID:7a9Jd4Eb
485のものですが,その後無事に解決しました.
(straceも参考になりました)

結局,カーネルをアップデートしただけなのですが,一発で良くなりました.
ただ,Pentium1機で動いていたのは謎ですが.

512 :login:Penguin:04/03/31 23:59 ID:Dl6EEHZc
WoodyのTips。

【2.6系kernelを入れるとDHCPでアドレスを取得できない】
Woodyにデフォルトで入ってるdhcp-clientは2.6系kernelに対応していない。
(カーネルのバージョンチェックに2.6以降が無い模様)

apt-get install dhcp3-client

でバージョンアップすべし。

これに嵌って、解決に3日ほど掛かってしまった……
ググっても情報が出てこなかったんだけど、これって割と常識?

513 :login:Penguin:04/04/01 00:02 ID:3xymnN6B
ちょっと前にこのスレで読んだ気もする。

違ったらスマソ。

514 :login:Penguin:04/04/01 00:04 ID:5eD+i3Jq
>>512
woodyに2.6入れようと思う人自体少ないからだろう。
あと、デフォルトのdhcpclientじゃなくて、dhcpcdを使う人も多いし。

515 :login:Penguin:04/04/01 00:10 ID:18WD+F0G
>>512
今までどうして dhcp-client でやっていけてたのか...漏れには信じられんが。


516 :login:Penguin:04/04/01 01:37 ID:gQcGLH8V
dhclient2.2 みたいのなかったっけ?

517 :login:Penguin:04/04/01 01:59 ID:h62yMBHQ
>>514
確かにstableなシステムにunstableな今の2.6.xを入れる奇特な香具師限定だな。

sargeにした方が色々と楽だろうし、どんな用途に使う気なのか聞いてみたい。

518 :login:Penguin:04/04/01 02:06 ID:gf64OuEK
テンプレをよく読んでから、メインのSuSE8.2を消して、Woody => sid環境にしてみた。 Debianは初めてだけど、AirH"でパッケージ入れながら眠りにつきます(/_-)

519 :login:Penguin:04/04/01 02:12 ID:3xymnN6B
>>515

dhcp-clientって何がダメなの?
IP取得できなかったとかいうような経験は無いんだけどなぁ。
それとも、表面化しないけどひどい不具合(って何だ?)とか
あるんでしょうか?

今までずっとデフォルトのままdhcp-client使ってるんで
ちょっと気になりました。

まずい理由を教えてくださいまし。

520 :login:Penguin:04/04/01 05:27 ID:5rNEYdTn
>>515
sidでkernel 2.6だけど
dhcp-client 2.0pl5-16.1で特に困ってないなぁ。




521 :login:Penguin:04/04/01 12:43 ID:/mL0pTr3
肉博士のdebパッケージキター
http://download.gna.org/kazehakase/debian/

522 :login:Penguin:04/04/01 14:41 ID:in6qAlmL
>>517
Woody で XFS と cryptoloop を、カーネルパッチ無しで使いたい。

XFSは2.4.25でつかえるようになったけどな。

523 :login:Penguin:04/04/01 15:52 ID:knXUAtNt
それにしても、2.6.Xは無茶苦茶早いよね。
速度面の改善が一番の魅力だ。

XFSのパッチの当たってるカーネルのインストーラーから、インストールしてみたけど、
netカードがモジュールだと認識しなかった。
8136too,via-rhine,tg3 もだめ。
仕方なく、Woodyに戻して、カーネルの2.6.4をダウンして、CDに焼き、もう一度インストール。
CDからカーネルソースをコンパイルして、ようやく、rootがXFSになった。
俺は馬鹿か?


524 :login:Penguin:04/04/01 16:57 ID:uLXMnv8v
ググるとベンチ結果が結構引っかかるが、そのほとんどで2.6は2.4より遅いと出てる。

結果の信頼性はさて置き。

525 :login:Penguin:04/04/01 18:48 ID:knXUAtNt
>>524

そうなんだ。初めて知った。
でも、体感速度は全然違うな。

526 :login:Penguin:04/04/01 21:14 ID:pky/2Bs+
前、zsh-4.1.xがだめだとかいう話があったけど、
あれってもう改善されたの?

527 :login:Penguin:04/04/01 21:21 ID:6telRXNp
>>526
一時的にかなりの補完設定が消えてしまったことがあります。
今は多くの補完設定が 4.2 から取り込まれたので、
個人的には、実用上の問題はないと思います。

不安だったら、今使っている ver. の .deb を残しておいて
新しいのを試すと良いでしょう。


528 :login:Penguin:04/04/01 21:35 ID:8CDIRhb8
>>525
スレ違いだが、体感速度が違うくらい変ったなら、
2.4.Xで何か問題があったと思われ。

529 :login:Penguin:04/04/01 21:43 ID:pky/2Bs+
>>527
情報サンクス。

>>528
私も2.6にしたらすごくレスポンスがよくなったよ。
動画再生時のCPU占有率も70%くらいから50%くらいまで下がったし。
ただ、古いノートのせいかサスペンドからうまく復帰できないので2.4に戻したけど。

530 :login:Penguin:04/04/01 22:10 ID:6telRXNp
>>505
今更だけど、o 押して以下のように設定しても駄目かしら?
文書の読み込み時に文字コードを変換する (*)YES ( )NO

531 :512:04/04/01 22:17 ID:nPqOUOiN
>>517
主な用途はデスクトップ兼ファイルサーバ。

stableをベースに新しいのが必要なものだけバックポートから借りることにした。
(詳しくないソフトは特に最新にする必要はないので)

2.6系kernelはスケジューラの変更があって、動作が軽快になるという話を聞いたので入れてみた。
2.4系に比べて確かに(体感的には)軽い。
あと、WorkbitのSCSIドライバが狙いだった。
ちなみに入れたのは本家のkernel2.6.3+wolk1.0。

……でも、sargeが次期安定板としてもうすぐリリース予定だったんなら、sargeを入れてもよかったかも。

>>519
同じく知りたい。

>>520
sidだといけるんだ。
woodyだと"Unrecognized kernel version"(だったと思う)というエラーを吐かれた。

>>524
オプションの設定やハードの構成に依るかと。
少なくともうちでは体感速度は速い。

532 :login:Penguin:04/04/01 23:40 ID:WLxgRzfh
軽快に感じるのは不公平なスケジューリングの恩恵だろう。
負荷がかかった状態でもGUIの応答性が悪くなりにくい。
GNOMEやKDEを中心に使ってる香具師にはうれしいかモナー。

533 :login:Penguin:04/04/02 05:06 ID:bER9O/yM
このスレに書くべきことか分かりませんが……

Window MakerのMENUの表示で文字が表示されない項目があるんです。
で、表示されない項目の上にポインタを合わせると文字が表示されるんです。
これってXの設定が悪いために起きる現象なんでしょうか。
XF86Config-4ファイルの水平垂直周波数の設定を正確に入力しても
この障害は改善されませんでした。
これと同じ現象に遭遇された方はいらっしゃませんか。


534 :login:Penguin:04/04/02 06:00 ID:aOlpwc47
>>533
Window ManagerスレへGO!
http://pc3.2ch.net/test/read.cgi/linux/1030639033/

535 :login:Penguin:04/04/02 07:18 ID:XWOQX2VK
sid に Gimp 2.0 来ましたなぁ。

536 :login:Penguin:04/04/02 10:06 ID:mMS7Flmc
>>535
情報thxです。

今日だけ本家apt-line使わせていただきました。
我慢できなくて、ゴメンナサイ、、、

537 :login:Penguin:04/04/02 11:05 ID:kbmwMczt
>>536
gimp1.3だとgimp2.0のrcが入ってたと思うけどそれじゃ駄目だったの?


538 :login:Penguin:04/04/02 12:12 ID:TUwsUAcS
玄人志向の玄箱にdebianをインストールした勇者はいらっしゃいますか?
やってみたいんだけど,何からはじめればいいかサパーリ…

539 :login:Penguin:04/04/02 12:59 ID:jJkIv+Hh
w3m0.5-5で日本語manが化けるぞゴルァ!

540 :login:Penguin:04/04/02 13:20 ID:OSlXqsOn
>>538
dpkgとaptとsshをいれなさい
それからあとはいっしょ。

別マシンでハードディスクに展開してから
そのハードディスクを組み込めばいい。
デフォルトはパスワードがテキストで保存さえれテルから
ユーティリティなんぞ使わんとやれ!

541 :538:04/04/02 14:39 ID:TUwsUAcS
>>540
ありがとうございます。
dpkg,apt,sshをユーティリティをつかわずに
あらかじめ別マシンに繋いだハードディスクに入れてから
玄箱につなぎ,debian化の作業を始めるってことしょうか?

なんか右も左もわからないって感じです。
こういう輩はやめておいたほうが吉なんですかね・・・?

542 :login:Penguin:04/04/02 15:00 ID:7NXZz8wH
>>541
> こういう輩はやめておいたほうが吉なんですかね・・・?
だな。

543 :login:Penguin:04/04/02 16:53 ID:U2DBj03+
4/1に apt-get update, upgrade したら、マウスが使えなくなりました。
Xは立ち上がるのにカーソルがうごきません。なんででしょうか。
sarge で、PCは ThinkpadX31 です。

544 :login:Penguin:04/04/02 18:14 ID:R5lWskhj
>>543
XF86Config-4にどう書いてるのか、そもそもUBSなのかPS/2なのか。
モジュールにしてるならちゃんと読み込んでいるのか。
エスパーじゃないんで情報を晒してください。


sidに風博士きたね。

545 :login:Penguin:04/04/02 20:25 ID:8P+qLrKJ
>>544
>そもそもUBSなのかPS/2なのか。
あれじゃね
キーボードのまんなかについてるチンコ

546 :login:Penguin:04/04/02 20:31 ID:7NXZz8wH
>>545
あれをマウスとは呼ばないでしょ。

547 :login:Penguin:04/04/02 21:18 ID:QYmydy3F
ポインティングデバイスをすべてマウスと呼んでいそうな悪寒。

548 :login:Penguin:04/04/02 21:30 ID:p8mrHD6l
アキュポイントのことだな

549 :login:Penguin:04/04/02 23:04 ID:qzFH9sOG
それは東芝のヤツじゃなかったっけ?
IBMはチンコポイントだろ。

550 :login:Penguin:04/04/03 10:54 ID:NBUw4jU6
/var/lib/dpkg/status ファイルの中で Depends: ..., zlib1g, ... の
ような Package: を探すと Package: w3m や Package: file などが見つ
かりますが、コマンドラインから

$ hoge -fuga zlib1g
w3m
file
gnupg
ssh
...

のようにzlib1gを必要とするパッケージ一覧を表示する方法はあります
でしょうか?


551 :login:Penguin:04/04/03 11:06 ID:LVSgI+oN
>>550
dpkg -remove zlib

552 :550:04/04/03 11:33 ID:NBUw4jU6
ちょっとそれは豪快すぎなような気が...
あ、でも動作しないモードでやればいいのか。

dpkg --no-act --remove zlib1g

でzlib1gに依存したパッケージのリストが得られました。
>>551に感謝。


553 :login:Penguin:04/04/03 12:08 ID:Thg/BK6E
ttp://debian.fam.cx/index.php?AptGet#content_1_30
じゃだめなんか?

554 :550:04/04/03 12:55 ID:NBUw4jU6
>>553
それだと希望の動作の逆方向の検索になってしまいます。


555 :login:Penguin:04/04/03 13:08 ID:uhtBmObS
分かりゃ何でもいいと思うが、
grep-dctrl -F Depends zlib1g -s Package /var/lib/dpkg/available


556 :login:Penguin:04/04/03 15:20 ID:VwbT20kd
質問します。

Maildir.apop対応のstable環境でのお勧めのpopperて何ですか?

Postfixを使おうと思っていたのでsolid-pop3がよさげだったんですがどうでしょう。

よろしくお願いします。

557 :login:Penguin:04/04/03 15:54 ID:OXBBCAyj
>>556
qmail

558 :login:Penguin:04/04/03 18:45 ID:LVSgI+oN
>>557
あんまり詳しくないんですがqmailってpopもできるんですか?


559 : ◆u2YjtUz8MU :04/04/03 19:14 ID:NZKrV7/O
>>558
qmail-pop3d


560 :login:Penguin:04/04/03 20:47 ID:XbzywCh3
>>554
553の示したところにはあるパッケージが依存するパッケージの一覧と
あるパッケージに依存するパッケージの一覧の両方の取り方が書いて
あったはずだが、そのどちらでもない逆方向っていったいどっちを向いて
いたんだろうか?



561 :login:Penguin:04/04/03 21:23 ID:wrZJ/qx5
初めてメールサーバーを立ち上げるんだったら、Postfix+ipopdの方が設定は簡単じゃないかな。
インターネットでの情報も多いし、書籍も一番だと思う。
ただ、qmailもpopが出来るんですか、という質問からすると、プロバイダーのメールサーバーを使うのが一番いいと思います。
設定なんていらないし、落ちたら文句が言えるし。

562 :login:Penguin:04/04/03 21:48 ID:uhtBmObS
courier-popもいいでよ。

>>561
ipopdって、元はwu-popdでしょ。ワシントン大学の。
やめといた方がいいよ。Security holeがムチャクチャ多い。
原因は、かなり独自のcoding convention使っているから、
source codeのmaintainerが少ないとみた。

>>559
qmail-pop3-svって名前に変わったんじゃないかな。(debian package name)

563 :login:Penguin:04/04/03 22:05 ID:N+BVusop
>>562
もしかしてwu-ftpdのwuってWashington Universityのこと?
ずっと中国人のウーさんが作ったのかと思ってた。


564 :login:Penguin:04/04/03 22:10 ID:uhtBmObS
そうだよ。大学の名前を関しているのにあの体たらく。
apt-get source ipopdしてみ。すごいソースが拝めるぞ!

565 :login:Penguin:04/04/03 22:28 ID:6D1MZ0CO
>>550
遅いかもしれんが、 deborphan -d なんかはどうだろう。


566 :login:Penguin:04/04/03 23:06 ID:YucN0+qN
uw-imapd使っているおれは負け組か_| ̄|○

567 :login:Penguin:04/04/03 23:38 ID:gcQD0pnD
そーいう基準に囚われてる時点でry

568 :556:04/04/03 23:48 ID:VwbT20kd
>>557
すみません。qmailはfreebsdな環境で使っているので勉強のためにも他の物を使おうと思っていました。
前提条件に書いていませんでした。

>>561
558は俺ではない。

>>562
wu-ftpdにはひどい目にあった人を何人か知っているので
ワシントン大学が作ったものはあまり信用できないので、
ipopdは止めました。

courier-pop 試してみます。

>>566
uw-imapdはIMAPサーバの参考にさせていただきます。

teapopも良いと聞いたのでいろいろ試してみたいと思います。

ご意見ありがとうございました。

569 :login:Penguin:04/04/03 23:58 ID:n7pROyoF
debian JPはサイトをリニューアルしないのかな。
debian独自ソフトのPOやマニュアル、ドキュメントの翻訳状況とか
どれが作業中でどれが放置中なのかを載せるとか。
できれば自由にTipsなんかを書き込めるWikiを用意したりして欲しいな。

今のままだと本家と内容がかぶりすぎてて、あまり役に立ってないと思うけど。
正直、本家で提供してないような情報をメインに載せて欲しい。
セキュリティ情報なんか長々とトップに載せてるけど、チェックする人は本家の方を見に逝くっしょ。
それと更新する予定のなさそうなページを整理するとかさ。

570 :login:Penguin:04/04/04 00:01 ID:koovJLDh
>>568
IMAPなら、courier-imapも検討対象に。俺はこれ使ってる。
uw-imapdは、元wu-imapdで(ry

571 :login:Penguin:04/04/04 00:04 ID:koovJLDh
>>569
我々には、http://debian.fam.cx/ があるではないか

572 :login:Penguin:04/04/04 00:46 ID:agspfwJ7
courierはMaildir専用じゃなかったっけ?

573 :login:Penguin:04/04/04 00:57 ID:rNxvnFkf
>>571
Debian-JPのトップからリダイレクトしてもらうとか。


574 :login:Penguin:04/04/04 01:09 ID:q8Kh0jH3
>>565
まさにこんなツールを探してました。
感謝であります。


575 :login:Penguin:04/04/04 01:40 ID:U0lmB63O
Xを入れようと思い
sudo apt-get install x-window-system qvwm
としたんですが、何かエラーが出て止ってしまい、まぁX必要じゃないからいいやと思ってたんですが
その後php4をapt-getした時
sudo apt-get install php4
中略
Need to get 0B of archives. After unpacking 0B will be used.
Setting up twm (4.3.0-7) ...
update-alternatives: unable to make /usr/man/man1/x-window-manager.1.gz.dpkg-tmp a symlink to /etc/alternatives/x-window-manager.1.gz: No such file or directory
dpkg: error processing twm (--configure):
subprocess post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of x-window-system:
x-window-system depends on twm; however:
Package twm is not configured yet.
dpkg: error processing x-window-system (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
twm
x-window-system
E: Sub-process /usr/bin/dpkg returned an error code (1)
となり終ってしまいました。関係無いはずなのに。。
で、phpも使えず、他のパッケージも全然インストール出来ません
誰か御教授お願いします。

576 :575:04/04/04 02:05 ID:U0lmB63O
訂正です。どうもインストールは出来てるみたいです。
しかしやっぱりapt-get install するたびに 上のようなエラーが発生するのは癪なので何か分る方御教授お願いします

577 :login:Penguin:04/04/04 05:08 ID:zGjhmwe2
中途半端に入ってるのを消したら。

578 :login:Penguin:04/04/04 10:57 ID:dpGaG5mO
例えば php4-imagick は X11 に割と豪快に depend する

579 :login:Penguin:04/04/04 11:17 ID:TMvx85Ih
正直gettextとpythonはどうにかして欲しい。


580 :576:04/04/04 15:11 ID:U0lmB63O
x-window-system は
apt-get --purge remove x-window-system で消えたみたいですが
twmが消えてくれません、、、

581 :login:Penguin:04/04/04 15:35 ID:nX31ITyJ
>>576
BTSへgo!

582 :login:Penguin:04/04/04 15:38 ID:koovJLDh
>>580
apg-get -f installしろよ

583 :login:Penguin:04/04/04 16:48 ID:uDUfHUZH
ifconfig eth0 (ip) netmask (mask) upするとsegmentation faultで落ちるんですが、
回避策or代替手段はありますでしょうか。
ifconfig -aすると、eth0とloが表示されます。

584 :login:Penguin:04/04/04 16:54 ID:koovJLDh
>>583
とりあえず、どこで落ちるのかltraceでもして調べたら?

Debian的には、
version up/downしたり、
inetutils-tools (experimental) を試してみるとか。

どうしてもダメなら、
ioctl(sock, SIOCSIFADDR, &sockaddr_in);
してみてね(w

585 :login:Penguin:04/04/04 17:04 ID:uDUfHUZH
>>584
レスありがとうございます。
試してみます。

586 :login:Penguin:04/04/04 17:11 ID:Z8rGHYLX
dpkg -i kernel-image-hogehoge.deb
で新しいバージョンのカーネルを構築して、現在Grubで2つのカーネルから
選んで起動できるようになっています
で、古い方のカーネルを消してしまいたいんですが、どうすればいいのでしょうか?
dpkg --purge kernel-image-hogehoge.deb
でいいのでしょうか?それとも--removeの方が良いのでしょうか?

587 :login:Penguin:04/04/04 17:22 ID:x4cAyISz
>>586
"ぱーじ"しなさい。

588 :login:Penguin:04/04/04 17:52 ID:QYxEYZPi
kddlab ミラーコネー。Packages.gz が固まったまんま。

589 :580:04/04/04 17:59 ID:U0lmB63O
>>581 >>580
BTS行きなのでしょうか、、

apt-get -f install してみましたが同じようにエラーが帰ってきます。
Setting up twm (4.3.0-7) ...
update-alternatives: unable to make /usr/man/man1/x-window-manager.1.gz.dpkg-tmp a symlink to /etc/alternatives/x-window-manager.1.gz: No such file or directory
dpkg: error processing twm (--configure):
subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
twm
E: Sub-process /usr/bin/dpkg returned an error code (1)
このように、、

590 :login:Penguin:04/04/04 18:10 ID:p8BGce00
>>589
たうぜん

/usr/man/man1/..とかいってる時点でおかしい

591 :583:04/04/04 18:19 ID:uDUfHUZH
>>584
inetutils-toolsを試してみましたが、segmentation faultでした。
ltraceによると、どちらもioctl(???, 35094<SIOCSIFADDR>, ???);の内部で落ちているようでした。
なので、最後の方法も駄目だと思います。
自分の知識ではこの方面の解決は無理そうなのでversion up/downを試してみます。
ありがとうございました。

592 :login:Penguin:04/04/04 19:27 ID:TMvx85Ih
>>591
NICが腐ってるとか?ドライバ間違ってるとか?

593 :login:Penguin:04/04/04 21:42 ID:koovJLDh
>>589
dpkg --force-all --purge twm

594 :login:Penguin:04/04/04 21:44 ID:koovJLDh
>>591
内部ってのはioctl()の帰り値がなかったということ?

いずれにせよ、>>592の言うようにdevice/driverが怪しいね。

595 :login:Penguin:04/04/04 23:15 ID:sEj6lkFx
woodyを使用しています。

apacheとphpをapt-getでインストールして利用していました。
phpにはZend Optimizer Ver.2.1.0を追加しました。

しばらくして、MySQLを勉強するために、apt-getで
php-mysqlとmysql-serverをインストールしました。

インストール時、php.iniにmysqlの設定するか?みたいなことを聞かれたのでyesにしました。

その後、phpinfo()を表示させてみましたら、
MySQLの項目がありませんでした。

先にMySQLを入れているとダメなのでしょうか?
このスレで合っているかわかりませんでしたが、
Debianでパッケージでのインストールでしたので、
こちらで質問させていただきました。

ここをみてみろという場所がありましたらご教示いただけませんでしょうか
よろしくおねがいします


596 :login:Penguin:04/04/04 23:45 ID:FggSZfcy
今までYahooBBの8Mのサービスで問題なく繋がっていたのですが、
引越しを期に45Mに変更したらDHCPでアドレスをもらえなくなりました。
ちなみに、WINではちゃんと繋がります。
同じような症状になっている人、もしくは解決の糸口を知っている人はいませんか?
ちなみに、woodyを使ってます。カーネルは2.4です。

597 :login:Penguin:04/04/04 23:51 ID:koovJLDh
利用してるADSLモデムのDHCPの問題では?
# tethereal -i eth0 port bootpc and port bootps
してみれ。

ちなみにDebian関係ないと思います。


598 :login:Penguin:04/04/05 00:04 ID:q46eMRFd
Y!BBのモデムはブリッヂ。
DHCPクライアントはやっぱりDebian。

599 :login:Penguin:04/04/05 00:12 ID:6QJO7v83
以前は $HOME/.gnomerc に

export XMODIFIERS="@im=kinput2"
kinput2 &

とか書いて日本語入力の設定をしていたが、どうも
gnome2.4 から $HOME/.gnomerc を読まなくなったようなので、
これらの設定を手動で読みこませて非常にめんどい。
おまいらはどうやって設定しているか教えてくださいぽ。
環境は sid


600 :login:Penguin:04/04/05 00:49 ID:hGzvSPWw
/etc/X11/Xsession.d/90ximに

#! /bin/sh
if [ -f $HOME/.xsession.xim ]; then
. $HOME/.xsession.xim
fi

と書いている。こうすれば、display manager一般, startx, xinitで有効。

601 :login:Penguin:04/04/05 00:49 ID:uDWG0i81
>>599
ttp://kmuto.jp/d/?date=20040405#p01
だそうだ。

602 :login:Penguin:04/04/05 01:22 ID:6ANlqXNs
Bugってハニー

603 :login:Penguin:04/04/05 01:35 ID:YXxXFxcX
高橋名人ですか

今日(/昨日)はあちこちで見かけるナァ(w

604 :login:Penguin:04/04/05 04:26 ID:o1gIs0jl
あるバージョンのカーネルを入れたらkernel panicが出て、
どうやっても直らずににっちもさっちも行かなくなったけど、
別のバージョンのカーネルを入れ直してみたらkernel panicが出ずにうまくいった
という現象はあり得ますか?

605 :login:Penguin:04/04/05 04:46 ID:JNlZJtSH
>>604
はい。普通に。


606 :login:Penguin:04/04/05 06:20 ID:o1gIs0jl
現在Debian3.0(woody) kernel 2.2.20-idepciを使用しており、kernelを2.4.17に
再構築しようとしています。

# apt-get build-dep kernel-source-2.4.17
# apt-get install kernel-source-2.4.17
# cd /usr/src
# tar xvfj kernel-source-2.4.17.tar.bz2
# ln -s kernel-source-2.4.17 linux
# cd linux
# cp /boot/config-2.2.20-idepci .config
# make oldconig
# make menuconfig
# make-kpkg clean
# make-kpkg kernel_image
# cd ..
# dpkg -i kernel-image-2.4.17_1.00.Custom.i386.deb

以上のようにして新しいカーネルを入れたところ、起動時に

request_module[block-major-3]: Root fs not mounted
VFS: Cannot open root device "hda2" or 03:02
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 03:02

というエラーが出て止まってしまいます。

>>607に続きます

607 :login:Penguin:04/04/05 06:21 ID:o1gIs0jl
>>606からの続きです
そこで、ここ
http://www.mylab.jp/diary/20040115.html
http://lists.debian.or.jp/debian-users/200204/msg00169.html
を参考にして

# mkinitrd -o /boot/initrd.img.2.4.17 /lib/modules/2.4.17

とし、/boot/grub/menu.lstに
initrd /boot/initrd.img.2.4.17
という行を加えてrebootしたところ、上の4行のエラーは出ず、

Kernel panic: VFS: Unable to mount root fs on 01:00

というエラーが出るようになりました。
kernel 2.2.20-idepciは普通に起動できます。

CPUはPentiumIII、メモリは128MB、HDDは一つで、/dev/hda1はswapで、/dev/hda2が/です。
起動にはliloではなくgrubを使っており、
/etc/kernel-img.confは

postinst_hook = /sbin/update-grub
postrm_hook = /sbin/update-grub
do_bootloader = no

>>608に続きます

608 :login:Penguin:04/04/05 06:23 ID:o1gIs0jl
>>606-607からの続きです。
/boot/grub/menu.lstは

default 0
timeout 5
color cyan/blue white/blue

title Debian GNU/Linux, kernel 2.4.17
root (hd0,1)
kernel /boot/vmlinuz-2.4.17 root=/dev/hda2 ro
#initrd /boot/initrd.img.2.4.17
savedefault

title Debian GNU/Linux, kernel 2.2.20-idepci
root (hd0,1)
kernel /boot/vmlinuz-2.2.20-idepci root=/dev/hda2 ro

のような内容です。
2.4.18で同じ症状が出たので2.4.17にしたのですが、何が悪いのか…。
どうすればいいのでしょうか?

609 :login:Penguin:04/04/05 09:17 ID:l5AbDmaa
>>608
[debian-users:40088]
ヴァージョンにも関係あるっぽいですが

610 :login:Penguin:04/04/05 09:38 ID:C7vKPgCT
無理になんでもかんでもモジュール化せんで、組み込めばええやん。
/のファイルシステム、HDD関係をYで再構築すればinitrd要らないんじゃね?

611 :login:Penguin:04/04/05 10:06 ID:4bKBNm7h
横から失礼します。
>>599さんと同じ症状で悩んでました。
>>600さん、ありがとうございます。

ところで、この場合、~/.gnomercは不要と言うことでいいんですよね?
それと~/.xsession.ximの記述はどうなりますか?
なにか追加が必要ですか?

612 :login:Penguin:04/04/05 10:46 ID:o1gIs0jl
>>609
ちょっとよく分からないのですが、ramdisk_blocksize=4096をgrubに指定してやる
という事でしょうか?
initrdの話のようなので、menu.lstに
initrd /boot/initrd.img.2.4.17 ramdisk_blocksize=4096
と書いてやったのですが、
Kernel panic: VFS: Unable to mount root fs on 01:00
となりました。

613 :login:Penguin:04/04/05 10:47 ID:o1gIs0jl
>>610
具体的にどれをbuild inすれば良いのでしょうか。
該当しそうなのはこんな感じになっているのですが…。
Block devices --->
<*> Loopback device support
<M> Network block device support
<*> RAM disk support
(4096) Default RAM disk size
[*] Initial RAM disk (initrd) support
ATA/IDE/MFM/RLL support --->
<*> ATA/IDE/MFM/RLL support
File systems --->
<*> Compressed ROM file system support
[*] /proc file system support
<*> Second extended fs support
Network File Systems --->
<*> NFS file system support
[*] Provide NFSv3 client support
<M> NFS server support
[*] Provide NFSv3 server support
<M> SMB file system support (to mount Windows shares etc.)
[*] Use a default NLS
Default Remote NLS Option: "cp932"

614 :login:Penguin:04/04/05 11:19 ID:4JYU8O+g
HDD関係は?
IDE HDDみたいだけど。
>>606でide-probe-mod(block-major-3)がネェヨといってるし。

いやーん。
pcmcia-csをupgradeしたらカーネル落ちたわー。
「常時」は相変わらず危険なのか。

615 :login:Penguin:04/04/05 11:54 ID:o1gIs0jl
>>614
<*> ATA/IDE/MFM/RLL support
<*> Enhanced IDE/MFM/RLL disk/cdrom/tape/floppy support
<*> Include IDE/ATA-2 DISK support
[*] Use multi-mode by default
<*> Include IDE/ATAPI CDROM support
<*> Include IDE/ATAPI FLOPPY support
こんな感じになっております。
CDROMとかは関係ないと思いますが…。
HDDはIDE接続です。

616 :login:Penguin:04/04/05 12:13 ID:4JYU8O+g
generic/default IDE chipset support(CONFIG_BLK_DEV_IDEPCI)
Generic PCI IDE Chipset Support(CONFIG_BLK_DEV_GENERIC)
あたりは?
2.6で見てるから、そんな項目なかったらスマソ

あー起動できてるカーネルのconfigと比べてみるのが早いっぽいけど。

617 :login:Penguin:04/04/05 12:23 ID:o1gIs0jl
>>616
下のはありませんでしたが、上のはNになっていました。
これをYにして--purgeして綺麗にしてから再構築したところ、正常に起動しました。
助かりました。ありがとうございました。

618 :login:Penguin:04/04/05 15:22 ID:eCeY/fAA
woody使ってたけどapt-getでgcc3.3を入れる方法がワケワカだったのでsargeにしちゃった。

619 :login:Penguin:04/04/05 15:26 ID:eCeY/fAA
それでもやはり入れ方が分からなくてショボーン

620 :login:Penguin:04/04/05 16:02 ID:4JYU8O+g
>>618-619

http://debian.fam.cx/index.php?AptGet

621 :login:Penguin:04/04/05 16:45 ID:eCeY/fAA
そのページは読んだんです。それでapt lineも自分のプロバイダのサーバを指すように書き換えて
普通のパッケージのアップグレードなどはうまくいってます。
http://debian.fam.cx/index.php?AptGet#content_1_6
これに近い状態になっています。

しかしapt-get updateしてapt-cache search gcc3とやっても何も表示されません。どのような原因が考えられるますか?

622 :login:Penguin:04/04/05 16:46 ID:eCeY/fAA
s/られるます/られます/; ;;

623 :login:Penguin:04/04/05 16:52 ID:N79jZNEn
>>621
> しかしapt-get updateしてapt-cache search gcc3とやっても何も表示されません。
じゃ、apt-cache search gcc-3 とやってみたら?

624 :login:Penguin:04/04/05 17:22 ID:eCeY/fAA
 ∧||∧
(  ⌒ ヽ ありがとうございました。
 ∪  ノ
  ∪∪

625 :login:Penguin:04/04/05 18:11 ID:QAfiTeTq
>>595
php.iniに
extension=まいえすきゅうえるもじゅーる.so
があるか見れ。

php4-pgsqlなら
extension=pgsql.so
になってるはず。


626 :583:04/04/05 19:49 ID:oLtu75BM
>>592
>>594
おかげで解決しました。
やはりデバイス(Intel Pro/1000 MT Network Connection)固有の問題で、
ドライバを自分でコンパイルしたものから2.4.25付属のものに変えることでつながるようになりました。
レスを下さった方ありがとうございます。

627 :login:Penguin:04/04/06 18:50 ID:tSrBOzMq
なぜ、apt-unstableを使わない

628 :login:Penguin:04/04/06 19:34 ID:qzOSaPpy
apt-unstableってなんですか?

629 :login:Penguin:04/04/06 21:04 ID:bVkor+zZ
ttp://www.namazu.org/~tsuchiya/debian/alpha/apt-unstable
これ??

630 :login:Penguin:04/04/07 00:34 ID:epp0Vnps
>>629
そうそれ
ttp://lists.debian.or.jp/debian-devel/200102/msg00080.html

# apt-unstable update
# apt-unstable source hogehoge
# cd hogehoge-hoge
# dpkg-buildpackage -us -uc
# cd ..
# dpkg -i hogehoge.deb

で、依存関係が出たらどんどんとってくれば、
とりあえず必要なものだけunstableになるよね

631 :login:Penguin:04/04/07 01:07 ID:nkUXDbxp
kernelを2.6.5にしたらalsaがコムパイル出来んくなったんだけど、そういうもん?
# BTSを見てもそれらしきもんを見つけられんかった。

alsa-source 1.0.3-1
kernel-package 8.085

632 :login:Penguin:04/04/07 01:12 ID:qR917/kA
俺2.6.5でnvidiaのドライバがコンパイルできなくなった

633 :login:Penguin:04/04/07 01:23 ID:Xe281zWU
debianに関係あんのか


634 :login:Penguin:04/04/07 02:18 ID:4dE9h4PP
俺、2.6.5でcorega WLCB-54GT使えるようになった (sid)
ttp://www.corega.co.jp/product/list/wireless/wlcb54gt.htm

やっとPrism54ドライバがカーネル標準装備になったよママン

635 :login:Penguin:04/04/07 02:27 ID:NnF/RZhD
>>630
ん? Pin 使えばいいんじゃないの?
ちなみに私の設定.(Pin-Priority の 1000 という微妙〜な値がポイント)

/etc/apt/preferences
Package: *
Pin: release a=testing-proposed-updates
Pin-Priority: 1000

Package: *
Pin: release a=testing
Pin-Priority: 1000

あとは /etc/apt/sources.list で testing と unstable の両方を記述して,
必要な Package だけ apt-get -u install hogehoge/unstable でインストール.
# testing と unstable だからなんとかなるという説も….stable だと依存
# 解決に苦労しそうだし….


636 :login:Penguin:04/04/07 02:48 ID:YsLq/zUl
cannaで日本語入力できません。
shift+spaceで [ あ ] は表示されるんですが、
文字を打つとアルファベットのままです。

それと、dpkg-reconfigure-localesでja_JP.eucJPを追加したはずなのに、
set-language-envするとja_JP.eucJPをインストールしろと言われます。
/etc/locale.genにもja_JP.EUC-JP EUC-JPとあります。
どうすればいいのかわからないです。


637 :login:Penguin:04/04/07 03:16 ID:Dp+kkplG
>>636
当てずっぽうで、、、。

~/.qt/qtrc
XIMInputStyle=Over The Spot

$ qtconfig
Over The Spot

638 :login:Penguin:04/04/07 03:56 ID:y/zhwujb
>>631
linux-2.6.5のALSAは1.0.4rc2だぞ

639 :login:Penguin:04/04/07 04:36 ID:YsLq/zUl
>>637
ダメでした。状況変わらずです。
ついでに、
$ qtconfig
KThemeStyle cache seems corrupt!
と表示されるんですが、どういう意味でしょうか?

640 :login:Penguin:04/04/07 10:21 ID:Dp+kkplG
>>639
http://debian.fam.cx/index.php?Japanese
ここ位は読んでると思うけど
それと、もうちょい情報くれ

corrupt! <ー不正ってことらすぃ、、、が関係なぁし。

641 :login:Penguin:04/04/07 11:08 ID:ltaC4hHT
debパッケージの依存関係をおっかけていくと
A depends B かつ B depends A
という依存をよく見かけるけど、これってどんな意味があるの?

依存関係ってのは端が開放された樹状になるイメージ(先入観とも
言う)があるんだけど。


642 :login:Penguin:04/04/07 11:12 ID:ibqVq0vq
AとBは一緒に入れないと意味がない

643 :login:Penguin:04/04/07 11:12 ID:ltaC4hHT
>>639
> >>637
> $ qtconfig
> KThemeStyle cache seems corrupt!
「キャッシュが壊れてるぜ」って意味らしいので、
ホームディレクトリ ~/ 配下のKDE関連(使ってる
のはKDEですよね?)のディレクトリを全部消して
再構築してみたら?

あとlocale情報も、もしかしたらキャッシュに
なっちゃってるのかも。


644 :login:Penguin:04/04/07 12:26 ID:xyIyFNnT
kernel-packageの問題みたいだが。#242038

645 :login:Penguin:04/04/07 23:02 ID:IcZZ7dTW
ML 痛いな。

646 :login:Penguin:04/04/07 23:02 ID:pcG0ySt6
rpmが

647 :login:Penguin:04/04/07 23:08 ID:i+ud0rfr
>>641
Aのファイル(コマンド)に、Bのコマンドが依存して、
Bのファイル(コマンド)に、Aのコマンドが依存している、
当然A←→Bになるのでは。

648 :login:Penguin:04/04/07 23:12 ID:eafIBqik
>>647
A←→Bの記号が分からん

649 :login:Penguin:04/04/07 23:47 ID:skNJLti9
sargeを使っております(1月ほど).
最近 upgrade した結果,libxft-devのバージョンの関係でupgradeがスムーズに
行えなくなりました。 -f をつけてもダメ.
解決方法のアドバイスをお願いします.

こんな感じです.
# apt-get -f install libxft-dev
libxft-dev 2.1.2-5 を(.../libxft-dev_2.1.2-6_i386.deb で)置換するための準備をしています...
diversion of /usr/X11R6/include/X11/Xft/Xft.h to /usr/X11R6/include/X11/Xft/Xft1.h by libxft-dev
Removing `diversion of /usr/X11R6/include/X11/Xft/Xft.h to /usr/X11R6/include/X11/Xft/Xft1.h by libxft-dev'
dpkg-divert: rename involves overwriting `/usr/X11R6/include/X11/Xft/Xft.h' with
different file `/usr/X11R6/include/X11/Xft/Xft1.h', not allowed
dpkg: /var/cache/apt/archives/libxft-dev_2.1.2-6_i386.deb の読み込みエラーです(--unpack):
サブプロセス pre-installation script はエラー終了ステータス 2 を返しました。。
以下のパッケージの処理中にエラーが発生しました:
/var/cache/apt/archives/libxft-dev_2.1.2-6_i386.deb

650 :login:Penguin:04/04/07 23:57 ID:55TJVT6l
>>649
apt-get remove libxft-dev
してくだ

651 :login:Penguin:04/04/08 00:01 ID:MocDyLta
sidの時にさんざん既出のネタだな。

652 :login:Penguin:04/04/08 00:07 ID:rSiT8F5W
>>650
以下のような感じです.
ログ中に出てくるパッケージも似たような感じ.

# apt-get -f remove libxft-dev
パッケージリストを読みこんでいます... 完了
依存関係ツリーを作成しています... 完了
以下の問題を解決するために 'apt-get -f install' を実行する必要があるかもしれません:
以下のパッケージには満たせない依存関係があります:
libpango1.0-dev: 依存: libxft-dev しかし、インストールされようとしていません
E: 未解決の依存関係です。'apt-get -f install' を実行してみてください(または解法を明示してください)。
# apt-get -f remove libpango1.0-dev
パッケージリストを読みこんでいます... 完了
依存関係ツリーを作成しています... 完了
以下の問題を解決するために 'apt-get -f install' を実行する必要があるかもしれません:
以下のパッケージには満たせない依存関係があります:
gnome-core-devel: 依存: libpango1.0-dev しかし、インストールされようとしていません
libgnomeprint2.2-dev: 依存: libpango1.0-dev しかし、インストールされようとしていません
libgtk2.0-dev: 依存: libpango1.0-dev (>= 1.2.0-3) しかし、インストールされようとしていません
libxft-dev: 依存: libxft2 (= 2.1.2-5) しかし、2.1.2-6 はインストールされようとしています
E: 未解決の依存関係です。'apt-get -f install' を実行してみてください(または解法を明示してください)。


653 :login:Penguin:04/04/08 00:42 ID:hOtqWOia
>>642,647
てか、ようするにAの依存を解決するとBが、Bの依存を解決するとAが
出てくるわけで。
これってループしちゃってるじゃないですか。

スクリプトで機械的に依存関係を辿る時に、すごく困ると思うんだけど。
Debianのパッケージ関連ツールは問題無く扱ってるみたいだし、
ひじょーに不思議に思ったわけですよ。

ループ状の依存を意図的に作っているとしたら、その理由は?ってのが
知りたいことなんだけど...
バージョン縛りがキツくて、片方のバージョンが上がっちゃうと
もう片方が動かなくなる。とか?
その割に、例えば autoconf と autoconf2.13 がループになってる
みたいだし。よーわからん。

誰か知ってる御仁がいらすようなら、教えてつかーさい。


654 :login:Penguin:04/04/08 00:46 ID:XdVkEnoF
>>645
まあ、何にしろ、逃げたほうが負けってことで。
逃げるくらいなら出てくんな。

655 :login:Penguin:04/04/08 01:01 ID:k3mq5O19
>>649
#rm /usr/X11R6/include/X11/Xft/Xft.h
#rm /usr/X11R6/include/X11/Xft/Xft1.h

656 :login:Penguin:04/04/08 01:05 ID:sBww4/5E
>>653
> スクリプトで機械的に依存関係を辿る時に、すごく困ると思うんだけど。

推移閉包を得たり、ループを検出するのは極めて初歩的なアルゴリズム。

> Debianのパッケージ関連ツールは問題無く扱ってるみたいだし、
> その割に、例えば autoconf と autoconf2.13 がループになってる
> みたいだし。よーわからん。

Depends: perl (>> 5.005), m4, debianutils (>= 1.8), autoconf2.13 (>= 2.13-41)
Conflicts: autoconf2.13 (<< 2.13-41), gettext (<< 0.10.39)
Description: (略)
This version of autoconf contains many changes from the previous
release, version 2.13. For now, it depends on autoconf2.13 to
provide compatibility. This will eventually go away, so please
upgrade your autoconfiscations.


657 :login:Penguin:04/04/08 01:24 ID:IHbUx+d4
>656

> 推移閉包を得たり、ループを検出するのは極めて初歩的なアルゴリズム。
単にこれまで読み取ったライブラリをリスト化しておいて照合するとか?

658 :653:04/04/08 01:37 ID:hOtqWOia
>>656
サンキューであります!
キーワードがもらえただけでも大収穫。

つか、もっと勉強しろってことなのね。
がんばります。


659 :645:04/04/08 02:09 ID:rSiT8F5W
>>655
ありがと。解決したみたいです。
意外と単純なのね…。即座に原因を特定するのは難しそうだけど。

660 :659:04/04/08 02:10 ID:rSiT8F5W
645じゃなくて649でした。

661 :login:Penguin:04/04/08 02:53 ID:7kb6SmvQ
>>638
さんくす

662 :login:Penguin:04/04/08 04:02 ID:LinZrbUn
いつの間にか
lynx が standard から optional になって、かわりに
w3m が standard になってる。

理由はよくわからんけど、日本人としてはうれしいな。

663 :login:Penguin:04/04/08 10:01 ID:zxiZCkjQ
> 理由はよくわからんけど

多言語対応が取り込まれたからでしょ?


664 :login:Penguin:04/04/08 10:07 ID:ctMBun6P
結構もめたんだけどなw3mをlynxの代わりにしようって言ってたとき

665 :login:Penguin:04/04/08 11:01 ID:/VjqMrH1
devpts ってなに?

666 :login:Penguin:04/04/08 11:15 ID:7+5oCwa/
>>665
くだ質へ逝け

667 :login:Penguin:04/04/08 13:32 ID:jJ3HpXa/
debian sarge installer beta3についてなんだが
IBM USBキーボード ウルトラ ナビ付をつないでインストールすると再起動してしまう。
woodyのインストーラだと問題はないんだが、何が原因かわからない

症状としては、murasakiとかusbmgr入れたときにdeviceがかち合ったときに
落ちたりするのと似た雰囲気がある

これったバグなのか?

USBコントローラはIntel ICH4内蔵のもの


668 :login:Penguin:04/04/08 15:23 ID:zxiZCkjQ
792:login:Penguin:04/04/07 21:11 ID:4eBsCxN+
  こないだ fedora でも public key に改行入れて、ssh のバグだ
  なんて騒いだ香具師ね>joe

(゜Д゜)pokan

669 :login:Penguin:04/04/08 15:36 ID:Ee9ycJ7G
こっちにもpokanが居るのか

670 :login:Penguin:04/04/08 19:26 ID:KVyl6Huz
SargeのIcecast2が見当たらないんだけど何かあった??

671 :login:Penguin:04/04/08 20:33 ID:Ye5ds1Yn
玄箱へのDebianインストールで詰まっています。
i386上のdebianでdebootstrap --arch ppc 〜〜して
PPCのベースシステムをHDDにインストールして
玄箱へ付け替えたいんですが
不可ですか?



672 :login:Penguin:04/04/08 22:13 ID:ikgNvZYm
インストール用フロッピィイメージについて質問です。

1スピンドルのノートパソコン (ThinkPad X23) に testing (sarge) をインス
トールしたいと考えています。しかし FAQ を見たところ、現段階では stable
(woody) 用の起動 FD イメージしか無いようなのですが、このイメージを使っ
て sarge をインストールする事は不可能なのでしょうか (或いは sarge 用の
起動 FD イメージはあるのでしょうか) 。

インストール後に/etc/apt/apt.conf.d/99target と/etc/apt/sources.list
を sarge 用に変更すれば以後は testing のパッケージを簡単にインストール
出来る事は分かったのですが、依存関係で不具合が発生するのも嫌なので、可
能ならば最初から sarge をインストールしたいのです。

CD イメージを使えば良いのかもしれませんが、自分の環境が貧弱な物で CD-R
を作成する環境が無いんですよね……。

# 一通り過去ログも FAQ も調べたつもりなのですが、既出の質問でしたら申し
# わけありません。

673 :login:Penguin:04/04/08 22:48 ID:sbCrib5h
ほんとに調べたのか?

http://www.debian.org/devel/debian-installer/

674 :login:Penguin:04/04/09 00:07 ID:ntdzwA6J

インストールしたパッケージの一覧を表示させたいのですが
apt 系のコマンドでできますか?

apt-cache show pkgname で指定せずに、一覧全部出したいのですが。 

675 :login:Penguin:04/04/09 00:10 ID:XeMI7M9I
>>674
http://debian.fam.cx/index.php?AptGet#content_1_15
ここくらい見てくれ。ほんとに便利にできてるから・・。

どうしても apt でしたいと言われると、知らない。

676 :login:Penguin:04/04/09 00:20 ID:ntdzwA6J
>>675
ありがとうございます。dpkg -l は知っていたのですが、
apt系のコマンドで同じ事ができないのかなと以前から不思議だったので。
というのはdpkgコマンドは今後aptに取ってかわられると考えていますので
これがaptでもできると便利だなと思ったためです。


677 :login:Penguin:04/04/09 00:48 ID:5ciLSUcv
apt って dpkg のフロントエンドだよ。


678 :login:Penguin:04/04/09 01:17 ID:Vy+D+9J5
>673
ああ、ありがとうございます。大変助かりました。

公式サイトにあったのを見逃していたんでは、調べていないと言われても仕方
ありませんね(^^;

御迷惑おかけしました。

679 :login:Penguin:04/04/09 02:46 ID:gzrHUd4D
viで日本語って入力/表示できないのでしょうか。

680 :login:Penguin:04/04/09 02:51 ID:wZbVDpxY
vim使うってのじゃだめなん?



681 :login:Penguin:04/04/09 03:15 ID:5ciLSUcv
nvi ファンのおれは m17n のpackage が消えて悲しかったが、
結局 /usr/local に自分で入れて気にしないことにした。


682 :login:Penguin:04/04/09 08:58 ID:8ICxARqG
>>697
vi は、
kterm と konsole で普通に読み書きできますが


683 :login:Penguin:04/04/09 09:07 ID:fVYZ9abR
>>682
Debianの標準のviはnviだったって事だろ
お前素のvi使ってみろ

684 :login:Penguin:04/04/09 09:18 ID:8ICxARqG
>>683
素のvi を使いたくてもそんなパケジございませんが
どうしましょ

685 :login:Penguin:04/04/09 10:07 ID:yMtM7uDH
woody 上で tripwire 使いたい(けどパケジがない)ので sid からソースもって
きてリビルドしますた。1台は無事インスコできたんですが、もう1台だと

| tripwire (2.3.1.2-6) を設定しています ...
| dpkg: tripwire の読み込みエラーです(--configure):
| サブプロセス post-installation script はエラー終了ステータス 10 を返しました。 。

こんなエラーを吐いてこけちゃいます。このステータス10の正体はどのあたりを調べ
ればいいすか? postinst スクリプトからは10なんて吐いてないし…(;´Д`)


686 :login:Penguin:04/04/09 10:13 ID:NtNIGGGl
>>671
debootstrap の README.Debian みると cross-strap できると書いてあるので
それでいいんじゃない?


687 :login:Penguin:04/04/09 10:17 ID:ECfDUNbE
>>684 じゃ氏ね

688 :login:Penguin:04/04/09 10:20 ID:6wD8oZ6M
# env DEBCONF_DEBUG='.*' dpkg --configure tripwire

/var/cache/debconf/config.dat 壊れてるかも…

689 :login:Penguin:04/04/09 10:27 ID:8ICxARqG
ははは、
vi もまともに使えねえ奴等がほざいても、、、。

690 :login:Penguin:04/04/09 10:32 ID:ECfDUNbE
>>689 素のviを使えないキチガイが何を言っても冷笑されるだけだと気付け、馬鹿。


691 :login:Penguin:04/04/09 10:36 ID:8ICxARqG
>>679
日本語環境が整っていないんでしょ、きっと。

692 :login:Penguin:04/04/09 10:37 ID:8ICxARqG
>>690
ここは、debianスレだろ。

693 :login:Penguin:04/04/09 10:44 ID:8ICxARqG
けけけ、
素のvi ってコンソールからって事か。
コンソールから日本語使うバカいるんだぁ。

694 :login:Penguin:04/04/09 10:47 ID:X8PLzTUV
>>693
> 素のvi ってコンソールからって事か。

脳内のどの部分から湧き出てきた妄想ですか?

695 :login:Penguin:04/04/09 10:48 ID:8ICxARqG
>>694
てめえも参加か?

696 :login:Penguin:04/04/09 10:48 ID:6wD8oZ6M
お前ら、やめれ

697 :login:Penguin:04/04/09 11:12 ID:CdQ1PAZx
kterm上でviを使うと、日本語が

\xa4\xa2\xa4\xa6

こんな文字になってしまいます。

698 :login:Penguin:04/04/09 11:29 ID:+NDK/MMH
またーりいきましょうぜ

699 :login:Penguin:04/04/09 11:36 ID:XP/T5B3C
vi の話をするときは
update-alternatives --display vi
を晒してからにしてくれ。


700 :login:Penguin:04/04/09 11:36 ID:AaonOv6f
stable環境で unstableとか testingのパッケージを利用したい時って、
それらのバイナリをそのまま使っちゃうもんなの?
それとも rebuildするの? 使い分けとかどうしたものやら。

701 :login:Penguin:04/04/09 11:42 ID:ZpKUdrIx
>>ID:8ICxARqG
「ははは」とか「けけけ」とか痛すぎ
氏ねば?

702 :login:Penguin:04/04/09 12:09 ID:E0LVBR3u
>>ID:8ICxARqG
ソウダソーダー!!
南海も氏ね氏ね〜〜〜〜〜〜〜〜!!
うっとーーーしいんじゃーーーーボケ
こいつはアホではなくて釣りえさにもならんボケですね!!
ケッケッケーーーー(笑)!


703 :login:Penguin:04/04/09 12:22 ID:CSRgnOkz
春だな

704 :login:Penguin:04/04/09 13:33 ID:Hzvf60R4
>>700
そんな事は人によると思うが、単純に考えて
・glibcなんかに依存→自前rebuild or backportものを利用
・依存性が少ないもの→unstable/testingからそのまま利用
って使い方が多そうだ。

705 :login:Penguin:04/04/09 14:13 ID:yMtM7uDH
>>688
うを、こんな変数があるのか。やってみたところ

| debconf (developer): starting /var/lib/dpkg/info/tripwire.postinst configure
| debconf (developer): <-- GET tripwire/use-sitekey
| debconf (developer): --> 0 true
| debconf (developer): <-- BEGINBLOCK
| debconf (developer): --> 0
| debconf (developer): <-- TITLE Get site passphrase
| debconf (developer): --> 0
| debconf (developer): <-- FSET tripwire/site-passphrase seen false
| debconf (developer): --> 10 tripwire/site-passphrase doesn't exist
| debconf (db configdb): saving database
| debconf (db templatedb): saving database
| dpkg: tripwire の読み込みエラーです(--configure):
| サブプロセス post-installation script はエラー終了ステータス 10 を返しました。 。

こんなんなってまして。site-passphrase がないから twadmin で作ってほし
いんだけど passphrase 訊いてくれないし、そこいらでひっかかってるみたい。
とりあえず passphrase なしでインスコした後、手動で passphrase 作って無
事使えるようになりますた。まじ多謝。

で、DEBCONF_DEBUG='.*' あたりの情報ってどこいらに載ってますか?
後学のためによかったら教えてください。

706 :login:Penguin:04/04/09 14:40 ID:WOGK8Vp8
>>670

http://bjorn.haxx.se/debian/testing.pl?package=icecast2

RCバグがあるせいじゃないのかな


707 :login:Penguin:04/04/09 16:46 ID:DdgvKIwL
春のせいかバカが多数わいてるようだな。

>>684
実はBerliOSに古のviが置かれてたりする。物好きな香具師は
使ってみるとよろしい。
http://ex-vi.berlios.de/


708 :login:Penguin:04/04/09 19:54 ID:sJAe50d2
libpam-modulesはsidだと0.76-xが使われていますが、
0.77になるとSELinuxに対応したものと、統合されるんでしょうか?
ひとつのバイナリで二つの動作モードに対応するというか。
そうなってくれたら、移行の障壁がかなり減る分、ユーザーとしては嬉しいです。

709 :login:Penguin:04/04/09 20:46 ID:T25Klo53
>>193 の独り言にマジレス。

woody の 0.16.5-6 ではタイトルバーやメニューなどの
日本語文字が本来あるべきところよりもフォント高さ分(?)だけ上方に表示されるので、
俺は
% COLUMNS=100 dpkg -l | grep enlightenment
hi enlightenment 0.16.3-8 The Enlightenment Window Manager
hi enlightenment-data 0.16.3-8 Enlightenment Window Manager Run Time Data Files
と 0.16.3-8 を hold して対処している。

あと、enlighte*n*ment な。

710 :688:04/04/09 21:43 ID:6wD8oZ6M
>>705
> で、DEBCONF_DEBUG='.*' あたりの情報ってどこいらに載ってますか?
> 後学のためによかったら教えてください。

debconf(1)じゃよ。
その他諸々は http://ukai.jp/debuan/2001w/debconf.txt でどうよ?

// debian.fam.cxにDEBCONF_DEBUG付け加えてくれると嬉しいの

711 :login:Penguin:04/04/09 22:42 ID:yMtM7uDH
>>710
ども。man debconf は最初にやったんですが、woody だと無かったもんで。
sid だとありますた。そか、ここに書いてあるのか。重ねがさねサンクスコ。

712 :login:Penguin:04/04/09 23:31 ID:WOGK8Vp8
>>708

ここでつぶやくよりBTSでwishlist突っ込んでみるほうがいいよ。


713 :login:Penguin:04/04/10 01:19 ID:04yJkWho
Debian入門のいい本ありますか?

714 :login:Penguin:04/04/10 01:22 ID:LpJAHC1S
>>713
無いです。

715 :login:Penguin:04/04/10 11:45 ID:WjXybFWE
小力のノートPCにDebian(wood)をインストールしたのです
windowマネージャは、icewmを使用しています
netscapeを入れたかったのですがありませんでした
mozillaをインスト-リングして、日本語は表示出来たのですが
どうしても日本語入力が出来ません

手順、やり方教えてくださいお願いします
canna、wnn、skkどれでも構いません
簡単なもので結構ですので教えてください

716 :login:Penguin:04/04/10 12:13 ID:3k8Icwq+
>>715
ここを読むといいよ
ばっちり書いてあるからね

http://debian.fam.cx/

717 :Wanderlust:04/04/10 13:41 ID:eXq5wG5Y
中島@エメラルドの中の人、sylphyeed にのりかえたのね…。

718 :login:Penguin:04/04/10 14:01 ID:3TTL0g6y
くだらない質問スレでわからない言われたのでこっちで質問させてください。
Debian3.0、カーネル2.4.18を使ってるのですが、sshでログインしていると、
どんなコマンドを入力しても、Too many open files in system
というエラーが返ってくるようになりました。

ps auxすると、
#0 230 0.0 0.1 2864 1404 ? S Apr09 0:00 /usr/sbin/nmbd -D
#0 232 0.0 0.1 2808 1160 ? S Apr09 0:00 /usr/sbin/nmbd -D
#0 234 0.0 0.1 2808 1168 ? S Apr09 0:00 nmbd
#0 236 0.0 0.1 2808 1168 ? S Apr09 0:00 nmbd
#0 238 0.0 0.1 2808 1168 ? S Apr09 0:00 nmbd
こんな感じで、以下nmbdが500個くらい続いていました。

nmbdをkillする直前のlog.nmbdを見ると、

[2004/04/10 01:13:39, 0] lib/pidfile.c:pidfile_create(86)
ERROR: nmbd is already running. File /var/run/samba/nmbd.pid exists and process id 230 is running.
[2004/04/10 01:13:39, 0] nmbd/nmbd.c:main(783)
Netbios nameserver version 2.2.3a-13 for Debian started.
Copyright Andrew Tridgell and the Samba Team 1994-2002
[2004/04/10 01:13:39, 0] nmbd/asyncdns.c:start_async_dns(148)
started asyncdns process 1486


[2004/04/10 01:23:52, 0] nmbd/nmbd.c:main(783)
Netbios nameserver version 2.2.3a-13 for Debian started.
Copyright Andrew Tridgell and the Samba Team 1994-2002
[2004/04/10 01:23:52, 0] nmbd/asyncdns.c:start_async_dns(137)
can't create asyncdns pipes
[2004/04/10 01:23:52, 0] lib/pidfile.c:pidfile_create(93)
ERROR: can't open /var/run/samba/nmbd.pid: Error was File exists

719 :login:Penguin:04/04/10 14:02 ID:3TTL0g6y
>>718の続きです。
こんな感じのエラーが何千行も連なっています。
sambaで共有しているディレクトリは別のマシンでNFSを動かして、それをmountしたものです。
sambaを止めてsar -vすると、このような結果でした。
17時55分01 符entunusd file-sz %file-sz inode-sz super-sz %super-sz dquot-s
z %dquot-sz rtsig-sz %rtsig-sz
18時05分01 媛391 7816 95.41 2158 0 0.00
0 0.00 0 0.00
lsofして各プロセスが使ってるファイルディスクリプタをまとめてみると、
http://pc3.2ch.net/test/read.cgi/linux/1080826243/803-805n
このようになりました。クライアントからTTSSHで接続してsuとかする→タイムアウトで切断
→新しくログインする の繰り返しなのですが、前のsshdとかbashとかのプロセスが
残ったままの状態になっているようです。おそらくnmbd増殖も同じ症状なのではないでしょうか。
これは何が原因なのでしょうか?また、どうすれば解決できるのでしょうか?
どうかよろしくお願いします。

720 :login:Penguin:04/04/10 21:22 ID:eXq5wG5Y
debianにsj3のパッケージはありますか。

721 :login:Penguin:04/04/10 21:51 ID:Dn7C0ylZ
>>718
可能ならば、kernelを2.4.20とかに上げてみたら?
それでダメなら今度はリモートの(NFSの)samba領域の代わり
にローカルにsamba領域を作って様子を見るとか。
それでもダメならsambaの起動をやめてみるとか。

どこが(あるいはなにが)悪いのか切り分けないと、考えにく
いのではないかと思う。


722 :login:Penguin:04/04/10 21:52 ID:Ft3/ecuC
woodyをネットワーク経由でノートPCにインストールしようとしている者です。
基本システムのインストールも終わって無事リブート出来たのですが、
パッケージのダウンロードの部分で詰まっています。
errorメッセージには、
"failed to fetch
http://(
cannot initiate the connection to ftp.jp.debian.org:80 (203.178.137.175)
- connect (101 Network is unreachable)"
といった文面が数回にわたって出てくるのですが、いったいどのように
対処したら良いのでしょうか?

723 :login:Penguin:04/04/10 21:57 ID:yiVCr+vl
>>722
たぶんネットワークの設定ができていない。
まずpingが外部に通じるか試すのがよろしかろう。

724 :login:Penguin:04/04/10 21:57 ID:z12E4QOp
ネットワークがつながってるか確認しる

725 :718:04/04/10 22:50 ID:3TTL0g6y
カーネル入れ直してみたのですが、同じ症状です。
どうすればいいのでしょうか…。

726 :login:Penguin:04/04/10 23:41 ID:9/KG5iJu
>>722
deb http://ftp.jp.debian.org/

deb ftp://ftp.jp.debian.org/
に変更

727 :login:Penguin:04/04/11 00:23 ID:Qb6NZjAO
>>725
レスがあったみたいよ
http://pc3.2ch.net/test/read.cgi/linux/1080826243/850

728 :login:Penguin:04/04/11 00:57 ID:tzp/kHdu
>>713
Sargeのリリースと同時くらいに出るんじゃないかな(期待)。

729 :login:Penguin:04/04/11 01:04 ID:mPUezQvY
ムトゥ以外にも「やるよ〜」って話がちらほら
ムトゥ本を含めて3冊は出ると思う

730 :login:Penguin:04/04/11 01:08 ID:xYvw2+5r
かなりいい出来なんだから加筆修正して毎バージョン出して欲しい
内容は良くても売り上げが良くなかったのかな

731 :login:Penguin:04/04/11 01:52 ID:y8lCz2KV
>>725
>721 "障害箇所を切り分ける"

自分だったら、あとはsmb.confからNFSマウントのディレクトリを削除して、
代わりにローカル(/usr/local/smbtmpとか適当に)をpublic扱いで設定して、
それでsambaを動かしてみるけどね。

# cp /etc/samba/smb.conf /etc/samba/smb.conf.20040411.bkup
# vi /etc/samba/smb.conf
...viで編集...
# /etc/init.d/samba restart (or /etc/init.d/inetd restart)

くらいか?

ほかに確認するとこはあるかも知れんけど、少しずつ試してみよー。


732 :login:Penguin:04/04/11 08:50 ID:IMCKVR4t
SargeのリリースってことはStableに格上げされるってこと?

733 :login:Penguin:04/04/11 08:54 ID:CkGeF7Vv
>>731
なるほど、プロセス増殖はくだらない質問の方のレスを見ると、
カーネルの問題とも限らないみたいですし、NFS使わずにちょっと試験運用してみます。
アドバイスありがとうございました。
症状が治まらないようならまた相談に来ます。

734 :login:Penguin:04/04/11 09:50 ID:A60snjU+
そういや
testing なものが stable にリリースされる瞬間って
testing はそのまま変わらないの?

735 :login:Penguin:04/04/11 10:07 ID:Wz48Sb8N
>>734
フリーズが解除されるだけじゃないのかな。

736 :login:Penguin:04/04/11 10:50 ID:VdjyiaVe
woodyのalsaについて教えてください

「GIGABYTE GA-8PE667Pro」というマザーを使っています。
付属のマニュアルによるとサウンドchipは「Realtek ALC650 CODEC」なのですが
これはalsaconfの設定リストの中にありませんでした。
色々調べて「via8233」or「via82xx」で設定すれば良いと言う事を突き止めたの
ですが、その設定もリストになくこれ以上の情報を見付ける事ができませんでした
debianではどのように設定したらよいのでしょうか?

kernelは、
「ii kernel-source- 2.4.22-3 Linux kernel source for version 2.4.22 with」を

soundcard susppend [*]
osssoundmodules [*]

にてコンパイル

alsa関係は以下のパッケージをinstallしています

ii alsa-base 0.9+0beta12-3 ALSA driver common files
ii alsa-modules-2 0.9+0beta12+3+ Advanced Linux Sound Architecture (drivers)
ii alsa-source 0.9+0beta12-3 ALSA driver source
ii alsa-utils 0.9.0beta12-1 Advanced Linux Sound Architecture (utils)
ii alsaconf 0.4.3b-4 ALSA configurator

よろしくお願いします


737 :login:Penguin:04/04/11 10:57 ID:EAsNmKKC
>>736
http://www.alsa-project.org/alsa-doc/doc-php/template.php?module=via82xx
http://alsa.opensrc.org/index.php?page=via8233

738 :login:Penguin:04/04/11 12:21 ID:yyB7fc0X
UNIXUSERについてたDVDとネットワークを使ってdebianをインストールしました。
インストール自体は普通にできたんだけど、Xがちゃんと動きません。
Asusのp4ge-vってマザーボードのオンボードのintel845geってグラフィックを利用
しようとしているんですが。

i810ドライバを使うように書いてあったので使うと
(EE) No devices detected.
Fatal server error:
no screens found
って言われてしまいます。
VESAドライバを使うと画面が映ることは映るんですが、表示が上にずれてしまい
画面最下部に一番上の部分が表示されてしまいます。
stableのドライバじゃだめなのかな?と思って、unstable(XFree86 4.3.x)にしても
同じようでした。
なんとかなりませんでしょうか?


739 :login:Penguin:04/04/11 12:28 ID:mH4Il9nj
>>738
i845ge は動く
自分で何とかしてみろ、できないならLinux はあきらめろ


740 :login:Penguin:04/04/11 12:34 ID:yyB7fc0X
>>739
i810で動くの?VESAで動くの?

741 :login:Penguin:04/04/11 12:48 ID:eLp/Mptk
i845g使ってるけど、ちゃんと起動するぞ。
i810でもvesaでも。


742 :login:Penguin:04/04/11 12:55 ID:gLupokro
http://www.kauda.jp/~koya/linux_845.html

743 :login:Penguin:04/04/11 13:05 ID:EpmrVFSk
>>740
sidにしたなら、既に動く環境です。
kernel moduleの設定はmodconfで。

>>742
情報古い(w

744 :login:Penguin:04/04/11 13:06 ID:gLupokro
>>743
死ね

745 :login:Penguin:04/04/11 13:11 ID:EAsNmKKC
春だな

746 :login:Penguin:04/04/11 15:05 ID:IXlEQewB
>>589

僕もさっき apt-get upgrade したときに似たような怒られ方をしました。
更に、偶然かも知れませんが僕のシステムにもqvwmが入っていました。
このことが、この現象と関係あるかどうかなんて、僕には分かりませんけどね。

んで、まあ、エラーメッセージの言っていることは
update-alternatives: unable to make /usr/man/man1/x-window-manager.1.gz.dpkg-tmp
a symlink to /etc/alternatives/x-window-manager.1.gz: No such file or directory
つまりは「ファイルかディレクトリがないです」ということだから、ホントに無いのか確かめてみました。
/etc/alternatives/x-window-manager.1.gz はあります。
でも、/usr/man なんてディレクトリはありません。もちろん、自分で消した覚えもないです。

どうして無いのか分からないけれど、原因はこれかなと思って、
mkdir /usr/man
mkdir /usr/man/man1
apt-get install x-window-system
とやったら今度はすんなりいきました。

でも、ホントにこれで良いのか不安は残るけど、とりあえずは良しとしました。
「それ、まずいよ」と思った識者の方、ご指摘下さいませ。

# すんごいおそレスだけど見てるかな? >>589

747 :746:04/04/11 15:09 ID:IXlEQewB
環境はwoodyです。

748 :login:Penguin:04/04/11 15:29 ID:EAsNmKKC
/usr/manなんてディレクトリは元々存在しない。
manの置き場は/usr/share/manだし。
ごまかすとしたら多分リンク張る方がいいだろうな。
# ln -s /usr/share/man /usr/man

BTSに報告されてるけど放置プレイ中っぽい
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=205188

749 :login:Penguin:04/04/11 15:41 ID:EAsNmKKC
testing以降で修正されてるみたい
>qvwm (1:1.1.11-0.1) unstable; urgency=low
>* Adapt x-window-manager alternative priority according to policy.

750 :login:Penguin:04/04/11 16:13 ID:MJLvRlqd
woody を 東芝Satellite305CDSにFDbootで ネットワークインストールに挑戦中

PCMCIAサポートの設定でPCMCIエラーが出ます。
根本的な理解不足だと思うのですが、どうしたらいいんでしょ?

NICカードは、 メルコのLPC3-CLTをつかえたらいいなと・・・・・

751 :login:Penguin:04/04/11 16:18 ID:G33NGqAc
debianにsj3のパッケージはありますか。

752 :738:04/04/11 16:54 ID:wlkB9P5A
845GEでX使おうとしていたものです。
無事いれることができました。どうやらXをバージョンアップしたつもりで、
実際はバージョンアップされてなかったみたいです。
dist-upgradeしたら、使えるようになりました。
厨房丸出しですいませんん。

ただ、17インチ液晶ディスプレイなんんですが
1280*1024で使おうとすると画面がずれてしまうので
1024*768で使っています。どうしたら大きい画面で使えますか?

753 :login:Penguin:04/04/11 16:56 ID:EAsNmKKC
>>750
使えんじゃないの。
過去ログ18の>>141あたりから読んでみそ。

>>752
くだ質に逝け

754 :login:Penguin:04/04/11 17:10 ID:mEmkLB9v
>>718
 
 http://www.samba.gr.jp/project/kb/J0/0/78.html は確認してあるんだよね?



755 :login:Penguin:04/04/11 17:22 ID:mEmkLB9v
>>732

 格上げっつーか stable -> woody を指していたのが stable -> sarge に変わる
 つうことやね。なんで、sargeまだコワイヨーってやつは apt line で stable の部分
 は woody にしとけば、リリースされてもしばらく様子見できる。




756 :非732:04/04/11 17:52 ID:bGi+9KBS
>755
stable = sargeになった時、testingはどうなるんでしょうか。
現在のunstableがtestingに格上げ?
でもunstableの名前はsidのママなんですよね。うう初心者には分かりにくい。

757 :login:Penguin:04/04/11 17:54 ID:gLupokro
>>752
アドジャストボタンを押すのです。

758 :login:Penguin:04/04/11 17:56 ID:IfRgIxIw
opera凄いね、F11押して全画面するとweb端末になったよ
Windows以外でこんな事が出来るなんて思っても見なかった
と言うかすごいのはDebianかな

759 :login:Penguin:04/04/11 17:59 ID:gLupokro
>>758
いや、opera

760 :login:Penguin:04/04/11 18:06 ID:79+IU0qM
>>756
とりあえず読め。
http://www.jp.debian.org/doc/FAQ/ch-ftparchives


761 :login:Penguin:04/04/11 18:46 ID:bGi+9KBS
>760
あ、わざわざ、どもです。英語には自信がないので、w3m-emacs + sdic +
auto-lookup 使って読んでみたんですが、

testing -> stable になったらunstableからある程度バグが取り除かれた物が徐々に testing に取り込まれて行くって感じなんすかね。

http://www.jp.debian.org/doc/FAQ/ch-ftparchives#s-frozen

このあたりに、そんな事が書かれているように思ったんですが。

762 :login:Penguin:04/04/11 18:47 ID:mPUezQvY
>>667
厨がインストールできないだけだろうと思って流していたんだが、
試してみたら、うちでも同じ現象がおきた。
がんばってすばやく、落ちるまでにインストールを終えて
カーネルにhidドライバを組み込んだものにすれば落ちない。
なぜかモジュールにしてると再起動するようだ。

763 :login:Penguin:04/04/11 18:51 ID:ydkXpgke
>>761
unstableから徐々にtetstingにパッケージが降りてくる
のはいつものことでは。

まずfrozenがtestingから分岐して、
その後frozenがstableになる
っていう流れじゃなかったっけ?

764 :login:Penguin:04/04/11 19:26 ID:+FxhvN+r
>>756
一般利用者がwoodyとかsargeとかいう名前を使う必要はない。
stable, unstable, testing...で十分。

765 :login:Penguin:04/04/11 19:33 ID:gLupokro
>>762
その実力以上の奢りで恥をかく。

766 :login:Penguin:04/04/11 19:42 ID:bPPrIzxV
>>765
いや762は気が付いたので恥ではない。

むしろ、初心に帰ることができるぶん漏れより数段上

767 :738:04/04/11 19:49 ID:wlkB9P5A
>>757
なんと!!ありがとう

768 :login:Penguin:04/04/11 20:16 ID:Aj2SgasF
>>751
> debianにsj3のパッケージはありますか。

なぜか放置プレイだな。まあ、これでも読んでくれ

http://www.debian.org/distrib/packages

769 :login:Penguin:04/04/11 20:17 ID:mEmkLB9v
>>756

>stable = sargeになった時、testingはどうなるんでしょうか。
>現在のunstableがtestingに格上げ?

 どうなるも何も変わらんよ? sidからある程度安定したとみなされたものが落ちてくるだけ。
 unstableはずっとunstableのままだ。

>でもunstableの名前はsidのママなんですよね。うう初心者には分かりにくい。

 unstableはずっとunstable。
 リリースされたらtestingのコードネームが変わるだけ。あとは玉突き式。
 unstableがなんでsidかはtoystoryでも見て来い。
 #Still In Development の意もひっかけてあるけど。

 http://www.debian.org/doc/FAQ/ch-ftparchives.html みれ。


 つーかよ、初心者に分かりにくいって藻前が混乱してるだけだろーに。
 初心者全部が藻前と一緒じゃねーよ。


770 :login:Penguin:04/04/11 20:18 ID:gLupokro
>>769
その奢りが恥の元。

771 :login:Penguin:04/04/11 20:26 ID:JGZmbJ+o
>>754 とか見てると(ry

772 :login:Penguin:04/04/11 20:45 ID:uzijhC8/
ID:mEmkLB9v

773 :login:Penguin:04/04/11 20:57 ID:V3qodMyc
>>732>>756
ここも参考になるYO!!
http://qref.sourceforge.net/Debian/reference/ch-system.ja.html

774 :login:Penguin:04/04/11 21:44 ID:bPPrIzxV
歌う前に林檎を食べると声の通りが良くなるんだって

775 :login:Penguin:04/04/11 22:01 ID:7B5o6Nsd
ポリカーボネートに歯が立ちませんですた。

776 :login:Penguin:04/04/11 22:30 ID:Pz1DHS/Z
Debian sid上のwineでmsgothic.ttcが使えないんだけど、同じ症状の人居る?

777 :login:Penguin:04/04/11 23:46 ID:4F9rt2oQ
>>776
んじゃ、がんばって原因究明して報告してください。

778 :login:Penguin:04/04/11 23:47 ID:joQixdJo
>>776
拡張子.ttcを.ttfに変えてみたり

779 :login:Penguin:04/04/11 23:47 ID:TfATFvuB
>>776
ln -s msgothic.ttc msgothic.ttf
とか
mv msgothic.ttc msgothic.ttf とかの話じゃないの?

780 :login:Penguin:04/04/12 00:38 ID:liTyLJqy
>>779
一応 ln -s msgothic.ttc msgothic.ttf はやってる
straceでおっかけるとmsgothic.ttcを読みには行ってるんだけどなぁ・・・

781 :login:Penguin:04/04/12 05:58 ID:KL1Pr3vM
dpkg-reconfigure xserver-xfree86で再設定しても
/etc/X11/XF86Config-4が変更されないんだけど
俺、なんか勘違いしてる?

782 :login:Penguin:04/04/12 05:59 ID:BDRKrcOj
>>764
そうとも言えないんじゃないかなあ。ホントに一般ユーザーならともかく、
rootなら使わないとまずい局面もあると思うぞ。
testingがstableに下りた瞬間とか、誰もが新stableに移りたいわけじゃない
からね。
そのためのoldstableだし。

783 :login:Penguin:04/04/12 06:45 ID:HQiCwPVr
>>782
安定性指向のシステムに遊び要素の固まりのdebは入れたくないなぁ。

784 :login:Penguin:04/04/12 08:10 ID:cH7HmG7d
>>776
wine は knoppix に入ってたみたいだけど
msgothic.ttc も入れてないし wine も使ってないので、すまそ。

785 :login:Penguin:04/04/12 12:56 ID:9+iy1PnG
このURIのパッチを適用したfontconfigなどのdebパッケージ
を公開されているところはないのでしょうか。

http://www.kde.gr.jp/~akito/patch/download.html


786 :login:Penguin:04/04/12 13:20 ID:EBeEbz7S
>781
XFree86 4.3 にしてから、私も同じように悩みましたが、
下記のような手順で変更できます。
新しい XF86Config-4 に記載されていました。

# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
# cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
# md5sum /etc/X11/XF86Config-4 > /var/lib/xfree86/XF86Config-4.md5sum
# dpkg-reconfigure xserver-xfree86

787 :login:Penguin:04/04/12 13:29 ID:zlmxtNsK
>>785
sid だけど。
http://tach.arege.net/debian/packages.html#label-0

788 :login:Penguin:04/04/12 13:55 ID:jm+yySUN
>>768
ないということでよろしいでしょうか。

789 :login:Penguin:04/04/12 16:30 ID:rl2dNo83
>>788
deb http://ftp.debian.gr.jp/debianguru unstable main contrib non-free
このapt lineを加えればインストール出来る模様.
stableやtestingはどうか知らない.

790 :login:Penguin:04/04/12 17:23 ID:uADwPIXg
Debian Woody インストール時に「SSH2 only?」というような内容を聞かれ、
確か NO にしたのですが、再設定はどのようにすればいいのでしょうか?

# dpkg-reconfigure では出来ませんでした。

調べたところ、sshd_configのProtocolの部分を変更すればいいことが分かりました。

現在は Protocol 2,1 になってます。Protocol 2 にすれば SSH2 only になるのでしょうか?

791 :login:Penguin:04/04/12 17:31 ID:5rIgeKSd
Hotplug makes my PC unstable!!

792 :login:Penguin:04/04/12 17:31 ID:vCcjPGPN
>>790 これで満足か?
ttp://www.unixuser.org/~euske/doc/openssh/jman/sshd_config.html

793 :790:04/04/12 17:39 ID:uADwPIXg
sshd_config の設定で Protocol 2 にして restart したのですが、Windowsのsshクライアントの
putty の ssh1 only モードでログインできてしまいました。

ssh2 only にするにはどうすればいいの?

794 :login:Penguin:04/04/12 17:42 ID:uADwPIXg
>>792
情報ありがとうございました。そこにあるドキュメントにある通り、
Protocol 2 にしましたが、>>793 に書いたとおりです。

クライアントソフトは putty なのですが、自分が今現在どちらのプロトコルで
通信を行っているかはわかるのですか?

795 :login:Penguin:04/04/12 17:48 ID:bUtXOaH6
馬鹿かこいつは

796 :login:Penguin:04/04/12 17:49 ID:zlmxtNsK
>>790
うん、そう。

797 :login:Penguin:04/04/12 19:41 ID:60oLGwfR
おいおまいら、俺のdebianは、縦書き日本語のPDFを印刷するとき、GSからPDFライタというフィルタを通さないと、用紙の向が縦長のままになる。
フィルタを通すと、なんとacroreadが立ち上がって、そこから正常に印刷しやがる。
それなら、acroreadからPDFを印刷できればいいようなもんだが、直接は印刷出来ない。
なんと、今度はGSに送ってそこから正常に印刷出来る。
何でなんだ。人のものは正常に印刷できるのに、自分の持ち物だと何か不具合が出る。
まるで、俺の人生みたいだ。
まぁいい、誰か教えろ。
GSは用紙の向きが変わらない。acroreadはAcrobat標準のフォントが自分では認識出来ない。

798 :login:Penguin:04/04/12 20:07 ID:WEEnTSCR
woodyからsargeにしようと思ってdist-upgradeしたらダウンロードする量が300MB超になっててびっくりしたよ。
エアエッジだと二日とちょっとかかるみたいだ。

799 :login:Penguin:04/04/12 20:20 ID:Ua+Y1+66
adslでネットワーク接続してるマシンに woodyをインストールしたいのですが、
ルータを使わずに ADSLモデムな場合には、インストール時の
「ネットワークの自動設定」ではどうしたらいいのでしょうか?

800 :login:Penguin:04/04/12 20:27 ID:mHdYhC9o
>>799
インストール時には設定せずに
インストール後、pppoeconfからせっていすれば?

801 :login:Penguin:04/04/12 21:16 ID:Ua+Y1+66
>>800
という事は、
ttp://www.fasp.tv/debian/debian_easy_install/image/058.config_net.use_dhcp_no.png
ここで<いいえ>として、
ttp://www.fasp.tv/debian/debian_easy_install/image/060.config_net.ip2.png
ここで<キャンセル>を選べばそれなりに進ませてくれるという事なのかな。
ためしてみます。

802 :login:Penguin:04/04/12 22:14 ID:ulCKJZ87
Debianのインストーラーって激しく使い辛い

803 :login:Penguin:04/04/12 22:17 ID:ih9vMN4N
>>799
その場で設定する気がないなら適当にEnter押して進めちゃえばいいんでないの。
そんな深く考えず。

804 :login:Penguin:04/04/12 23:16 ID:yfsbOjuO
コ」、゙、ヌテッ、ャ dhcp 、ハ、、ォサネ、ヲ、ォ・ワ・ア、ネサラ、テ、ニ、ソ、ア、ノ。「
ヘァソヘ、ホ・゙・キ・、シォハャ、チ、ヒサ、チオ「、テ、ニ、ュ、ニ・、・・ケ・ウ、キ、ソ、ネ、ュ
dhcp 、ホ、「、熙ャ、ソ、オ、ャ、、ォ、テ、ソ。」

、ウ、、ォ、鬢マ・ッ・鬣、・「・・ネ・゙・キ・、ヒ、マ。「static 、ヒ IP ・「・ノ・・ケ、ハ、、ォ、ユ、熙゙、サ、。」


805 :login:Penguin:04/04/12 23:19 ID:ltoDVjez
まぁ餅つけ

806 :login:Penguin:04/04/12 23:32 ID:nki0oxRG
今まで誰が dhcp な??箸Δ?椒韻隼廚辰討燭韻鼻?
友人のマシ????舛忙?ち帰ってきてイ?好海靴燭箸?
dhcp のありがたさが??辰拭?
こ??蕕魯?薀ぅ▲?肇泪轡?砲蓮?tatic に IP アド?垢覆??佞蠅泙擦??

807 :login:Penguin:04/04/12 23:34 ID:4FqcyUx6
うるさいハエだなぁ(AA略)

808 :login:Penguin:04/04/13 00:44 ID:IVUsUYVY
sidなんだけど、
hotplugのせいでnvidiaドライバが動かなくなるってありえる?

809 :login:Penguin:04/04/13 00:49 ID:yMhgD33B
>>808
ここのところ何通もバグリポートが出て、そのたびに鵜飼氏がこうしろ、って言って閉じてるあれか

810 :login:Penguin:04/04/13 04:09 ID:SEPpXjl/
>>809
で、その通りにすると直るの?

いずれにせよ、最近のバージョンアップで
「これまで動いていたものが動かなくなった」
という事例が頻発してるのは確かだと思うんだけど。
「こうしろ」で問題なくなるなら、それはhotplug scriptに
入っているべきだと思うんだが。

なんか、どんどん傷を拡げてるような気がする。

俺んとこでは、USB-coreがblack-listedされちゃったよ。
結局、ここんとこずっとtestingのhotplugでfixしてる。

811 :login:Penguin:04/04/13 04:34 ID:uCc6AOmo
>>793
sshd立ち上げなおしたかな?

>>802
後輩(28歳、独身女性)にインスコさせてみたが、
「RedHatより簡単」っていってたぞ。


812 :login:Penguin:04/04/13 06:49 ID:RPeg7UjD
独身(;´Д`)ハァハァ

813 :790:04/04/13 09:28 ID:p8WODQgB
>>811
もちろん立ち上げなおしました。OSも再起動しました。
しかし、Protocol 2 に設定しても putty の ssh1 only モードでログインできてしまいます。

ssh2でないと通信不可にしたいのですが。どうすれば・・・・

814 :790:04/04/13 09:40 ID:p8WODQgB
ssh2 only モードに設定できました。

今まで出来なかった原因は不明です。関係のないポートを変えたり、他の設定を
いじったりして sshd の再起動を繰り返してる内に ssh1 ではログインできなくなりました。
重ね重ね原因は不明です。僕は間抜けなので、Plochokol 2 とか書いていたのかもしれません。
すみませんでした。

815 :login:Penguin:04/04/13 09:55 ID:KcmkxfnU
使い辛いと言っているだけで、難しいと言っている訳ではない。
いい歳のようだが、意味わかる?

816 :login:Penguin:04/04/13 11:22 ID:q2JDqI2e
>> 787

レス,サンクス。

817 :login:Penguin:04/04/13 11:28 ID:FiY9EVXp
Debian用にPCを組もうとしてるんですが
M/B選びで悩んでいます。
i865ではトラブルが多いでしょうか?

818 :login:Penguin:04/04/13 12:57 ID:MQQ8ZvQW
>>817
でびあんはパーフェクチヴなのでどんな最新のマザーでも
問題は生じません。

819 :login:Penguin:04/04/13 13:43 ID:F3XcULHE
>>817
sarge以降をつっこむ予定なら問題ないんじゃないの。

820 :login:Penguin:04/04/13 14:52 ID:VPVmkFq6
>>817
大丈夫。
俺がIntel865Gで使ってる。
sargeだがXも問題ないよ。


821 :login:Penguin:04/04/13 16:24 ID:APfVuiJo
debianには十分満足しているけど、IMEだけはwindowsにかなわない。
wnn7もクライアントがバージョンアップして、KDEとの相性はatokxより良くなったが、
まだインライン変換には対応していないし、atokxはjustがバージョンアップをしないから、どんどん他のソフトとの相性が悪くなる一方だ。
だから、今は、wnn7,atokx,kinput2+esecanna+wnn7dic という三つのIMEを立ち上げて、
デフォルトにwnn7とし、アプリケーションとの相性によって、メニューをいじって他のIMEとの組合わせで使っている。
誰がもっといい方法があったら教えてくらさい。

822 :login:Penguin:04/04/13 16:33 ID:f5N7IaRE
>>821
Anthy/uimの組み合わせはいかがか?

もっとも自分はskkinput(とemacs上ではskk)で充分だったり
するのだが。


823 :login:Penguin:04/04/13 16:36 ID:P+0r+DdX
t-code もなかなかいいよ。

824 :821:04/04/13 16:39 ID:APfVuiJo
>>822

ありがと、Anthy/uimはまだ使ったことがない。
試してみる。原稿書く仕事なので、何はなくとも日本語変換なんだ。
期待通りだったらいいな。

825 :821:04/04/13 16:40 ID:APfVuiJo
>>823

t-code って聞いたことないな。
探してみるよ。ありがと。

826 :login:Penguin:04/04/13 16:50 ID:ij9h82IB
>>821
UNIX板のT-Codeスレ。
http://pc3.2ch.net/test/read.cgi/unix/1061936143/

827 :login:Penguin:04/04/13 17:02 ID:RMcfO6Gj
漏れはim-jaがいいと思う。
http://im-ja.sourceforge.net/

828 :login:Penguin:04/04/13 17:05 ID:1uNu0LoS
>>821
> まだインライン変換には対応していないし、

これアプリは何?
Wnn7のxwnmo自体はインライン変換に対応してます。


ところでWindowsもMac OS XもLinuxで、
変換モード状況をカーソル付近に表示するのって、
kterm(Athena widget) + kinput2くらいじゃないのかな?
近くにないと今のモードが分かりにくいんだけど…

eggはelisp書いてカーソルの色を変えているんだけどねえ。

829 :login:Penguin:04/04/13 17:59 ID:QYPPXHrh
つかスレ違い。

830 :login:Penguin:04/04/13 18:42 ID:1uNu0LoS
あ、ごめん、直前読んでいたIM関係のスレと勘違いした…

831 :login:Penguin:04/04/13 19:14 ID:VnztJGtT
anthyの変換精度はかなりのところまできているんだが、
uimがまだまだ不安定なのよね。

832 :821:04/04/13 20:13 ID:APfVuiJo
>>826

どうもありがと、T-Code一度挑戦してみます。

>>827

IM-jaかぁいろいろあるんですね。試してみます。

>>828

対応してるんですか。KDEだとonthespotではだめみたいっす。
そういえば、GTK2のアプリでは大丈夫みたいだから、(GTK2って無理矢理onthespotですよね)
KDEの問題なのかぁ。でも、atokxだとkonq以外はonthespotでもまともになったんで、
てっきり、wnn7側の問題かと…。
それに、オフィシャルサイトでも、overthespotを使えと書いてあったもんで、
すいません。早とちりみたいっす。

>>831

確かに、いいです。
さっそく、uim+anthy+prime でこれ書いてるんですけど、
多少のところに目をつぶれば、ひょっとして、一番いいかも。

833 :login:Penguin:04/04/13 22:43 ID:8Dt/Iifh
AUの人名癖って直ったの?

834 :login:Penguin:04/04/13 23:03 ID:Ieo/ewSS
なんだAUって。

835 :login:Penguin:04/04/13 23:29 ID:8Dt/Iifh
anthy+uim

836 :login:Penguin:04/04/13 23:40 ID:waCgvt2c
>>833
上流では直ってるようだが。


837 :login:Penguin:04/04/14 00:13 ID:MI3Ntkch
いいかげんanthy/uimスレでやってください。

838 :login:Penguin:04/04/14 00:26 ID:uVFmyEwb
ほかのディストリでは自分でcannaの辞書をインポートするところもあるようだけど
でびあんではanthy-cannadicをインストールするだけでよい

839 :login:Penguin:04/04/14 01:18 ID:eLrwT5f5
>>599-602
sarge なのでやっとこの話題に追いつきまひた.

これ,gdm の BTS にも出てるけど,仕様変更であって Bug ではないな.
gdm で Default を選べば ~/.xsession が呼ばれるのでユーザ設定の余地があるけど,
明示的に gnome を選ぶとユーザ設定の余地がない.

xim 専用だと本体には取り込まれないだろうから,

/etc/X11/Xsession.d/98user-startup

# execute user's custom startup script before actual X session
if [ -f $HOME/.xsessionrc ]; then
. $HOME/.xsessionrc
fi

あたりにしておくといいかも….

# 実際自分は xhost なんかもここに入れてるし….

840 :login:Penguin:04/04/14 11:23 ID:GsXlijeC
debianのインストールに PPP over ethernet を使用することは可能ですか。

841 :login:Penguin:04/04/14 11:54 ID:C/nESxdl
woodyならpppoeも入るはずだが。

842 :login:Penguin:04/04/14 11:57 ID:qLNaR4Ar
>>841
sargeは?

843 :login:Penguin:04/04/14 11:57 ID:XimV19c+
debian使い始めました
icewmを使用しているのですが、壁紙を表示させたいと思い
iceconfをインストールして設定したらテーマが変わってしまって
しかもメニューも日本語表示でなくなりバグってしまいました

元の日本語表示と黒いクールなテーマに戻したいのですが
どうすればよいのでしょうか?

844 :login:Penguin:04/04/14 12:07 ID:HhFGXThm
deselectを使っていたところ、導入または削除の段階で下のようなエラーが
出るようになってしまいました。
apt-getでも同様のエラーが出ます。

dpkg: `ldconfig' not found on PATH.
dpkg: `start-stop-daemon' not found on PATH.
dpkg: `install-info' not found on PATH.
dpkg: `update-rc.d' not found on PATH.
dpkg: 4 expected program(s) not found on PATH.
NB: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin.
E: Sub-process /usr/bin/dpkg returned an error code (2)

変だなぁ。これらのファイルはちゃんと/sbin/ないし/usr/sbin/のパス上に
あるのに。

845 :login:Penguin:04/04/14 12:32 ID:HhFGXThm
今、http://www.debian.org/ を開いてみたら

>NO Software Patents in Europe

という文字が…

>We are protesting against software patents in Europe.

だって。どういうこと?

846 :login:Penguin:04/04/14 12:35 ID:FqDBtY5P
そのままの意味

847 :login:Penguin:04/04/14 12:53 ID:qtjMi2OU
>>843
Window Managerスレにでも逝け。

>>844
まんまだが、rootのPATHに/usr/local/sbin...は含まれているのか?
$PATHで確認してみそ。

848 :login:Penguin:04/04/14 13:49 ID:AyYgNrVO
>>845
http://demo.ffii.org/ に賛同してるところは web に書いてる。
gnu.org とか kde.org とか。


849 :login:Penguin:04/04/14 13:50 ID:Apjl8XXX
>>844
ぐぐれよ。
http://www.google.co.jp/search?q=dpkg%3A+%60ldconfig%27+not+found+on+PATH.&ie=UTF-8&oe=UTF-8&hl=ja&lr=lang_ja

850 :login:Penguin:04/04/14 13:51 ID:Apjl8XXX
>>845
いつの話だよ。

ソフトウェア特許問題スレ
http://pc3.2ch.net/test/read.cgi/linux/1061982926/

851 :843:04/04/14 13:52 ID:XimV19c+
もどりました^^;

852 :840:04/04/14 14:27 ID:GsXlijeC
>>841
> woodyならpppoeも入るはずだが。

そういういみではなく、FD で boot して network install する際に、PPP
over ethernet は利用可能ですか。


853 :login:Penguin:04/04/14 14:45 ID:PL+Pr8p/
emacs の起動時に次のエラーをもらいます。
error: "Can't activate input method `japanese-skk'"

ヒント下さい。

~$ dpkg -l |grep skk
ii dbskkd-cdb 1.01-11 The fastest dictionary server for SKK
ii skk 10.62a-7 Simple Kana to Kanji conversion program
ii skkdic-cdb 20040323-1 SKK Dictionary in cdb format (SKK-JISYO.L.cd
ii skkinput 2.06.4-1 X input method for Japanese with SKK convers

XEmacs では skk で入力できます

854 :login:Penguin:04/04/14 14:55 ID:GsXlijeC
>>853
SKK は obsolete、ddskk をつかえばよろしい。

855 :login:Penguin:04/04/14 15:08 ID:PL+Pr8p/
>>854
ddskk 12.2.rel.0-3
インストで解決しました。

ありがとうございました。

856 :login:Penguin:04/04/14 15:36 ID:+eNXaPb1
ここかくだ質か迷いましたがdebianなんでこちらにpostします。
専用スレもみあたりませんでしたので。

debian woodyを使ってますがspamが増えてきたので
fetchmail+spamassassin+procmailで対応しようと思いました。
で、現時点でプロバイダ側で全部転送する設定なのですが
procmailで転送しようとするとeximに怒られました。
そもそも設定がLocal delibery onlyだったで当然なのですが
この場合の妥当な設定はどのようになるんでしょう?

まず、基本的には常時オンラインです。
そしてprocmailの転送以外は全てプロバイダ側のsmtpを利用します。
情報へのポインタもしくは情報そのものがありましたら宜しくお願いします。

857 :login:Penguin:04/04/14 15:44 ID:lILXh8Ix
>>852
聞く前に試せ。

858 :login:Penguin:04/04/14 15:47 ID:0mBCgbCw
パッケージのビルドについて質問です。

自分で CVS 管理しているとあるソフトウェアの deb パッケージを作ってます。
CVS 管理しているソース自体に (ソースディレクトリ)/debian というディレクトリ
を作り、パッケージ関係のファイルはここで管理してます。

debuild をかけると、lintian に以下のような文句を言われます。

W: xxxxx source: source-contains-CVS-dir ruby/CVS
W: xxxxx source: source-contains-CVS-dir ruby/doc/CVS
W: xxxxx source: source-contains-CVS-dir ruby/doc/setup/CVS
W: xxxxx source: source-contains-CVS-dir ruby/doc/setup/doc.en/CVS
W: xxxxx source: source-contains-CVS-dir ruby/doc/setup/doc.ja/CVS

debuild から呼び出される dpkg-source が CVS ディレクトリを含めた tar.gz を
作ってしまうのだと思いますが、CVS ディレクトリを含ませないような
debuild のオプションや環境変数みたいなものってあるんでしょうか?


859 :login:Penguin:04/04/14 16:00 ID:8eLk52ax
>>865
うに板の exim スレか internet mail なんとかスレで聞いたら?

あと
> で、現時点でプロバイダ側で全部転送する設定なのですが
この意味がよくわからない。

860 :865:04/04/14 16:23 ID:+eNXaPb1
>>859
了解しました。移動します。
Linux板だけみていたのでUNIX板のほうはすっかり忘れておりました

>> で、現時点でプロバイダ側で全部転送する設定なのですが
>この意味がよくわからない。
えっと、プロバイダが標準で提供しているメール転送機能を有効にして、
他のアドレスにも転送しているんです。

このままだとSPAMも全部送られてくるので、プロバイダ提供の
メール転送機能を無効にして、
スパムフィルタを通してから転送しようと思ったわけです。


では。UNIX板に行ってきますー

861 :856:04/04/14 16:24 ID:+eNXaPb1
って865じゃなくて856ですた。申し訳ない

862 :login:Penguin:04/04/14 16:34 ID:GsXlijeC
>>857
うるさい、でぶ。


863 :login:Penguin:04/04/14 16:59 ID:O7F+gKS6
>>862

人に聞くときには、それなりの礼儀を持ちましょう。

それと、丁寧に質問している方には、せめて、愛想よく断りましょう。
閉鎖的ですよ、このスレは。気をつけましょう。

864 :login:Penguin:04/04/14 17:12 ID:GsXlijeC
>>863
> 人に聞くときには、それなりの礼儀を持ちましょう。

すいません。

> それと、丁寧に質問している方には、せめて、愛想よく断りましょう。
> 閉鎖的ですよ、このスレは。気をつけましょう。

どういうことか詳しく教えていただけないでしょうか。

865 :login:Penguin:04/04/14 17:15 ID:NoJcNgXf
>>863
閉鎖的なのはおまいだろ

866 :login:Penguin:04/04/14 17:16 ID:ZoxjMkQ0
僕の肛門も閉鎖(ry

867 :login:Penguin:04/04/14 17:17 ID:Gu89pj0G
Debianなんて餓鬼が使ってるんだから、閉鎖的にもなるわな

868 :login:Penguin:04/04/14 17:22 ID:NoJcNgXf
      | Hit!!
      |
      |
   ぱくっ|
     /V\
    /◎;;;,;,,,,ヽそんなので
 _ ム::::(,,゚Д゚)::| 俺様が釣られると思ってんのか!!
ヽツ.(ノ:::::::::.:::::.:..|)
  ヾソ:::::::::::::::::.:ノ
   ` ー U'"U' 

869 :login:Penguin:04/04/14 18:06 ID:NoJcNgXf
>>858
debuild -ICVS

870 :login:Penguin:04/04/14 18:55 ID:fBZh0Dfv
AirH"でパッケージのインスコ終わんねー
素直に学校でisoファイルをダウンロードしようかな。

871 :login:Penguin:04/04/14 20:00 ID:QCkTRQVB
>>870
>AirH"でパッケージのインスコ

シャア:馬鹿なことはやめろ!
>>870:やってみなければわからん!
シャア:正気か!?
>>870:貴様ほどインスコを急ぎもしなればAirH"に絶望もしちゃいない!


872 :login:Penguin:04/04/14 20:51 ID:p+sM2r/D
sid用のEmacs22のアプトラインをご存じの方。
教えていただきたい。

873 :login:Penguin:04/04/14 21:07 ID:Il1bF89n
自分でbuildしれ。アフォ

874 :login:Penguin:04/04/14 21:28 ID:MSedAQTw
そもそもemacs22なんて出てたっけか?

875 :login:Penguin:04/04/14 22:03 ID:8rx/emei
21.3.50 の deb は woody 上ではうまく作れてんだけど、sid だとなんか駄目
なんだよなあ。最近やってないからなにが駄目だったのか忘れたけど。

876 :login:Penguin:04/04/14 22:39 ID:r267X7Sj
sargeのxfce4に関する質問です。

apt-get install xfce4

でインストール後に、startxとすると画面左上にktermは立ち上がるものの、
背景はtwmのときと同じ灰色単色に。(但し、ktermはxfce4のテーマになっています)
画面下のパネルも現れない……
おまけに日本語入力できない(ktermだけは出来る)

xfce4を使うのに他に何か必要なもの&設定はありますか?
ちなみに

・gnome2はインストールしていない
・twmは動く&日本語は入力/表示OK

という状態です。

877 :login:Penguin:04/04/14 22:54 ID:p+sM2r/D
>>876
~/.xsessionに書いてるか
xfce-mcs-manager
xfwm4 --daemon
xftaskbar4 &
xfdesktop&
exec xfce4-panel

878 :login:Penguin:04/04/14 22:56 ID:MSedAQTw
>>877
exec xfce4-session
だろう。

879 :login:Penguin:04/04/15 00:01 ID:k/zZX0d2
openoffice-l10n-jaに関しての質問です
apt-getでインストールしました
xfontselでは認識されているんですが
openoffice.orgからは、OpenTypeフォントが認識されてません。
ほかに必要な設定はあるのでしょうか。


880 :login:Penguin:04/04/15 01:36 ID:3TYFMcKa
OOoはOpenType使えたっけ?

881 :login:Penguin:04/04/15 01:54 ID:t/lWQ9Ha
sargeでgdmをupgradeしたらログイン画面のセッションがデフォルトだけになっちゃった。
gnomeしかたちあがらねぇ。
他のwm使いたいんですけど、どこに登録すればええのでしょうか?

882 :login:Penguin:04/04/15 02:10 ID:XR5N4r4E
$ ls /etc/X11/gdm/Sessions/
Debian Gnome Xsession


883 :881:04/04/15 03:04 ID:t/lWQ9Ha
いや、そこにファイルはあるんだけどgdmが読み込んでないみたいなんですよ。
バージョンは2.4.4.7-1。
何か本家のMLで検索したら設定とかいろいろ変わったらすいって読みとれた。
/etc/dm/Sessions以下にセッション追加するみたいだけど..ちっともわからんotz

884 :login:Penguin:04/04/15 03:40 ID:GRUQ+s/f
sidでX.orgのX11R6.7のパッケージやってる人っているんでしょうか?
ttp://www.apt-get.org/ でも引っかからなかった orz

885 :login:Penguin:04/04/15 03:57 ID:3TYFMcKa
そんなもんのパッケージつくってる暇があるならsargeの方を手伝え、と言われるぞ(w

886 :login:Penguin:04/04/15 05:01 ID:XR5N4r4E
>>883
$ cat /etc/dm/Sessions/gnome.desktop
Name=GNOME Session
Comment=This is the GNOME session by gnome-session
Exec=gnome-session
Icon=/usr/share/pixmaps/gnome-logo-icon.png
Type=Application

とかなんじゃないの? default.desktopは、~/.xsessoin読むらしいし。

887 :login:Penguin:04/04/15 08:01 ID:mOT/rsjn
ハマッたので報告かきこ

症状:
apt-get install apache-perlでCGI環境導入。
/etc/apache-perl/httpd.confを正しく編集。
正しいCGIを作成。
アクセスすると505エラー。ログは"Premature end of script headers"。

解決方法:
mkdir /var/log/apache

原因:
/usr/lib/apache/suexecがログを書けないから。
apache-perlは/var/log/apache-perl/以下にログを書き、
suexecは/var/log/apache/以下にログを書くが、
apt-get install apache-perlでは/var/log/apache/が作成されないから。

888 :login:Penguin:04/04/15 10:24 ID:iIxsxQeQ
>>854
何で旧SKK残しっぱなしなんだろね。

889 :login:Penguin:04/04/15 11:25 ID:fMmhkk+G
誰もなにも言わないからじゃないの。

890 :login:Penguin:04/04/15 12:54 ID:0sj/4xNi
>>887
> ハマッたので報告かきこ
このスレッドだけで埋もれさせるには惜しい内容。
ぜひBTSに投げれ。


891 :login:Penguin:04/04/15 13:26 ID:hXBaRMNt
国内代表者に聞くオープンソースの今
http://www.itmedia.co.jp/enterprise/special/0404/ossnow/

ムトゥ神キタ━━(゚∀゚)━( ゚∀)━(  ゚)━(  )━(  )━(゚  )━(∀゚ )━(゚∀゚)━━!!!!!

892 :login:Penguin:04/04/15 13:42 ID:w0Pq4Jat
>>891
なんで紙なの?

893 :login:Penguin:04/04/15 14:26 ID:ahOs50ey
>>892
以前、メーリングリストで、どんな低脳の
質問にも丁寧に回答してたから。


894 :login:Penguin:04/04/15 14:34 ID:fMmhkk+G
ムトゥ神乙彼

895 :login:Penguin:04/04/15 14:44 ID:t587QoAc
>>892
http://debian.fam.cx/index.php?Tips#content_1_42
Tips。

896 :login:Penguin:04/04/15 16:17 ID:PdQBQpaN
>>892
伽藍におわすお方こそ神であろう


897 :login:Penguin:04/04/15 16:56 ID:FevSs1Bf
vanillaのインストールディスクをCD-Rに作りたいんですが、
CD-ROMセットを焼かずに、必要な分(フロッピー6枚分のデータ)だけ
CD-Rに焼いて作ることはできますか?

898 :login:Penguin:04/04/15 18:47 ID:mDBYEs/g
>>896
誰もいませんよ?

ガ(ry

899 :login:Penguin:04/04/15 19:32 ID:xefXso90
>898 は
が ら ん が ら ん
ということを言いたいのですね??

900 :login:Penguin:04/04/15 20:57 ID:u3JShza7
な、なんだってーーー!(AA略

分かんなかった。orz

901 :login:Penguin:04/04/15 22:12 ID:IWbXAGdu
876です。

set-language-envで作成したxsessionの最後に>>877を追加。
.xsessionの先頭に以下を追加

TERMINAL_EMULATOR=NONE
WINDOW_MANAGER

更に.gtkrc-2.0というファイルをを作って以下を記述。
(東風ゴシック12pt : ttf-kochi-gothicインストール済み)

gtk-font-name = "kochi gothic 12"

見事にxfce4が立ち上がりました。日本語の表示/入力もOK。
しかもメニューまで日本語とは……

xfce3はインストール→startxで動いていたので、xfce4も同じだと思っていました。
>>877 >>878の方、ありがとうございました。

で、もう一つ質問なんですが。
sargeからemacs-dlが無くなったみたいなんですが、
emacsでFreewnnを使って日本語入力する方法をご存知の方います?
(出来ればxemacsは使わない方向で)

902 :login:Penguin:04/04/15 23:20 ID:8/0bpSGN
>>901
どうぞ
ttp://www.google.co.jp/search?q=emacs+Freewnn&ie=UTF-8&oe=UTF-8&hl=ja&btnG=Google+%E6%A4%9C%E7%B4%A2&lr=lang_ja

903 :881:04/04/15 23:56 ID:t/lWQ9Ha
>>886
結局、/etc/dm/Sessions/xfce4.desktop作って
[Desktop Entry]
Name=Xfce4
Comment=Xfce4
Exec=/usr/bin/xfce4-session
# no icon yet, only the top three are currently used
Icon=
Type=Application
って書き込んでます。
これで起動はした。
でもxfce4のメニューなんかは英語のままでーす。
日本語入力もできねぇ。ダウングレードしようかと検討中。

904 :login:Penguin:04/04/16 01:03 ID:c4wZNgF5
>>903
> でもxfce4のメニューなんかは英語のままでーす。
> 日本語入力もできねぇ。ダウングレードしようかと検討中。

そのくらい環境変数書けよ。fam.cxにも書いてあるぞ。

905 :login:Penguin:04/04/16 01:41 ID:QVNTXmim
再び876です。

>>902
ありがとうございます。

apt-get egg

でTamago V4を入れた後、emacs起動→Ctrl+\で日本語入力できました。

ただ、emacs起動後に"japanese-egg-wnnが見つからない"というメッセージが出るのですが。
一先ず、.emacsの

(set-input-method 'japanese-egg-wnn)
(toggle-input-method nil)

をコメントアウトしてエラー表示を回避してますが……
ちなみに.emacsはset-language-envで作成したものです。


906 :login:Penguin:04/04/16 01:53 ID:srT8p0DZ
>>905
wnn7egg - Wnn-nana-tamago -- EGG Input Method with Wnn7 for Emacsen

ってのがありますが、こいつはどんな関係ざんしょ

907 :login:Penguin:04/04/16 02:23 ID:4wekcFtS
>>904
そういわず助けてくれないか?

908 :login:Penguin:04/04/16 02:59 ID:TusN9WaB
>>907
>>600

909 :login:Penguin:04/04/16 03:43 ID:DzvVRjBI
gdm, kdm, wdm 以外で wm を選択できる dm ない?


910 :login:Penguin:04/04/16 04:50 ID:Tu+P3EG/
SargeのIRCdの事なんだけど

ircd-irc2 (2.10.3p5-2)
オリジナルの IRCNet IRC サーバデーモン

ircd-ircu (2.10.11.04-3)
Undernet IRC Server daemon

これは性能時に大きく変わるとか、そう言うことはありますか?
Debian の標準(?)は ircd-ircu のようだけど、日本で一番利用者が
多いのは IRCNet だっけ?どちらを使ったら良いのか・・・

アドバイスお願いします。

911 :login:Penguin:04/04/16 06:41 ID:MSQVPgim
最近xfceって良く聞きますが今更あのWMにこだわる理由って?

912 :login:Penguin:04/04/16 07:18 ID:c4wZNgF5
>>906
何との関係? 読んだ通りだけども…

913 :login:Penguin:04/04/16 07:31 ID:5LXG0c8n
>>911
/**軽くて多機能--XFceスレ**/
http://pc3.2ch.net/test/read.cgi/linux/1075393158/

914 :login:Penguin:04/04/16 07:55 ID:srT8p0DZ
>>905
$ dpkg -l |grep wnn
ii freewnn-common 1.1.0+1.1.1-a0 Files shared among the FreeWnn packages
ii freewnn-jserve 1.1.0+1.1.1-a0 Japanese input system
ii kinput2-wnn 3.1-3 An input server for X11 applications that wa
ii libwnn0 1.1.0+1.1.1-a0 FreeWnn library for Wnn (FreeWnn jserver)
ii libwnn6 1.0.0-11 Wnn6 client library

これ、knoppix のです

915 :login:Penguin:04/04/16 22:32 ID:QpCPwzOz
FletsADSLでネットにつなぎたいんだけど、
pppoeとかやって、ifconfig ppp0でipアドレスもらってるんだけど、
pingやっても返事ないし、もちろんブラウザでページも見れない。
これって何でなんだー!
わかる人、教えてちょんまげ。

916 :login:Penguin:04/04/16 22:37 ID:UKttBj31
>>915
エスパーを呼べ。
というか、その情報量では回答しようがない。


917 :login:Penguin:04/04/16 22:39 ID:QpCPwzOz
>>916
どれだけ書けばいいでしょうか。
必要なだけおっしゃってください。


918 :login:Penguin:04/04/16 22:40 ID:GxdHTY7X
エスパーです。DNS設定見直して出直してください

919 :login:Penguin:04/04/16 22:46 ID:QpCPwzOz
>>918
エスパーさん、DNSは/etc/resolv.confにプロバイダのものが書かれてますが、
それだけじゃ駄目ですか?

920 :login:Penguin:04/04/16 22:47 ID:GxdHTY7X
    ∧_∧ ミ __ __
   ;< #`Д´>つ| |\\.| | ファビョーン
    ( つ ノ  | |_|≡| |
    彡

921 :login:Penguin:04/04/16 23:17 ID:KddBtR2J
>>919
IPアドレスでもダメなの?
くだ質向きっぽいな。

922 :login:Penguin:04/04/16 23:42 ID:QpCPwzOz
やったこと書きます。
皆さん、お願いします。

1.pppoeconf を実行して、設定。
2./etc/ppp/peers/dsl-providerの中に、
  pty "pppoe -I eth0 -T 80 -m 1412"
  persist
maxfail 0
を書く。
3./etc/network/interfacesの中に、
  auto ppp0
iface ppp0 inet ppp
provider dsl-provider
  を書く。
4./etc/ppp/pap-sercretsの中に、
  user@provider.ne.jp * passwd
  があるのを確認する。

以上をやりました。
ifconfigをした結果は、eth0 ppp0 ppp1 ppp2 があり、
ipをもらってるのはppp0だけでした。


923 :login:Penguin:04/04/16 23:44 ID:d8EkBPbN
pppoeで繋ぐ奴っているんだ

924 :login:Penguin:04/04/16 23:56 ID:QpCPwzOz
>>923
fletsでpppoe以外で接続する方法があったら教えてください。

925 :login:Penguin:04/04/17 00:11 ID:GPZvYFEP
ウチは1.5Mのフレッツだけどpppoeconfなんて使わないで

1. /etc/ppp/pap-secreに
user@provider.ne.jp * passwd

2. /etc/ppp/peers/dsl-providerに
user user@provider.ne.jp
usepeerdns

でponすれば繋がるぞ。

926 :login:Penguin:04/04/17 00:11 ID:I43ryvEz
pppoe って
ポポポオエ で読み方あってますか?

927 :login:Penguin:04/04/17 00:13 ID:twzvtQ3r
>>922
くだ質行け。

その前にnetstat -rnの結果と、
tethereal -i ppp0の結果を眺めとけ。


928 :login:Penguin:04/04/17 00:25 ID:qqPYTnJ8
>>926
大体正解。

929 :login:Penguin:04/04/17 02:02 ID:lUYC8MBS
apt-getでどんなプログラムをインストールできるかを知るにはどうしたらいいのでしょうか?

930 :login:Penguin:04/04/17 02:05 ID:z54izl60
apt-get install aptitude

931 :login:Penguin:04/04/17 02:06 ID:twzvtQ3r
>>929
apt-cache search .

932 :login:Penguin:04/04/17 02:41 ID:UAMoMxsB
apt-get install synaptic

933 :login:Penguin:04/04/17 04:00 ID:vsVVFt7K

そんなの apt-get install dselect に決まってるじゃん


934 :login:Penguin:04/04/17 09:06 ID:BSNxMh5l
なんかkcontrolとかからapt-getでインストールしたkochiフォントが見えないんだけど、
これは自分で登録しないといけないのかな?

935 :login:Penguin:04/04/17 09:39 ID:gfGx7Do4
>>893
Debianじゃないが、Sambaの小田切さんもかなり神。


936 :login:Penguin:04/04/17 10:12 ID:6Vq/K2Dx
>>934
そんなことないと思う
たしか、自動で登録されてたはず

フォントサーバの設定してる?


937 :login:Penguin:04/04/17 11:22 ID:8uVMjtpf
woodyだとxft2が見つからないしdefomaがめんどくさそうだからsargeが来るまでjis-fixedとmisc-fixedでいいや('A`)

938 :login:Penguin:04/04/17 11:34 ID:0aEUQDR8
>>929
zshでapt-get install <tab>


(w

939 :login:Penguin:04/04/17 13:40 ID:gfGx7Do4
woodyでCUPS使ってる人はいらっしゃいますか?
使い心地などを聞いてみたいのですが。


940 :login:Penguin:04/04/17 13:44 ID:twzvtQ3r
いい湯加減です。

941 :not 939:04/04/17 14:11 ID:mMFI3a63
>>940
lprngからわざわざ乗り換えるほどのものでしょうか?

942 :login:Penguin:04/04/17 14:19 ID:95cWKaUx
人それぞれ。

943 :939:04/04/17 14:30 ID:gfGx7Do4
sambaでプリンタ共有を作る時に、LPRngにするかCUPSにするか
で迷っているんですが、そんなに変わらないってことですかね。

ってことはwoodyのCUPSはLPRngと同じくらい安定してるってこ
とかしらん。
となると試しにCUPSという手もあるなあ。


944 :login:Penguin:04/04/17 14:33 ID:twzvtQ3r
cupsはIPPを喋るので、クライアントによってはsambaはいらないかも。
というかdebian関係ないだろ。

> ってことはwoodyのCUPSはLPRngと同じくらい安定してるってことかしらん。

アフォ?


945 :939,943:04/04/17 15:41 ID:gfGx7Do4
アフォ?はひどいな。安定して動いてくれるのを期待しただけなのに orz
cupsがIPPを喋るのは知りませなんだ。教えてくれてありがとです。

できるだけstableなapt-lineからパッケージを入れたいので「testing,
unstableから持ってくれば良し!」とはしたく無いのです。


946 :login:Penguin:04/04/17 17:10 ID:3jeOHA1y
質問ではないのですが、Debianの素晴らしさに感動いたしました。ありがとう。

947 :login:Penguin:04/04/17 17:16 ID:Ab1nkKeu
どういたしまして。

948 :login:Penguin:04/04/17 17:29 ID:gIa1ckVl
今時lprng使ってる奴いるの? みんなcupsだろ

949 :login:Penguin:04/04/17 18:04 ID:d9DNbKjs
漏れのプリンタはcupsでは動かん。

950 :login:Penguin:04/04/17 18:12 ID:mMFI3a63
coreutilsに入っている /bin/dir はいったい何のためにあるんでしょうか。
使い方もバイナリのサイズも ls と全く同じです。
なんでハードリンクやsimlink, aliasではないんでしょう?

% dir -il /bin/dir
38696 -rwxr-xr-x 1 root root 72460 2003-10-05 08:10 /bin/dir*

% ls -il /bin/ls
39583 -rwxr-xr-x 1 root root 72460 2003-10-05 08:10 /bin/ls*


951 :login:Penguin:04/04/17 18:15 ID:mJNuXS1F
何使おうが本人の自由。
漏れはどっちも動くが、どっちも使わん。

952 :login:Penguin:04/04/17 18:24 ID:G0evS34o
>>950
BTS しといてよ。

953 :login:Penguin:04/04/17 19:44 ID:Jx+Zjacr
>>950
$ info dir
かな?ハードリンクではない理由は俺も分からん。

954 :950:04/04/17 20:48 ID:mMFI3a63
>>953
ヒントありがとうございました。
man ls をよく見ると vdir という ls -l にそっくりなものもありました。

vdirでググってみると、
dir も vdir も この↓あたりが起源のようで、
http://www.gnu.org/software/fileutils/fileutils.html
Debian特有のものではありませんでした。

FreeBSDでもfileutilsというパッケージの中に
gls, grm, dir, vdirなどが入ってました。

955 :login:Penguin:04/04/17 21:48 ID:5aMMX3lh
>>950
sidだけど、双方のfileを16進でdumpしてdiffしてみたら、
1Byteだけ違いが有った(w

956 :login:Penguin:04/04/17 22:05 ID:yxks8vQW
はじめて debianに触れるんだけど、
なんで apt-get install migemo で emacs とかまで入るのでしょうか?
vi派の方はどうしてる?


957 :login:Penguin:04/04/17 22:09 ID:zxCQxlCq
>>950
> coreutilsに入っている /bin/dir はいったい何のためにあるんでしょうか。

GNU coding standardsも嫁。

> 使い方もバイナリのサイズも ls と全く同じです。
> なんでハードリンクやsimlink, aliasではないんでしょう?

$ md5sum /bin/dir
af4c015f445d68a977c5a6f6e2d325d4 /bin/dir

$ md5sum /bin/ls
6dcbf1acea6b102bc40de4cda0f40649 /bin/ls


958 :login:Penguin:04/04/17 22:13 ID:ynuzRhj9
>>956
vimをリビルドしてcmigemo

959 :login:Penguin:04/04/17 22:15 ID:j1BIAChk
>>945
安定してなかったらstableに入ったりはしないんじゃないかと。

960 :login:Penguin:04/04/17 22:47 ID:xW2DqROa
Sargeインスコ実験ついでに、パッケージの説明も読まずに入れまくってしまう厨から脱却しよう。
ってことでpackages.debian.orgと照らし合わせながらRecommendedやSuggestedなパッケージを取捨選択して
必要十分な環境を構築しようと思ったんですけどね。

とても無理。
追いかけきられない(特にデスクトップ環境辺り)
もうtaskselで終わりたい気分。

みなさんはどうやって取捨選択してますか?

961 :login:Penguin:04/04/17 22:59 ID:IeD/Dd2t
HDDを節約するマシンではとりあえず最低限の環境でインストールして
必要なツールが出てきたらその都度install

実験的にHDDに余裕のある場合は
とりあえず必要かな?と思ったパッケージは全部インストール


後者のやり方だとaptitudeで選択してるだけで楽に1時間は吹っ飛ぶけどな。


962 :login:Penguin:04/04/17 23:49 ID:5LyV4LJe
>>960
・初回インストールは基本システムのみ。(taskselは使わない)
・apt-line編集して、必要なソフトをapt-get install。

で、依存関係を解消しつつ簡単に必要なものだけ入れられると思うけど。
せっかくaptがあるんだから活用しないと。

963 :login:Penguin:04/04/17 23:56 ID:EYkhVqg2
>>959
うーん。安定して使えるモノってのと、不完全なモノってのは別なのかな。

むかしstableからphpgroupware-*てのを入れたんだけど、まだ作りこんで
ない箇所があるみたいで、いまいち使えなかった経験があるのです。
だからcupsもstableだからと言って、万全に使えるのかどうかに疑問が
あったわけで、実体験を聞いてみたかったのです。

cupsysのchangelog読んでみまつ。


964 :login:Penguin:04/04/18 00:12 ID:X9RCo0T9
>>962
自分も「基本システムのみ→apt-getで順番に必要なものだけ」でやりますです。
とりあえず最初にapt-getしてくるのは
ntp
grub
kernel-image-2.4.x
language-env
kon2
emacs21
emacs21-el
ddskk
skkfep
w3m-ssl
lv
ruby
auto-apt
くらい。あとは、各パッケージのSuggestsを適宜追加。

話がズレるけど、自分のインストールCDだと、インストールの後に
# dpkg-reconfigure locales
しないと /etc/locale.* が生成されない。
ので、インストールする時にちょっとだけlocaleを気にしてみてください。


965 :login:Penguin:04/04/18 01:18 ID:omr4+PYP
emacs で M-x describe-function すると、
*Help* buffer に関数の comment と、その関数が定義されたファイル名が表示されます。
このファイル名の上にカーソルをおいて return すると、そのファイルの関数定義部分に
飛べるわけですが、
.elc と .el が同じ所にないとエラーになって飛べません。

例えば info など、emacs の標準ライブラリに入ってるもの(/usr/share/emacs/21.3/lisp/)は
飛べるけど、navi2ch は .elc と .el の場所が違うので、飛べません。

何かうまい解決策はないですか?

966 :login:Penguin:04/04/18 01:47 ID:S252HknC
navi2chスレで聞けばぁ?

967 :965:04/04/18 02:07 ID:omr4+PYP
いや navi2ch というか、wl でも skk でも同じです。
elisp のパッケージは .el と .elc を分けるという
debian のポリシーによるものだと思うんで、
ここで聞けば解決してる方がいるかなと思ったんです。

968 :login:Penguin:04/04/18 03:58 ID:vpxlLzFB
/usr/share/emacs/site-lisp 以下も load-path に入れとけば。


969 :965:04/04/18 04:32 ID:omr4+PYP
load-path に uncompiled files のディレクトリを入れるかどうかは
完全にパッケージによってますね。
emacs-goodies なんかは
/etc/emacs/site-start.d/50emacs-goodies-el.el に
;; Make sure that the uncompiled files are also in the load-path, near the
;; end. This is for moving point to the code when view help.
こんなのが書いてあって、ちゃんと入れてあります。
あとは自分で load-path 設定するしかなさそう。

970 :965:04/04/18 04:46 ID:omr4+PYP
結局こんなのを .emacs の最後に入れることにしました。
(let ((lisp-dirs (split-string
(shell-command-to-string
"find /usr/share/emacs/site-lisp -type d") "\n")))
(while (car lisp-dirs)
(if (not (member (car lisp-dirs) load-path))
(setq load-path (append load-path (list (car lisp-dirs)))))
(setq lisp-dirs (cdr lisp-dirs))))



971 :965:04/04/18 04:47 ID:omr4+PYP
結局こんなのを .emacs の最後に入れることにしました。

(let ((lisp-dirs (split-string
(shell-command-to-string
"find /usr/share/emacs/site-lisp -type d") "\n")))
(while (car lisp-dirs)
(if (not (member (car lisp-dirs) load-path))
(setq load-path (append load-path (list (car lisp-dirs)))))
(setq lisp-dirs (cdr lisp-dirs))))



972 :login:Penguin:04/04/18 07:48 ID:6Iar4vlT
>>961
私の場合後者でした。
1時間どころか丸一日ぐらい潰れてしまいそう。

>>962,964
必要最低限を目指すならそれでいいと思うんです。
でも自分的にあったほうが良いパッケージが結構RecommendedやSuggested
だったりするもんで…

ソフト単体なら追っかけてみようって気も起こるんですけどね。
大量のlibがついてきたりするともう。

結局まだauto-aptとssh関係ぐらいしか入れてません。げそ。

973 :login:Penguin:04/04/18 10:47 ID:oGlnQi6D
>>960
> パッケージの説明も読まずに入れまくってしまう厨から脱却しよう。

その考え方自体が厨なんじゃないの?
きっちりやるところ、Debianにお任せするところ、
メリハリつけてやった方が、浅くパッケージの説明読むだけよりいい。
いやどうしてもやりたいということなら、
こんなところでグスグス言ってる間に全てのパッケージを調べればいい。

974 :login:Penguin:04/04/18 10:56 ID:AiLMiP+7
エノヘ・ン・・キ。シ、ハ、、ニ。「ソヘ、ス、、セ、。「チネソ・、ス、、セ、、ハ、、タ、隍ヘ。」
ソ゚、ネ、ォソ゚、ク、网ハ、、、ネ、ォ、テ、ニイソケヘ、ィ、ニ、、、タ、、ヲ、ネサラ、ヲ。」

975 :login:Penguin:04/04/18 11:34 ID:weMrj7qU
>>374
まあ、そんな感じかも。

976 :login:Penguin:04/04/18 11:51 ID:jBByyy8M
もしかして依存関係の解消のために自動で追加されるやつまで全部解説を読んでる?
そりゃ時間の無駄だと思う。
そういうlibとかで読むのは依存関係のバッティングで
aptまかせだとうまく入れられない所だけですよ。

977 :login:Penguin:04/04/18 18:09 ID:3ghCElGZ
のべつまくなしに入れまくっても1GBは越えないよ。

978 :login:Penguin:04/04/18 20:00 ID:4pHFCKTx
Debian パッケージのperlって jperl じゃないようなんですが、
日本語の処理(例えば日本語のテキストファイルの処理)を
したい場合、みなさんどうされてますか?


979 :login:Penguin:04/04/18 20:35 ID:4VklMD3k
>>978
perl 5.8.3 で何ら不自由してないのだけれど
jperl でないと何が困るの?

980 :login:Penguin:04/04/18 20:46 ID:4pHFCKTx
>>979
例えば、print "ほげほげほ %s げほげほげほげほげ\n", $aaa;
とかすると、文字化け表示されませんか?


981 :login:Penguin:04/04/18 20:47 ID:4pHFCKTx
>>980
すみません。print -> printf です

982 :login:Penguin:04/04/18 21:19 ID:oGlnQi6D
perlのスレにいって、perl屋さんにちゃんと教えて貰いなさい。
perl 5.8はあなたよりずっと文字について詳しいです。

983 :login:Penguin:04/04/18 23:08 ID:jePeUTLC
次スレ

Debian GNU/Linux スレッド Ver. 23
http://pc3.2ch.net/test/read.cgi/linux/1082297069/

このスレッドを使い切り次第、移動して下さい。

984 :login:Penguin:04/04/18 23:22 ID:4VklMD3k
>>980
jperl でできることは全部 perl 5.8 でもできる。

ただし、jperl は日本語処理に特化して作られたものなのに対し
perl 5.8 は Unicode を(おおむね)全て扱えるように作られたものなので
同じことをやろうとしても、使い方はかなり違う。

>>980 の話は、たぶんスクリプトの文字コードと、変数の中に格納されているデータ
(たぶんファイルやDBから読み込んできたかCGIにPOSTされてきたものだろう)の文字コードと
出力の文字コードとが整合してないために起きたんだと推測するが、
何がどう違うかをちゃんと理解して、それを整合させるようにコードを書けば、問題無い。
jperl で使っていたスクリプトが無修正で 5.8.3 で動くわけではない。詳細は perl スレへ。

これからは perl 5.8 → 6 のパスが主流になるのは間違いなく
すでに役目を終えた jperl にしがみつくのも誉められた話じゃないだろう。

ただ、woody の perl は 5.6.1 なので、
sarge にした方がいいかもしれん、という気はちょっとだけする。

985 :login:Penguin:04/04/18 23:42 ID:oGlnQi6D
CGIならperlスレじゃなくて、
http://pc5.2ch.net/test/read.cgi/php/ の方がいいな。

986 :login:Penguin:04/04/18 23:57 ID:FJCYshji
gnomeと sawfishを組み合わせて使うにはどうしたらいいのでしょうか?
sargeで sawfish, sawfish-gnome は入ってるのですが、
gnome control center にウィンドウマネージャーを
選択するメニューがないようで。。。

987 :login:Penguin:04/04/19 00:33 ID:71lo7y++
# update-alternatives --config x-window-system
でsawfishに切り替えればいいんじゃね。
sawfishで使った事ないから合ってるかどうか知らんけど。

988 :login:Penguin:04/04/19 01:00 ID:brWoPCz3
>>986
設定するところなくなっちゃったみたいね。
$ pkill metacity # ←metacityはたぶん
$ sawfish
してlogoutすると覚えるよ。詳しくはGNOMEスレで。


989 :login:Penguin:04/04/19 01:01 ID:TRVyblqf
セッションを保存した場合は
update-alternatives --config x-window-manager
ではうまく行かなかったような気がするけど。
まあどうせkillall metacity && sawfishしてから
セッションを保存すればいいんだけどさ。


990 :login:Penguin:04/04/19 01:02 ID:5RMTo7F2
>>986
ウィンドウマネージャは何が起動しているんですか

991 :986:04/04/19 06:19 ID:TEwkRQFF
いろいろアドバイスありがとうございます。
結局、>>989のように
% killall metacity && sawfish &
として、metacityが再起動する前にうまく sawfishが起動してくれたらいけました。
なんか viewportとかの機能が(デフォルトでは)なくなってて、
しかもその件に関して gnomeスレ見たら大昔に話題になってるからタイムスリップした気分。

992 :login:Penguin:04/04/19 15:03 ID:jz/G+YYa
snd-pcm-ossをhotplugが呼んでくれないのかな
/etc/modutils/alsaにも/etc/modules.confにもちゃんと書かれているんだけど


993 :login:Penguin:04/04/19 16:29 ID:MWZcrkew
再設定してインストールしなおす方法を教えて下さい。

最初に
mysql - apache - php4
という順にapt-getで入れて、後でpostgresを使いたくなったのですが、
apt-get remove php4
apt-get install php4
とやってもphpinfoで確認すると--without-pgsql となっています。
dpkg--reconfigureもできません。

宜しくお願いします。

994 :login:Penguin:04/04/19 16:38 ID:zyegiA/x
>>993
php4-pgsql を入れて設定すればいいのでは。


995 :login:Penguin:04/04/19 16:52 ID:MWZcrkew
>>994
apt-get remove php4
apt-get install php4-pgsql
apt-get install php4
この状態でphpinfoを見ると、真っ白になったのでhttpd.confを確認すると
LoadModuleのphp4のところがコメントになってたので、それを外して、
apache リスタート。
そしてphpinfoを表示。
--without-pgsql
_| ̄|○

996 :login:Penguin:04/04/19 17:06 ID:D5R5DNTd
>>995
/etc/php4/apache/php.iniでextensionのとこ確認してみた?


997 :login:Penguin:04/04/19 17:46 ID:MWZcrkew
>>996
extension=pgsql.so
という項はありました。(コメントにはなっていません)

998 :login:Penguin:04/04/19 18:25 ID:gEU0j+Tl
ここのスレに出てくるBTSって何ですか?

999 :login:Penguin:04/04/19 18:35 ID:M6y6Et8W
>>998
http://debian.fam.cx/index.php?%CA%D8%CD%F8%A4%CA%A5%B5%A5%A4%A5%C8%BD%B8#content_1_4

1000 :login:Penguin:04/04/19 18:36 ID:M6y6Et8W
ついでに1000

1001 :1001:Over 1000 Thread
このスレッドは1000を超えました。
もう書けないので、新しいスレッドを立ててくださいです。。。

259 KB
★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.02.02 2014/06/23 Mango Mangüé ★
FOX ★ DSO(Dynamic Shared Object)